Did you try to clean your installed libraries? eo_ functions have been renamed 
to efl_.

On Thu, 22 Sep 2016 17:19:45 +0900
Shuhrat Dehkanov <k...@efir.uz> wrote:

> Hello,
> 
> Current the latest head (97a2d7ff33d9e8493427bf4eb4fdea4163808bf2) is
> failing on my end with the following error:
> 
> >   CCLD     bin/ecore_evas/ecore_evas_convert
> > /usr/local/lib/libecore_con.so.1: undefined reference to
> > `eo_manual_free_set' /usr/local/lib/libecore_con.so.1: undefined
> > reference to `_eo_add_end' /usr/local/lib/libecore_con.so.1:
> > undefined reference to
> > `_eo_call_end' /usr/local/lib/libecore_con.so.1: undefined
> > reference to `eo_isa' /usr/local/lib/libecore_con.so.1: undefined
> > reference to
> > `_eo_add_internal_start' /usr/local/lib/libecore_con.so.1:
> > undefined reference to
> > `_eo_call_resolve' /usr/local/lib/libecore_con.so.1: undefined
> > reference to `eo_class_new' /usr/local/lib/libecore_con.so.1:
> > undefined reference to
> > `_eo_init_generation' /usr/local/lib/libecore_con.so.1: undefined
> > reference to `eo_ref' /usr/local/lib/libecore_con.so.1: undefined
> > reference to `eo_data_scope_get' /usr/local/lib/libecore_con.so.1:
> > undefined reference to `eo_unref' /usr/local/lib/libecore_con.so.1:
> > undefined reference to
> > `eo_manual_free' /usr/local/lib/libecore_con.so.1: undefined
> > reference to
> > `_eo_class_creation_lock' /usr/local/lib/libecore_con.so.1:
> > undefined reference to
> > `_eo_api_op_id_get' /usr/local/lib/libecore_con.so.1: undefined
> > reference to `eo_super' collect2: error: ld returned 1 exit status
> > Makefile:25059: recipe for target
> > 'bin/ecore_evas/ecore_evas_convert' failed make[4]: ***
> > [bin/ecore_evas/ecore_evas_convert] Error 1 Makefile:50281: recipe
> > for target 'all-recursive' failed make[3]: *** [all-recursive]
> > Error 1 Makefile:16908: recipe for target 'all' failed make[2]: ***
> > [all] Error 2 Makefile:2958: recipe for target 'all-recursive'
> > failed make[1]: *** [all-recursive] Error 1 Makefile:2055: recipe
> > for target 'all' failed make: *** [all] Error 2  
> 
> All I did was
> 
> ./autogen.sh
> make
> 
> I tried cleaning everything locally, but no success.
> Am I missing something? Is it only me?
> 
> Thanks.
> 
> ------------------------------------------------------------------------------
> _______________________________________________
> enlightenment-devel mailing list
> enlightenment-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/enlightenment-devel
> 
> 


------------------------------------------------------------------------------
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to