On Thu, Sep 22, 2016 at 7:12 AM, Hermet Park <her...@hermet.pe.kr> wrote:
> Hi,  fellipe
>
> EFL is no more successful in building on my machine.
>
> Probably because of c++ version.
>
> Now bindings requres c++ 14 but not 11 ?
> If you intended this, then our configure should be updated also.

Hello Hermet,

std::aligned_union is a C++11 feature that was only implemented in
GCC 5.1. Are you using GCC 4.9? Which distro?

At https://phab.enlightenment.org/T4610 netstar has the same
problem in OpenBSD which is using GCC 4.9 (next version
will be > 6.0).

I had already commited with netstar to make a workaround so
the C++ bindings can be used in current version of OpenBSD,
which will also work for GCC 4.9 and likely some Ubuntu LTS
with old GCC version as well. I'll try to do that sometime this week.

[snip]

Regards,
-- 
Felipe Magno de Almeida

------------------------------------------------------------------------------
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to