I've been struggling with this for a while, and really can't figure
out the problem.

On my desktop, i have a few gadgets added through E's menu (Settings >
Gadgets). I've added the clock and the systray, and resized /
positioned them to my liking. They're near the top right of the
screen, but i've tried other positions as well. When E restarts,
(either by logging out, or using the Enlightenment > Restart menu
entry) the systray gadget appears in the top-left corner, extremely
small. If i've logged in again, the icons in it are one or two pixels
in size. If i simply restart E, the systray icons don't appear at all.
This makes it very difficult to right-click on the gadget to resize it
again, as there seems to be a single pixel sweet spot.

Now, if i delete the systray gadget, leaving only the clock, the same
happens to the clock when restarting. Although it's not quite as small
and the displayed time is almost legible. But it is tiny and moved
over to the top left of the screen. Wondering if it's a problem with
the last gadget added, i've tried adding more after the systray, but
it's always the systray the gets so drastically shrunk on restart.

Even weirder: seeing as both the clock and the systray exhibit similar
behaviour, i tried switching the order in which they're added. I added
the systray and resized it (it defaults to the previous one's size,
the tiny one in the top left corner). Then i add the clock, and as it
appears, the systray shrinks back to near nothing in size in the top
left corner. This is without restarting E!

I've tried all the appearance options for the systray (fixed,
horizontal, and vertical; plain and inset, though they look exactly
the same). I can't think of anything else to get a systray to stick,
without re-adding it every time i start E.

I'm running E 0.21.10 at the moment, but i've had this problem for a
long time, probably since 0.19 days. And every now and then, with some
versions, i get lucky and i don't have the problem. Although it's
quite likely by stumbling around adding/removing gadgets i
accidentally found a combination that worked. I've also completely
nuked the ~/.e directory a few times in case any stray, leftover
settings were to blame.

Any ideas if there's some E settings issue? Or perhaps a ./configure
flag i'm leaving out (or adding) when building E? Any more information
i can provide to track this down? Thanks anyone/all!

Shine like thunder
Cry like rain

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
enlightenment-users mailing list

Reply via email to