Public bug reported:

apt upgrade returns error with dependencies failing to upgrade samba. It
fails during starting /etc/init.d/smbd service with systemd. apt upgrade
prints the following error:

Job for smbd.service failed because the control process exited with error code. 
See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.

After that line the fail info about the packages which depend on the
samba being upgraded is apparently printed.


# systemctl status smbd.service
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Пн 2016-10-17 14:13:16 MSK; 55s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 32705 ExecStart=/etc/init.d/smbd start (code=exited, 
status=1/FAILURE)
#


# journalctl -xe   (translated some captions into English):
Oct 17 14:09:40 kartashev2 systemd[1]: Starting LSB: start Samba SMB/CIFS 
daemon (smbd)...
-- Subject: Начинается запуск юнита smbd.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Starting running unit smbd.service.
Oct 17 14:09:40 kartashev2 smbd[23272]:  * Starting SMB/CIFS daemon smbd
Oct 17 14:09:41 kartashev2 smbd[23272]:    ...fail!
Oct 17 14:09:41 kartashev2 systemd[1]: smbd.service: Control process exited, 
code=exited status=1
Oct 17 14:09:41 kartashev2 systemd[1]: Failed to start LSB: start Samba 
SMB/CIFS daemon (smbd).
-- Subject: Unit error smbd.service
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit failed smbd.service.
-- 
-- Result: failed.


# /usr/sbin/smbd -F -S
smbd version 4.3.11-Ubuntu started.
Copyright Andrew Tridgell and the Samba Team 1992-2015
WARNING: Ignoring invalid value 'share' for parameter 'security'
error opening config file '/etc/samba/smb.conf'


# lsb_release -rd
Description:    Ubuntu 16.04.1 LTS
Release:        16.04


# apt-cache policy samba
samba:
  Installed: 2:4.3.11+dfsg-0ubuntu0.16.04.1
  Candidate: 2:4.3.11+dfsg-0ubuntu0.16.04.1
  Version table:
 *** 2:4.3.11+dfsg-0ubuntu0.16.04.1 500
        500 http://ru.archive.ubuntu.com/ubuntu xenial-updates/main amd64 
Packages
        500 http://ru.archive.ubuntu.com/ubuntu xenial-security/main amd64 
Packages
        100 /var/lib/dpkg/status
     2:4.3.8+dfsg-0ubuntu1 500
        500 http://ru.archive.ubuntu.com/ubuntu xenial/main amd64 Packages


If 'security = share' is removed from smbd.conf then all runs fine.
Everything worked with previous version.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: samba 2:4.3.11+dfsg-0ubuntu0.16.04.1
ProcVersionSignature: Ubuntu 4.4.0-43.63-generic 4.4.21
Uname: Linux 4.4.0-43-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Thu Oct 13 21:13:20 2016
DpkgHistoryLog:
 Start-Date: 2016-10-13  21:13:18
 Commandline: apt-get install kpartx
 Requested-By: shmyak (1000)
 Install: kpartx:amd64 (0.5.0+git1.656f8865-5ubuntu2.2)
ErrorMessage: подпроцесс установлен сценарий post-installation возвратил код 
ошибки 1
InstallationDate: Installed on 2010-10-12 (2196 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
NmbdLog:
 Packet send failed to 10.0.3.255(138) ERRNO=Недопустимый аргумент
   Packet send failed to 10.0.3.255(138) ERRNO=Недопустимый аргумент
OtherFailedConnect: Yes
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1.1
 apt  1.2.12~ubuntu16.04.1
SambaServerRegression: Yes
SmbConfIncluded: Yes
SmbLog:
 
SourcePackage: samba
Title: package samba 2:4.3.11+dfsg-0ubuntu0.16.04.1 failed to install/upgrade: 
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
UpgradeStatus: Upgraded to xenial on 2016-08-19 (58 days ago)

** Affects: samba (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-package third-party-packages xenial

-- 
You received this bug notification because you are a member of Ubuntu
Server/Client Support Team, which is subscribed to samba in Ubuntu.
Matching subscriptions: Ubuntu Server/Client Support Team
https://bugs.launchpad.net/bugs/1634119

Title:
  package samba 2:4.3.11+dfsg-0ubuntu0.16.04.1 failed to upgrade due to
  invalid value 'share' for parameter 'security'

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1634119/+subscriptions

-- 
Mailing list: https://launchpad.net/~enterprise-support
Post to     : enterprise-support@lists.launchpad.net
Unsubscribe : https://launchpad.net/~enterprise-support
More help   : https://help.launchpad.net/ListHelp

Reply via email to