[EMAIL PROTECTED] wrote on 11/30/2007 08:08:22 AM: > Hi all, > > For the org.eclipse.equinox.util bundle: > https://bugs.eclipse.org/bugs/show_bug.cgi?id=206151 > I have some comments/questions. > > > 1. Can I change the name to the "org.eclipse.equinox.internal.util" > and kept here only the classes that are needed for more than one bundle?
There is no precedence for doing this in Eclipse. But it does make some sense to me. This would make it obvious that the whole bundle is really just an internal implementation detail. What do others think? > > 2. Still we will keep the bundle in the equinox distribution or we will > move the classes to the org.eclipse.equinox.common.jar in the future? For now I think we should make all the packages internal and use x-friends where appropriate for the other service bundles. In the future it is possible that we could move the packages to common and make them real API with no "internal" name in the package. But we will not do that unless the gain is substantial (i.e. needed by a large set of clients in the Eclipse community). > > Next week I will work on removing dependencies and some packages from > the util bundle but I need decision about the packaging and naming > prior finishing the work. > > > -Pavlin Thanks Pavlin. For now you should move the packages out of the equinox.util into other bundles where appropriate and rename the remaining packages to include "internal" in the name with x-friends for the bundles that need the package. A final decision on the symbolic name of the util bundle can be made after the package restructuring. Tom.
_______________________________________________ equinox-dev mailing list [email protected] https://dev.eclipse.org/mailman/listinfo/equinox-dev
