On 09/05/2010 08:31 PM, Maciej Stachowiak wrote:
The strawman has a note where I suggested matching "hashcode" with "identity" 
as the method name. If nothing else, the name length and lack of hackerly abbreviation recommend 
it. Comments?

I would expect a function named "identity" to be a function of one argument that returns it unmodified, 
rather than a two-argument predicate that implements an equivalence relation. "eq" seems like an ok name. 
"egal" will probably seem more mysterious than "eq".

Object.identical seems to imply the right things, certainly better than 
Object.identity.  To the extent I want to get involved in this paint job, I 
think this is the best shade I've considered.

Object.equals is reasonable, although as I assume people read (=)== as (strictly) equals, 
reusing the "equals" name seems like a mistake to me, if potentially one of 
small import (or not, I don't have much faith in my ability to predict this future, so 
would play it safe and avoid the name).

Object.eq, put bluntly, is obthcure.

Object.egal would just be confusing for ECMAScript.

Jeff
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to