On Thu, Dec 16, 2010 at 1:53 PM, David Herman <dher...@mozilla.com> wrote:
>
>    function Point(x, y) {
>        private x, y;
>        this.x = x;
>        this.y = y;
>        ...
>    }
>
> than
>
>    function Point(x, y) {
>        var _x = gensym(), _y = gensym();
>        this[_x] = x;
>        this[_y] = y;
>    }

I tend to disagree with most developers, so take it with a grain of
salt that I find the latter form, with all the implied abilities,
easier to understand.

Kris Kowal
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to