2011/10/7 Juan Ignacio Dopazo <[email protected]> > > On Fri, Oct 7, 2011 at 12:34 PM, Axel Rauschmayer <[email protected]> > wrote: > >> I would prefer the name Object.copyOwnPropertiesTo(source, target) or >> Object.copyOwnTo(source, target) to the name “extend” (which, to me, >> suggests inheritance). >> >> -- >> Dr. Axel Rauschmayer >> >> I also think Object.extend suggests inheritance. Other possibilities would > be: > > Object.merge() >
`Object.merge()' suggests a pure function though, which I don't think would be a bad thing at all.
_______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

