>> let obj = base beget {a: 1, b: 2}
>> let arr = base beget [p, q, r]
>> let fun = base beget function (...args) { ... }
>> let re = base beget /(\w+)\s+(\w)+/g
>>
>> It's still idiomatic as a name for differential inheritance, but it is more
>> pithy than 'make' or 'create' (and one character shorter than 'create' -- no
>> Unix 'creat' reruns! ;-). Comments?
>
> Of the various keywords that I been suggested for this operator, I think I
> like it the best. It is probably good that it is fairly unique and idiomatic.
>>
>> Saying or writing "triangle" does not convey meaning, and it's confusing in
>> geometry/graphics contexts.
>
> yes, my original suggest is that <| should be produced "prototype for"
One last idea, then I’ll stop my bikeshedding:
I think it helps if it reads well. For example:
const Employee = Person refinedBy { ... }
const Employee = Person subsuming { ... }
const Employee = Person parenting { ... }
const Employee = Person above { ... }
const Employee = Person before { ... }
The above examples are almost English (well, to programmers, anyway).
--
Dr. Axel Rauschmayer
[email protected]
home: rauschma.de
twitter: twitter.com/rauschma
blog: 2ality.com
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss