I’ve updated the gist with (most of) your suggestions and rationales for the
decisions.
> Minor quibbles
>
> get rid of
> [incAge]: ...
> just make it
> @incAge
>
> we don't need both [propname] and @propname in property declarations and
> @propname has a narrower meaning (which is good). Also, I don't want to
> unnecessarily couple object/class declaration syntax with [ ] semantics.
>
> You don't show other@foo but we need it. I would prefer it to be written as
> other.@foo
>
> You don't show it, but I would be fine with @foo as an abreavation for
> this@foo but if it is available we could probably get away with requiring
> this.@foo
>
> I know this will be controversial, but I would prefer only having the
> expression form. The reason is that
>
> let Monster = Being <| mylib.mixin(Evil, Scary) <| class {...}
>
> is an important usecase and it is harder to make the syntax work with a pure
> class declaration.
Fine with me, I don’t have any preference in this regard.
--
Dr. Axel Rauschmayer
[email protected]
home: rauschma.de
twitter: twitter.com/rauschma
blog: 2ality.com
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss