On Nov 16, 2011, at 8:19 AM, Russell Leggett wrote:
> On Wed, Nov 16, 2011 at 11:07 AM, Jake Verbaten <[email protected]> wrote:
> It's simply that
>
> var x = someProto beget { ... }
>
> reads nicer then
>
> var x = someProto extends { ... }
>
> I'd prefer to have readability on the non class related operator then the
> class related operator
>
> I was actually suggesting extends on the left - so
>
> var x = extends someProto { ... }
>
> Which reads better than someProto extends { ... }, because that reads as
> though {...} is the parent.
I think you cracked an important problem here. Someone on my blog commented
"why not infix extends" (my paraphrase) but with proto on the left that's
backwards. Putting proto on the right of infix 'extends' does not work well
because the object literal on the left can be large, making the extends and the
(generally shorter) proto expression hard to see. More to your point, that also
misaligns with
class C extends B {...}.
If we can get class as a unary operator right, or even if not due to <| looking
bad in too many common fonts, then your prefix binary 'extends' operator looks
winning to me. It's not perfect, but nothing is.
/be
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss