Allen Wirfs-Brock wrote:
On Feb 19, 2012, at 3:18 PM, Brendan Eich wrote:
Allen Wirfs-Brock wrote:
...
Your proposal would change that equivalence. In one sense, the BSR
would be a switch that controls whether a ES "character" corresponds
to "code unit" or a "code point"
Yes, and we might rather have a different word on that basis too.
How about "character element"? "Element" to capture indexing as the
means of accessing the thing in question.
I generally try to use "element" in informal contexts for exactly that
reason. However, shouldn't it be "string element" and we could let
"character" and "Unicode character" mean the same thing?
Yes, see my es-discuss+you followup -- should have measured twice and
cut once.
I like this much better than anything overloading "character".
To hope to make this sideshow beneficial to all the cc: list, what do
DOM specs use to talk about uint16 units vs. code points?
/be
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss