On Aug 1, 2012, at 3:53 PM, Mark S. Miller wrote: > On Wed, Aug 1, 2012 at 3:44 PM, Brendan Eich <[email protected]> wrote: >> [...] However in print, Name can work as well as Symbol or other terms. > > > If we call the category of things that Object.getOwnPropertyNames does > not return "Name"s, ... > > It is too late to rename getOwnPropertyNames.
That's been bothering me too. I think it's good you brought this up. As long as we come up with a reasonable new term, it's probably best for us to alpha-rename the spec-internal concept of "a thing that can be used as the key of an object property", and stick with "name" and "key" as user-facing terminology for "a string that is used as the key of an object property." Dave _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

