The @iterator part of the iteration protocol is not about coercion or
types at all. It is a "pattern" for getting or creating a usable
iterator from an object.
In this light, ToIterator is the wrong name. GetIterator (see C#) is better.
/be
Allen Wirfs-Brock wrote:
Personally, I don't really think about what is going on here as a type
coercion but I have no problem if you what to explain it as applying
ToIterator. It may even be useful to use this in the spec.
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss