That’s very sad, because they’re wrong, not “wrong”.

Norbert


> On Jul 20, 2015, at 23:29 , Domenic Denicola <d...@domenic.me> wrote:
> 
> They're already shipping with the "wrong" names in every browser. 
> 
>  
> 
> From: Norbert Lindenberg <ecmascr...@lindenbergsoftware.com>
> Sent: Jul 20, 2015 23:25
> To: Dmitry Soshnikov
> Cc: Norbert Lindenberg; Domenic Denicola; es-discuss
> Subject: Re: String.prototype.trimRight/trimLeft
> 
> These methods should be called trimStart and trimEnd. Determining which parts 
> of the string are left and right would require running the Unicode 
> Bidirectional Algorithm, and that’s probably not intended here. 
> 
> Norbert 
> 
> 
> > On Jul 20, 2015, at 15:09 , Dmitry Soshnikov <dmitry.soshni...@gmail.com> 
> > wrote: 
> > 
> > Will somebody be so kind to present this on the following meeting for me, I 
> > don't have an ability to attend, and the change is pretty small (July 28th, 
> > 2015)? 
> > 
> > People were asking, and we'd like to polyfill it instead of doing regexp 
> > replaces. Again the spec is here: 
> > https://gist.github.com/DmitrySoshnikov/65a2070477fffb465048 
> > 
> > Thanks! 
> > 
> > Dmitry 
> > 
> > On Wed, Mar 18, 2015 at 2:26 PM, Dmitry Soshnikov 
> > <dmitry.soshni...@gmail.com> wrote: 
> > OK, the spec is here: 
> > https://gist.github.com/DmitrySoshnikov/65a2070477fffb465048 Will 
> > appreciate review and corrections if needed. 
> > 
> > Dmitry 
> > 
> > On Tue, Mar 17, 2015 at 7:36 PM, Dmitry Soshnikov 
> > <dmitry.soshni...@gmail.com> wrote: 
> > Sounds good. Yeah, I'll spec it, and add the test. 
> > 
> > Dmitry 
> > 
> > 
> > On Tuesday, March 17, 2015, Domenic Denicola <d...@domenic.me> wrote: 
> > Yeah, this seems like a shoe-in for ES7. It will probably be able to 
> > advance through the stages very quickly given that it already has three 
> > (four?) shipping implementations. 
> > 
> >  
> > 
> > Someone just needs to write up a formal spec (using Ecmarkdown! ^_^) and 
> > test262 tests. The only snag would be if you find non-interoperable 
> > behavior between browsers in the course of writing those tests, and need to 
> > get some patches accepted before you can reach stage 4. 
> > 
> >  
> > 
> > From: es-discuss [mailto:es-discuss-boun...@mozilla.org] On Behalf Of 
> > Dmitry Soshnikov 
> > Sent: Wednesday, March 18, 2015 05:02 
> > To: Tab Atkins Jr. 
> > Cc: es-discuss 
> > Subject: Re: String.prototype.trimRight/trimLeft 
> > 
> >  
> > 
> > Right, so from the several feedback I had so far, it seems it will make 
> > sense just to add to ES7? In this case we'll be able to polyfill now, the 
> > spec'ing it will be trivial (I'll add the spec). 
> > 
> >  
> > 
> > I guess we just need to confirm it's good to go to ES7? 
> > 
> >  
> > 
> > Dmitry 
> > 
> >  
> > 
> > On Tue, Mar 17, 2015 at 12:21 PM, Tab Atkins Jr. <jackalm...@gmail.com> 
> > wrote: 
> > 
> > On Mon, Mar 16, 2015 at 11:07 PM, Leon Arnott <leonarn...@gmail.com> wrote: 
> > > I believe opinion hasn't shifted since it was discussed 
> > > [previously](https://esdiscuss.org/topic/standardizing-more-de-facto-functions)
> > >  
> > > - in short, "show me the cowpath". (But, I've just learned that the IE 
> > > Technical Preview now supports trimLeft/trimRight, so there'll soon be 
> > > support for it in all the major engines. Maybe the cows are there after 
> > > all.) 
> > 
> > I use both lstrip() and rstrip() in Bikeshed (a Python project): 
> > 
> > https://github.com/tabatkins/bikeshed/search?utf8=%E2%9C%93&q=lstrip&type=Code
> >  
> > https://github.com/tabatkins/bikeshed/search?utf8=%E2%9C%93&q=rstrip&type=Code
> >  
> > 
> > In particular, lstrip() is used when I'm separating a key and value; I 
> > don't want to mess with the value much at all, just pull off the 
> > whitespace at the start.  rstrip() is used when I know I don't need to 
> > strip from the left side, because I'm just pulling off newlines or 
> > something, so might as well let the program avoid even trying. 
> > 
> > ~TJ 
> > 
> >  
> > 
> > 
> > 
> > _______________________________________________ 
> > es-discuss mailing list 
> > es-discuss@mozilla.org 
> > https://mail.mozilla.org/listinfo/es-discuss
> 

_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to