I think it would be super useful to be able to do something like:

Promise.after(1000).then( /* cb */ );

and have the promise resolve after 1000 milliseconds.

The promise would just resolve with the same value (in this case 1000) but
could easily delay resolving another value like so:

Promise.after(1000).then(() => "other value");

instead of currently having to use a setTimeout:

new Promise(resolve => setTimeout(() => resolve("some value"), 1000));

I believe Promise.after would be so much more readable and useful.

I am not sure if the name `after` is the best name, `wait`, `when`, `sleep`
are possible names or maybe there is a better name I haven't even thought
of.
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to