By the way it looks very similar to  [s-ctypes/StructType](
https://developer.mozilla.org/en-US/docs/Mozilla/js-ctypes/js-ctypes_reference/StructType#Describing_fields)
Although it designed for interoperability with native code (not for code
performance improvement, or better code readability), it still might be
interesting for you (more links can be found at [wiki/Libffi/JavaScript](
https://en.wikipedia.org/wiki/Libffi#JavaScript) )
_______________________________________________
es-discuss mailing list
[email protected]
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to