On Sat, Aug 5, 2017 at 10:13 AM, Naveen Chawla
> I would be comfortable with `module.import()` and `module.meta`
> instead of `import()` and `import.meta`, simply because the name
> `module` more automatically describes the module specific "global"
> object than `import` does.
If `module` were used, it would have to be an identifier (like `Symbol` and
`Reflect`), not a keyword; we can't break existing code using `module` as
an identifier. And like `Symbol` and `Reflect`, codebases that use it for
something else would have to adjust if they want to use the new thing. (If
they don't need to use the new thing, they're fine, they just shadow it.)
If it's an identifier, it contains a value; that value can be assigned to
other variables, passed into functions, etc. I'm not steeped enough in the
proposal to know whether that's a problem; I suspect it is. But I thought
I'd note it.
-- T.J. Crowder
es-discuss mailing list