On Wed, Feb 28, 2018 at 4:00 AM, <es-discuss-requ...@mozilla.org> wrote:

> From: Mike Samuel <mikesam...@gmail.com>I'm looking for other criticism
> of https://github.com/mikesamuel/tc39-module-keys and for interested
> parties who might have time to refine it.

I'm just taking a bit of time to read over it.  Keep in mind, I'm no
security expert.

In the spec, you write,

> We use the name frenemies below. This is a terrible name.

I suggest "counterparties".

What's a Box?  (I'm serious.  You really don't define what it is in this
context.)  You also talk about boxed values and unboxed values, but I may
have missed the paragraphs explaining the difference.

In your example code sections, you imply these properties are directly
named as properties of alice and bob, respectively... do we want all of
those as such, or maybe under a namespace
(alice[someNameOrSymbol].publicKey)?  Particularly with such generic names
as box and unbox...
I'd feel more comfortable if they were under a predefined
Symbol.MODULE_KEYS namespace.

That's my two cents - and they're worth exactly that much after inflation.


"The first step in confirming there is a bug in someone else's work is
confirming there are no bugs in your own."
-- Alexander J. Vincent, June 30, 2001
es-discuss mailing list

Reply via email to