Hi ESS users,

I'm using Vincent Goulet's modified Emacs 27.1 for Windows, with ESS
18.10.2, on a Windows 10 computer.

I'm having trouble installing the latest ESS from MELPA. I don't
normally install things from MELPA (I usually use MELPA Stable), and
as far as I can remember, I haven't installed ESS from MELPA before,
except for these recent attempts.

I did M-x package-list-packages, then went down the list to ess, then
pressed i, then pressed x.

The installation process seemed to get "stuck" with the message
"Checking c:/Users/marks/.emacs.d/elpa/ess-20210210.1202..." being
displayed. After 15 minutes, I stopped the installation process using
C-g. In the list of packages, it now says ess 20210210.1202 has Status
"installed", but I don't know if it's installed correctly.

The directory C:\Users\marks\.emacs.d\elpa\ess-20210210.1202 contains
only 48 items, whereas C:\Users\marks\.emacs.d\elpa\ess-18.10.2
contains 134 items.

I restarted Emacs, and when I start R, there is a message "Symbol’s
function definition is void: ess-local-process-name", which I don't
usually get. When I do C-h v ess-version, it says "18.10.3snapshot".

When I send a command from a .R file to the R console buffer, the
command is sent successfully, but there is a message "Error running
timer ‘ess--idle-timer-function’: (void-function
ess-local-process-name)", which I don't usually get.

I tried deleting the C:\Users\marks\.emacs.d\elpa\ess-20210210.1202
directory and installing ESS again, but the same thing happened. I had
also tried installing ESS from MELPA about a week ago, and had the
same problem.

For comparison, I installed packages 0blayout and 2048-game from MELPA
using M-x package-list-packages i x, and they both finished
successfully within about one second, with message "Operation
finished.  Packages that are no longer needed: 7.  Type `M-x
package-autoremove' to remove them".

My first question is, does having only 48 items in
C:\Users\marks\.emacs.d\elpa\ess-20210210.1202 compared to 134 items
in C:\Users\marks\.emacs.d\elpa\ess-18.10.2 indicate that the new ess
did not install correctly?

If the new ess is not correctly installed, what can I do to
troubleshoot the installation process? Should the installation take
more than 15 minutes?

If the new ess is correctly installed, how can I avoid getting the
error messages "Symbol’s function definition is void:
ess-local-process-name" and "Error running timer
‘ess--idle-timer-function’: (void-function ess-local-process-name)"?


Mark Seeto

ESS-help@r-project.org mailing list

Reply via email to