Greetings all,

What configure arguments do I use to build evolution so that the following 
portability warnings don't appear:

mv -f .deps/calendar-weather.Tpo .deps/calendar-weather.Plo
/usr/bin/libtool --tag=CC   --mode=link gcc  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC -DLDAP_DEPRECATED
-I/usr/include/et -Wno-sign-compare        -DG_DISABLE_DEPRECATED=1
-DPANGO_DISABLE_DEPRECATED=1   -DGDK_PIXBUF_DISABLE_DEPRECATED=1
-DGDK_DISABLE_DEPRECATED=1      -DEDS_DISABLE_DEPRECATED=1
-Wdeclaration-after-statement   -Werror-implicit-function-declaration
-UGNOME_DISABLE_DEPRECATED -fno-strict-aliasing -module -avoid-version
-o liborg-gnome-calendar-weather.la
-rpath /usr/lib64/evolution/2.22/plugins
calendar-weather.lo ../../calendar/gui/libevolution-calendar.la -pthread
-lgtkhtml-3.14 -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2
-lgnomecanvas-2 -lart_lgpl_2 -lecal-1.2 -ledataserverui-1.2 -lglade-2.0
-lebook-1.2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0
-lpangocairo-1.0 -lpango-1.0 -lcairo -lgnome-2 -lpopt -ledataserver-1.2
-lxml2 -lgconf-2 -lbonobo-2 -lbonobo-activation -lgmodule-2.0 -ldl
-lORBit-2 -lgthread-2.0 -lrt -lgobject-2.0 -lglib-2.0

*** Warning: Linking the shared library liborg-gnome-calendar-weather.la
against the loadable module
*** libevolution-calendar.so is not portable!


Thanks,
Gary Ilijevich

_________________________________________________________________
Reveal your inner athlete and share it with friends on Windows Live.
http://revealyourinnerathlete.windowslive.com?locale=en-us&ocid=TXT_TAGLM_WLYIA_whichathlete_us
_______________________________________________
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to