On Sun, 2009-10-18 at 17:30 -0400, Paul Smith wrote:
> Hi all.  I've been updating my Evo Makefile to build the latest 2.28
> version of evolution.
> 
> When I try to connect to my exchange 2007 server using MAPI, it asks for
> my password but then says that the login failed.  It seems to work to
> some extent, though, because I see my folders etc.
> 
> Looking at the log file I see these errors:
> 
> ../../../../evolution-mapi/src/libexchangemapi/exchange-mapi-connection.c:2856:
>  Leaving exchange_mapi_get_folders_list libexchangemapi-Message: 
> ../../../../evolution-mapi/src/libexchangemapi/exchange-mapi-folder.c:139: 
> exchange_mapi_peek_folder_list: unlock(folder_lock)
> libexchangemapi-Message: 
> ../../../../evolution-mapi/src/libexchangemapi/exchange-mapi-connection.c:3106:
>  exchange_mapi_create_profile: unlock(connect_lock)
> libexchangemapi-Message: 
> ../../../../evolution-mapi/src/libexchangemapi/exchange-mapi-folder.c:134: 
> exchange_mapi_peek_folder_list: lock(folder_lock)
> libexchangemapi-Message: 
> ../../../../evolution-mapi/src/libexchangemapi/exchange-mapi-folder.c:139: 
> exchange_mapi_peek_folder_list: unlock(folder_lock)
> e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring 
> reports: No matching results)
> e-data-server-ui-Message: Key file does not have group 
> 'Passwords-ExchangeMAPI'
> 
> Anyone have any idea what need to be done to get the right group in the
> keyring, or if this is indeed even the right error message?

I built a brand new version using my makefile and tried again, and got
this same error again.

After I got this in the log file, I got a new dialog asking me to
re-enter my password:

        Unable to authenticate to Exchange MAPI server.  Please enter
        the MAPI password for psm...@....

I re-entered my password (I was leery of this because the other day I
locked my account by Evo asking for my password too many times in a row)
but the second time it took and worked.

It doesn't seem anyone has any ideas what this problem might be?  Which
"Key file" are they talking about here, and who is supposed to create
the group "Passwords-ExchangeMAPI"?

Note I had checked the "remember this password" box.  I haven't tried
restarting Evo to see if I have to retype it again.

_______________________________________________
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to