On Do, 2011-04-28 at 13:07 -0400, Matthew Barnes wrote:
> It hadn't occurred to me the word "calendar" might be ambiguous.  I
> blame the iCalendar spec for overloading it.  In the real world, one
> does not make a "calendar of tasks", one makes a "list of tasks".

But tasks are shown on calendars because they have deadlines. It depends
whether you see a calendar as a container of something or a tool to work
with date-dependent items.

> Maybe this is too Evolution-centric, but to me the container/item
> relationship is clear:
>    an ADDRESS_BOOK  contains  CONTACTS
>     a CALENDAR      contains  EVENTS
>     a TASK_LIST     contains  TASKS / TODOS
>     a MEMO_LIST     contains  MEMOS / JOURNALS
>     a MAIL_STORE    contains  MESSAGES
> The enum values should be named consistently.  So if we change CALENDAR
> to EVENTS, I think we should change the rest.
> FWIW, the new ESource API is already using container names.  Key files
> will have groups named [Address Book], [Calendar], [Task List], etc.
> instead of [Contacts], [Events], [Tasks], etc.
> To me it sounds more natural to refer to containers than items, but
> maybe I'm too indoctrinated in Evolution-speak.

Perhaps it is really to ingrained into Evolution already to change it.
Never mind, I'll cope with it either way ;-)

Bye, Patrick Ohly

evolution-hackers mailing list
To change your list options or unsubscribe, visit ...

Reply via email to