Milan Crha wrote:
> 
> On Sun, 2011-05-15 at 22:39 -0700, tudstudent wrote:
>> ...
>> When compiling evolution-mapi-3.1.1 I get stuck with the following error:
>> ...
>> exchange-mapi-connection.c: In function
>> 'exchange_mapi_util_get_attachments':
>> exchange-mapi-connection.c:1272:5: warning: passing argument 2 of
>> 'cast_SPropValue' from incompatible pointer type
>> /usr/include/libmapi/libmapi.h:262:11: note: expected 'struct
>> mapi_SPropValue *' but argument is of type 'struct SPropValue *'
>> exchange-mapi-connection.c:1272:5: error: too few arguments to function
>> 'cast_SPropValue'
>> /usr/include/libmapi/libmapi.h:262:11: note: declared here
>> ...
>> The file libmapi.h is present and is from the latest openchange (0.10).
> 
>       Hi,
> is it possible you've installed two different libmapi.h or openchange
> versions, thus the configure part was done against a different
> openchange version? The 3.1.x, same as 3.0.x and couple versions before,
> has conditional compilations for detecting when to use what, and this
> API change is part of this detection. Could you check what has your
> config.h and config.log in the evo-mapi build directory and what
> signature the cast_SPropValue function of libmapi.h is, please?
>       Bye,
>       Milan
> 
> _______________________________________________
> evolution-hackers mailing list
> evolution-hackers@gnome.org
> To change your list options or unsubscribe, visit ...
> http://mail.gnome.org/mailman/listinfo/evolution-hackers
> 
> 

When I check for multiple versions of libmapi:

<code>
locate libmapi.h
/usr/include/libmapi/libmapi.h
</code>

So I have only 1 libmapi.h installed on my system. Furthermore I have looked
into libmapi.h:

uint32_t                cast_SPropValue(TALLOC_CTX *, struct mapi_SPropValue
*, struct SPropValue *);

I hope I give you correct information. I did not understand what you wanted
to have so I tried my best.
What do you want with config.log and the other (better said what do I need
to check specificly).
-- 
View this message in context: 
http://old.nabble.com/Compile-Evolution-Mapi-3.1.1--%3E-Error-on-libmapi.h-tp31626288p31626473.html
Sent from the Gnome - Evolution - Dev mailing list archive at Nabble.com.

_______________________________________________
evolution-hackers mailing list
evolution-hackers@gnome.org
To change your list options or unsubscribe, visit ...
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to