Robert W. wrote:
> I am trying (still) to get a Belkin F5D6020 wireless adapter to work
> under Linux. PCMCIA recognizes the card when I plug it in. Using the
> "prism2_cs" driver, 'ifconfig -a' shows a wlan0 device, with no HWaddr
> or IP address. Running "ifup wlan0" reports the error 'SIOCSIFFLAGS: No
> such device'. Am I using the wrong driver? Missing an option? Something
> else entirely?
> What I've tried:
> (1) Using the "orinoco_cs" driver. No network devices ever appear for
> 'ifconfig -a'.
> (2) 'ip link set wlan0 up' returns the same error message as 'ifup
> wlan0'.
> (3) Added 'alias wlan0 prism2_cs' to /etc/modules.config. It had no
> discernible effect.
> (4) Calls to iwconfig fail, saying there is no device wlan0.
> (5) Google for "SCIOCSIFFLAGS prosm2_cs" and "SCIOCSIFFLAGS belkin"
> turned up no useful information.
> (6) 'lsmod' reports that prism2_cs is loaded.
> Hardware:
> Toshiba Libretto 50CT
> Belkin F5D6020 wireless PCMCIA (not CardBus) adapter

I had my own problems with a netgear wireless pcmcia on my sony vaio.
in my case the module that was loaded automatically was the orinoco_cs

this is how I eventually solved the problem :

1) I removed the "acpi=off" parameter from my LILO config (I suggest that  you
add an experimental LILO config ...)

2) using the TEXT based linuxconf tool, there I found I could specify module
(orinoco_cs) and IRQ for the eth1 adapter (I entered the IRQ in use when using

now both eth0 and eth1 are avaialble at boot time and I'm happy with my Mdk9.1



Want to buy your Pack or Services from MandrakeSoft? 
Go to

Reply via email to