Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: uuid


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192564





------- Additional Comments From [EMAIL PROTECTED]  2006-05-23 18:32 EST -------
(In reply to comment #3)
> As for rpath, my understanding is that we should do what we can to eliminate 
> it
> but that if it's simply not possible then it won't keep the package out.  But
> after patching the spec as I suggested I see no trace of rpath.  That 
> technique
> has worked for me in the past.

Weird.  I just tried it again, and it works this time.  I must have changed the
wrong make line or something.

> About the unstripped libraries, it looks like they aren't executable, so they
> don't get stripped.  I've seen this in the past, and a chmod 755 has fixed it
> up, but while looking through /usr/lib/rpm/redhat/brp-strip* I saw this:
> 
> # Strip ELF shared objects
> # Please note we don't restrict our search to executable files because
> # our libraries are not (should not be, at least) +x.

That's interesting.  Just about everything else in my /usr/lib64 is executable.
 And, sure enough, adding in a chmod gets rid of that rpmlint warning.

Try -3, please.

-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

_______________________________________________
Fedora-package-review mailing list
Fedora-package-review@redhat.com
http://www.redhat.com/mailman/listinfo/fedora-package-review

Reply via email to