On 25/02/15 11:55 AM, Paul B Mahol wrote:
> +static inline void line_copy8(uint8_t *line, const uint8_t *srcp, int width, 
> int mergin)

Unless I'm missing something, "mergin" seems to always be 1.
The code below could be simplified.

> +{
> +    memcpy(line, srcp, width);
> +
> +    for (int i = mergin; i > 0; i--) {
> +        line[-i] = line[i];
> +        line[width - 1 + i] = line[width - 1 - i];
> +    }
> +}

_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to