On 9/19/2022 2:57 PM, Rémi Denis-Courmont wrote:
+void checkasm_check_vorbisdsp(void)
+{
+    VorbisDSPContext dsp;
+
+    ff_vorbisdsp_init(&dsp);
+
+    if (check_func(dsp.vorbis_inverse_coupling, "vorbis_inverse_coupling"))
+        test_inverse_coupling();
+    report("vorbis_inverse_coupling");

Should these not be just "inverse_coupling" seen as there is already a
"vorbisdsp" prefix in the logs?

It can, if anything so the relevant line is shorter when the report is printed. Changed locally.

I just went and used the name of the function pointer as it's in VorbisDSPContext. A name that could be changed too, for that matter.


Other than that, this is very much welcome for me.

+}
diff --git a/tests/fate/checkasm.mak b/tests/fate/checkasm.mak
index 4d2f321e84..fbba0b5b8f 100644
--- a/tests/fate/checkasm.mak
+++ b/tests/fate/checkasm.mak
@@ -43,6 +43,7 @@ FATE_CHECKASM = fate-checkasm-aacpsdsp
              \ fate-checkasm-vf_nlmeans                                \
fate-checkasm-vf_threshold                              \
fate-checkasm-videodsp                                  \ +
fate-checkasm-vorbisdsp                                 \
fate-checkasm-vp8dsp                                    \
fate-checkasm-vp9dsp                                    \


_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to