On 1/22/2019 2:17 PM, Vittorio Giovara wrote:
> On Mon, Jan 21, 2019 at 2:15 PM FeRD <ferd...@gmail.com> wrote:
>> On Mon, Jan 21, 2019 at 1:55 PM Moritz Barsnick <barsn...@gmx.net> wrote:
>>> On Mon, Jan 21, 2019 at 12:38:58 -0500, FeRD (Frank Dana) wrote:
>>>> After applying both patches, 'make fate' succeeds and ffmpeg is still
>>>> functional.
>>> You're not allowed to break fate (or compilation). So the two pathes
>>> need to be merged.
>> Aha, thanks. I'll resubmit squashed into a single patch.
> maybe it would be a good opportunity to expose the symbol publicly, and
> prefix it with AV_ instead of FF_, like it was done for AV_CEIL_RSHIFT
> (21f946840260da150affd9a20cc35b3d56194ba6)

That's not a good example seeing FF_CEIL_RSHIFT is still defined for
backwards compatibility. The idea here is to remove RSHIFT altogether.

I'm not against renaming it to AV_ROUNDED_RSHIFT or similar, but other
than an entry in APIChanges we have no way to let library users that
RSHIFT will be removed two or so years from now.
ffmpeg-devel mailing list

Reply via email to