On Wed, Oct 09, 2019 at 11:56:42 +0200, Paul B Mahol wrote:
> --- a/libavfilter/af_anlms.c
> +++ b/libavfilter/af_anlms.c
> @@ -60,13 +60,14 @@ typedef struct AudioNLMSContext {
>
>  #define OFFSET(x) offsetof(AudioNLMSContext, x)
>  #define A AV_OPT_FLAG_AUDIO_PARAM|AV_OPT_FLAG_FILTERING_PARAM
> +#define C AV_OPT_FLAG_COMMAND_PARAM

Perhaps, like in other filters, #define "AF" and "AFC"?

> +    { "mu",      "set the filter mu",      OFFSET(mu),      
> AV_OPT_TYPE_FLOAT, {.dbl=0.75}, 0, 1, A|C },

Avoids OR-ing to an already OR-ed value. (Readability only.)

Moritz
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to