#5892: Show Qavg -nan when end of aac stream
             Reporter:               |                    Owner:
  chengmo03013106                    |                   Status:  new
                 Type:  defect       |                Component:
             Priority:  normal       |  undetermined
              Version:  unspecified  |               Resolution:
             Keywords:  aac          |               Blocked By:
             Blocking:               |  Reproduced by developer:  1
Analyzed by developer:  1            |

Comment (by chengmo03013106):

 Replying to [comment:1 cehoyos]:
 > I don't really understand your issue (do you think what is printed is
 wrong or unclear?) but in any case, please provide the command line that
 allows to reproduce the issue together with the complete, uncut console
 output to make this a valid ticket.

 Thank you for the replying.
 I am sorry for my confusing issue.
 the printed is vivid that "Qavg -nan".
 I meant that there is bug in  libavcodec/aacenc.c, line:846 "av_log(avctx,
 AV_LOG_INFO, "Qavg: %.3f\n", s->lambda_sum / s->lambda_count);".
 s->lambda_count was 0 in some time, could "s->lambda_count" be 0 ? same as
 a/b, b should not be 0, is that right ?

 Anyway the details I gave unclearly.
 I didn't run the command "ffmpeg balabala..."
 I invoked the API directly in my codes.

 The backtrace show this:
 (gdb) bt
 #0  aac_encode_end (avctx=0x7fc68c045ac0) at libavcodec/aacenc.c:844
 #1  0x0000000000b3254a in avcodec_close (avctx=0x7fc68c045ac0) at
 #2  0x000000000041238b in OutputProc::Close (this=0x273a600) at
 #3  0x00000000004156a0 in ConvertdProcess::CloseClear (this=0x273a4a0) at

 at mediaproc.cpp:1162 is

 Is there enough for the issue ? If I should show more details about the
 issue, tell me
 Thanks again.

Ticket URL: <https://trac.ffmpeg.org/ticket/5892#comment:2>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker
FFmpeg-trac mailing list

Reply via email to