#5985: error decoding h264 stream with h264_cuvid in udp mpegts
-------------------------------------+-------------------------------------
             Reporter:  doubleb      |                    Owner:
                 Type:  defect       |                   Status:  new
             Priority:  normal       |                Component:
              Version:  unspecified  |  undetermined
             Keywords:               |               Resolution:
             Blocking:               |               Blocked By:
Analyzed by developer:  0            |  Reproduced by developer:  0
-------------------------------------+-------------------------------------

Comment (by doubleb):

 capture: I mean without transcodng:

 ./ffmpeg_g -report -v 9 -loglevel 99 -y -f mpegts -i
 
"udp://239.100.1.101:1001?buffer_size=2000000&fifo_size=2000000&overrun_nonfatal=0"
 -map "0:#0x9c4" -map "0:#0x9c5" -vcodec copy -acodec copy /tmp/bbcopy.mp4

 and after it transcoding:

 ./ffmpeg_g -report -v 9 -loglevel 99 -y -vcodec h264_cuvid -f mpegts -i
 /tmp/bbcopy.mp4 -vcodec libx264 -preset fast -s 640x360 -g 25 -vb 800k
 -bufsize 3000k -r 25 -maxrate 1200k -profile:v high -level 4.0 -pix_fmt
 yuv420p -acodec libfdk_aac -cutoff 20000 -ac 2 -ar 44100 -ab 192k
 /tmp/bbout.mp4

 it works as expected.

 But I need on-the-fly transcoding.

 I will test with current git very soon.

--
Ticket URL: <https://trac.ffmpeg.org/ticket/5985#comment:2>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker
_______________________________________________
FFmpeg-trac mailing list
FFmpeg-trac@avcodec.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-trac

Reply via email to