#6999: Filter "aphasemeter" not working in latest FFmpeg version
-------------------------------------+-------------------------------------
             Reporter:  BlackScreen  |                    Owner:
                 Type:  defect       |                   Status:  closed
             Priority:  important    |                Component:  avfilter
              Version:  git-master   |               Resolution:  wontfix
             Keywords:  aphasemeter  |               Blocked By:
  regression                         |  Reproduced by developer:  0
             Blocking:               |
Analyzed by developer:  0            |
-------------------------------------+-------------------------------------

Comment (by BlackScreen):

 Replying to [comment:5 MReedAustin]:
 > aphasemeter outputs the audio received (with metadata injection) on its
 first output pad, and the generated video on the second, so in your case
 you were attempting to map the audio output into the video of your output
 file. The modified command below should work for you, I believe.
 >
 > {{{
 > ffmpeg -hide_banner -i "Test.wav" -filter_complex "[0:a]
 aphasemeter=s=hd720:rate=50:mpc=cyan, format=yuv420p [a][v]" -map "[v]"
 -map [a] -r 50 -vcodec libx264 -s 1280x720 -pix_fmt yuv420p -preset slow
 -crf 20 -profile:v main -level 4.0 -acodec aac -ab 192k -ac 2
 "Test_Phase.mp4"
 > }}}
 I tried your solution, but it does not work either. I tried it with quotes
 for "[a]", but I get more or less the same error. See here:
 {{{
 [Parsed_aphasemeter_0 @ 000000000016cd40] Media type mismatch between the
 'Parsed_aphasemeter_0' filter output pad 0 (audio) and the
 'Parsed_format_1' filter input pad 0 (video)
 [AVFilterGraph @ 0000000000170bc0] Cannot create the link aphasemeter:0 ->
 format:0
 Error initializing complex filters.
 Invalid argument
 }}}

--
Ticket URL: <https://trac.ffmpeg.org/ticket/6999#comment:6>
FFmpeg <https://ffmpeg.org>
FFmpeg issue tracker
_______________________________________________
FFmpeg-trac mailing list
FFmpeg-trac@avcodec.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-trac

Reply via email to