Hi Ravi,

On Wed, May 16, 2018 at 11:44:06 +0530, Ravi Kumar wrote:
> After trying above command with different scenarios we are getting 
> following errors.
[...]
> #2)Unrecognized option 
> 'filter_complex\[0]scale=512:-2,pad=512:768:(ow-iw)/2:(oh-ih)/2[vs0],color=black:size=512x768:duration=2.716[b0],[b0][vs0]concat[r0c0];\[1]scale=512:-2,pa=512:768:(ow-iw)/2:(oh-ih)/2[vs1],color=black:size=512x768:duration=0[b1],[b1][vs1]concat[r0c1];\[r0c0][r0c1]hstack=inputs=2[video];\[2]aresample=async=1,adelay=2743.0|2743.0[a0];[3]aresample=async=1,adelay=5.0|5.0[a1];\[a0][a1]amix=inputs=2[audio]-map[video]-map[audio]-acodec'.
> Error splitting the argument list: Option not found

This shows that the shell is not passing your command line to ffmpeg
properly. Is it being run in an interactive shell? Please remove all
line breaks, backslashes, and so on.

For example, what you quoted:
> ffmpeg -i /var/www/html/swipr/uploads/test/video1.mkv -i 
> /var/www/html/swipr/uploads/test/video2.mkv -acodec libopus -i 
> /var/www/html/swipr/uploads/test/audio1.mka -acodec libopus -i 
> /var/www/html/swipr/uploads/test/audio2.mka -y -filter_complex " 
> [0]scale=512:-2,pad=512:768:(ow-iw)/2:(oh-ih)/2[vs0],color=black:size=512x768:duration=2.716[b0],[b0][vs0]concat[r0c0];\[1]scale=512:-2,pa=512:768:(ow-iw)/2:(oh-ih)/2[vs1],color=black:size=512x768:duration=0[b1],[b1][vs1]concat[r0c1];\[r0c0][r0c1]hstack=inputs=2[video];\[2]aresample=async=1,adelay=2743.0|2743.0[a0];[3]aresample=async=1,adelay=5.0|5.0[a1];\[a0][a1]amix=inputs=2[audio]"
>  
> -map[video] \ -map[audio] \ -acodec libopus \ -vcodec libvpx \ output.webm

- Did you break these lines or did your mailer?
- Why are there backslashes in the middle of the command, near
 "-vcodec" and "-acodec" (or did your mailer merge several lines)?
- Why this backslash and the others in the middle of the filter
  expression?: "...concat[r0c0];\[1]scale=512:-2..."

Further comments:
- "-map[audio]" should be "-map '[audio]'" (there needs to be a space
  inbetween, and safer to quote shell arguments with brackets, though
  not necessarily required). Same for "-map[video]".
- You are using too few semicolons instead of commas. Before "color"
  comes a semicolon, and before "[b0][vs0]concat" comes a semicolon
  (else these filter chains get connected).

Cheers,
Moritz
_______________________________________________
ffmpeg-user mailing list
ffmpeg-user@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-user

To unsubscribe, visit link above, or email
ffmpeg-user-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to