Update of /cvsroot/fink/dists/10.3/unstable/main/finkinfo/gnome
In directory 
sc8-pr-cvs5.sourceforge.net:/tmp/cvs-serv22437/10.3/unstable/main/finkinfo/gnome

Modified Files:
        gtkmm2.4.info 
Log Message:
new version


Index: gtkmm2.4.info
===================================================================
RCS file: /cvsroot/fink/dists/10.3/unstable/main/finkinfo/gnome/gtkmm2.4.info,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -d -r1.5 -r1.6
--- gtkmm2.4.info       11 Aug 2005 15:23:54 -0000      1.5
+++ gtkmm2.4.info       8 Aug 2006 05:01:24 -0000       1.6
@@ -1,18 +1,18 @@
 Package: gtkmm2.4
-Version: 2.6.4
+Version: 2.6.14
 Revision: 1
 GCC: 3.3
-Depends: %N-shlibs (= %v-%r), libsigc++2-shlibs, gtk+2-shlibs (>= 2.6.0-1), 
atk1-shlibs (>= 1.9.0-1), libgettext3-shlibs, glib2 (>= 2.4.0-1), libiconv, 
libjpeg-shlibs, libpng3-shlibs (>= 1.2.5-4), libtiff-shlibs, pango1-xft2 (>= 
1.5.2-1), x11, glibmm2.4 (>= 2.6.0-1)
+Depends: %N-shlibs (= %v-%r), libsigc++2-shlibs, gtk+2-shlibs (>= 2.6.0-1), 
atk1-shlibs (>= 1.9.0-1), libgettext3-shlibs, glib2-shlibs (>= 2.12.0-1), 
libiconv, libjpeg-shlibs, libpng3-shlibs (>= 1.2.5-4), libtiff-shlibs, 
pango1-xft2 (>= 1.5.2-1), x11, glibmm2.4 (>= 2.10.5-1)
 Replaces: %N-shlibs (<< 2.6.4-1)
-BuildDepends: glib2-dev (>= 2.4.0-1), libsigc++2, glibmm2.4-dev (>= 2.6.0-1),  
gtk+2-dev (>= 2.6.0-1), atk1 (>= 1.9.0-1), pango1-xft2-dev (>= 1.5.2-1), 
libpng3, libjpeg, libtiff, pkgconfig (>= 0.15.0-2), libgettext3-dev, 
gettext-bin, gettext-tools, libiconv-dev, x11-dev
+BuildDepends: glib2-dev (>= 2.12.0-1), libsigc++2, glibmm2.4-dev (>= 
2.10.5-1),  gtk+2-dev (>= 2.6.0-1), atk1 (>= 1.9.0-1), pango1-xft2-dev (>= 
1.5.2-1), libpng3, libjpeg, libtiff, pkgconfig (>= 0.15.0-2), libgettext3-dev, 
gettext-bin, gettext-tools, libiconv-dev, x11-dev
 Source: mirror:gnome:sources/gtkmm/2.6/gtkmm-%v.tar.bz2
-Source-MD5: f71d1c4a89c4f9e054400f12a82dec5f
+Source-MD5: 31f28293f9d258c40b1a1181900dbe12
+PatchScript: perl -pi -e 's/^(SUBDIRS.*)tests/\1/' Makefile.in
 NoSetLDFLAGS: true
 SetCPPFLAGS: -no-cpp-precomp -DX_LOCALE
 SetCFLAGS: -O3 -funroll-loops -fstrict-aliasing -pipe
 SetLIBRARY_PATH: %p/lib
-#SetMACOSX_DEPLOYMENT_TARGET: 10.3
-ConfigureParams: --mandir=%p/share/man --disable-shm 
--disable-dependency-tracking --enable-warnings=maximum --enable-static
+ConfigureParams: --mandir=%p/share/man --disable-shm 
--disable-dependency-tracking --enable-warnings=maximum --enable-static 
--disable-examples --disable-demos
 CompileScript: <<
   PERL_PATH=/usr/bin/perl ./configure %c
 # ulimit -s unlimited && make -j2
@@ -20,7 +20,7 @@
 <<
 SplitOff: <<
   Package: %N-shlibs
-  Depends: gtk+2-shlibs (>= 2.6.0-1), atk1-shlibs (>= 1.9.0-1), 
libgettext3-shlibs, glib2-shlibs (>= 2.4.0-1), libiconv, libjpeg-shlibs, 
libpng3-shlibs (>= 1.2.5-4), libtiff-shlibs, pango1-xft2-shlibs (>= 1.5.2-1), 
x11, libsigc++2-shlibs
+  Depends: gtk+2-shlibs (>= 2.6.0-1), atk1-shlibs (>= 1.9.0-1), 
libgettext3-shlibs, glib2-shlibs (>= 2.12.0-1), libiconv, libjpeg-shlibs, 
libpng3-shlibs (>= 1.2.5-4), libtiff-shlibs, pango1-xft2-shlibs (>= 1.5.2-1), 
x11, libsigc++2-shlibs, glibmm2.4-shlibs (>= 2.10.5-1)
   Files: lib/lib*.*.*.dylib
   Shlibs: <<
     %p/lib/libatkmm-1.6.1.dylib 2.0.0 %n (>= 2.6.4-1)
@@ -36,8 +36,8 @@
   DescPackaging: <<
     Uses pkgconfig.
     Any package which BuildDepends on this one must also BuildDepend on:
-      atk1 (>= 1.9.0-1), glib2-dev (>= 2.4.0-1), pango1-xft2-dev (>= 1.5.2-1),
-      glibmm2.4 (>=2.6.0-1), libsigc++2
+      atk1 (>= 1.9.0-1), glib2-dev (>= 2.12.0-1), pango1-xft2-dev (>= 1.5.2-1),
+      glibmm2.4 (>= 2.10.5-1), libsigc++2
   <<
   BuildDependsOnly: True
   Files: include lib/gtkmm-2.4/include lib/lib*.* lib/pkgconfig
@@ -51,6 +51,11 @@
 we'll make a clean break with the Shlibs dependency.
 
 Doc processors (lib/{gtk,gdk}mm-2.4/proc) were in %N-shlibs until 2.6.4-1
+
+  Use glib2-2.12.0 for GCC version independence and new glib2 package layout
+
+  Require gtkmm >= 2.10.5 to avoid versions with broken signal handlers.
+  See: http://bugzilla.gnome.org/show_bug.cgi?id=349740
 <<
 License: LGPL
 Maintainer: The Gnome Core Team <[EMAIL PROTECTED]>


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fink-commits

Reply via email to