Update of /cvsroot/fink/experimental/alexkhansen/10.4/finkinfo/x11-system
In directory sc8-pr-cvs5.sourceforge.net:/tmp/cvs-serv31664/finkinfo/x11-system

Modified Files:
        applex11-dev.info applex11.info 
Log Message:
Moving towards workability.


Index: applex11.info
===================================================================
RCS file: 
/cvsroot/fink/experimental/alexkhansen/10.4/finkinfo/x11-system/applex11.info,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -d -r1.3 -r1.4
--- applex11.info       16 Aug 2006 20:03:36 -0000      1.3
+++ applex11.info       17 Aug 2006 01:19:13 -0000      1.4
@@ -22,38 +22,39 @@
 
        install -d -m 755 "%d"
 
-   echo -e "- searching for an X11 installer: \c"
+   echo -e "- searching for an X11User installer: \c"
        find /Volumes /Users -type d -name X11User.pkg 2>/dev/null | grep -v 
Receipts | while read PACKAGE; do
                if [ -f "$PACKAGE/Contents/Archive.pax.gz" ]; then
                        echo "found $PACKAGE"
-                       pushd "%d"
-                       gzip -dc "$PACKAGE/Contents/Archive.pax.gz" | pax -r '*'
-                       popd
-                       break
+                               if [ -z $( grep 10.4 
"$PACKAGE/Contents/version.plist" ) ] ; then
+                               cat<<END
+This version of X11User.pkg is incompatible with Tiger.  
+END
+                       else
+                               cat<<END
+This is indeed a Tiger X11User installer.  Extracting files... 
+END
+                               pushd "%d"
+                               gzip -dc "$PACKAGE/Contents/Archive.pax.gz" | 
pax -r '*'
+                               popd
+                               break
+                       fi
                fi
-       done
-       echo $PACKAGE   
+       done    
        if ! test -f "%d/usr/bin/open-x11"; then
                cat <<END
-I was unable to find X11USer.pkg on your hard drive.  Please find the file and
+I was unable to find a valid X11User.pkg .  Please find the file and
 put it under /Volumes or /Users or insert your Tiger installation DVD and try 
 again.
 END
                exit 1
        fi
-       if ! ( grep 10.4 "$PACKAGE/Contents/version.plist" )  ; then
-               cat<<END
-I found a version of X11User.pkg is that is incompatible with Tiger.  
-Move it out of the way and try again if you have a correct one available.
-END
-       exit 1
-       fi
 <<
 SplitOff: <<
        Package: %N-shlibs
        Provides: libgl-shlibs, x11-shlibs, xft1-shlibs, xft2-shlibs, 
fontconfig1-shlibs
-       Conflicts: xfree86-base-shlibs, xfree86-base-threaded-shlibs, 
xfree86-rootless-shlibs, xfree86-rootless-threaded-shlibs, system-xfree86, 
xfree86-shlibs
-       Replaces: xfree86-base-shlibs, xfree86-base-threaded-shlibs, 
xfree86-rootless-shlibs, xfree86-rootless-threaded-shlibs, system-xfree86, 
xfree86-shlibs
+       Conflicts: xfree86-base-shlibs, xfree86-base-threaded-shlibs, 
xfree86-rootless-shlibs, xfree86-rootless-threaded-shlibs, system-xfree86, 
xfree86-shlibs, xorg-shlibs
+       Replaces: xfree86-base-shlibs, xfree86-base-threaded-shlibs, 
xfree86-rootless-shlibs, xfree86-rootless-threaded-shlibs, system-xfree86, 
xfree86-shlibs, xorg-shlibs
        Files: <<
                /usr/X11R6/lib/libAppleWM.*.dylib
                /usr/X11R6/lib/libFS.*.dylib
@@ -158,18 +159,39 @@
 #;;
 #esac
 #      <<
-<<
-
+#<<
 PreInstScript: <<
-#echo "WARNING: if you compile X11 applications against this X.org release,"
-#echo "you will *not* be able to run them if you decide to revert to Apple's"
-#echo "X11 provided with the OS."
-
 case "$1" in
        install)
-               echo "If you have previously build packages against XFree86 > 
4.4 or 
-               echo "X.org, they will very likely no longer run."
+               cat <<END
+               Warning!  If you have previously build packages against 
+               XFree86 > 4.4 or X.org, they will very likely no longer run.
+               You will need to rebuild them."
+               END
+#              if [ -e /usr/X11R6/bin/xterm -o -e /usr/X11R6/bin/xrdb -o \
+#                      -e /etc/X11 -o -L /etc/X11 ]; then
+#                      echo
+#                      echo "You have an existing X11 installation in 
/usr/X11R6 and/or /etc/X11."
+#                      echo "This package refuses to overwrite these. Remove 
them, then tell Fink to"
+#                      echo "install xfree86 again. (The package won't be 
recompiled.) If you want"
+#                      echo "to keep your X11 installation, please see the FAQ 
entry at"
+#                      echo 
"http://fink.sourceforge.net/faq/usage-packages.php#apple-x11-wants-xfree86";
+#                      echo "for more information on how to configure your 
system."
+#                      echo
+#                      echo "Press Return to continue."
+#                      read
+#                      exit 1
+#              fi
                ;;
+       upgrade)
+
+               # deal with font listings (we no longer use xfont-base, font
+               #       packages install their fonts in the Fink directories)
+               for dir in 100dpi 75dpi CID cyrillic local misc Speedo Type1 ; 
do
+                       rm -f /usr/X11R6/lib/X11/fonts/$dir/fonts.dir 
/usr/X11R6/lib/X11/fonts/$dir/fonts.scale 
/usr/X11R6/lib/X11/fonts/$dir/fonts.scale.bak
+               done
+               ;;
+
 esac
 <<
 PostInstScript: <<

Index: applex11-dev.info
===================================================================
RCS file: 
/cvsroot/fink/experimental/alexkhansen/10.4/finkinfo/x11-system/applex11-dev.info,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -d -r1.2 -r1.3
--- applex11-dev.info   16 Aug 2006 16:37:58 -0000      1.2
+++ applex11-dev.info   17 Aug 2006 01:19:13 -0000      1.3
@@ -22,33 +22,35 @@
 
        install -d -m 755 "%d"
 
-   echo -e "- searching for an X11 installer: \c"
+   echo -e "- searching for an X11SDK installer: \c"
        find /Volumes /Users -type d -name X11SDK.pkg 2>/dev/null | grep -v 
Receipts | while read PACKAGE; do
                if [ -f "$PACKAGE/Contents/Archive.pax.gz" ]; then
                        echo "found $PACKAGE"
-                       pushd "%d"
-                       gzip -dc "$PACKAGE/Contents/Archive.pax.gz" | pax -r '*'
-                       popd
-                       break
+                               if [ -z $( grep 3.2 
"$PACKAGE/Contents/version.plist" ) ] ; then
+                               cat<<END
+This version of X11SDK.pkg is incompatible with Tiger.  
+END
+                       else
+                               cat<<END
+This is indeed a Tiger X11SDK installer.  Extracting files...
+END
+                               pushd "%d"
+                               gzip -dc "$PACKAGE/Contents/Archive.pax.gz" | 
pax -r '*'
+                               popd
+                               break
+                       fi
                fi
        done
 
        if ! test -f "%d/usr/include/Xplugin.h"; then
                cat <<END
-I was unable to find X11SDK.pkg on your hard drive.  Please download the
-Xcode Tools dmg (and open/mount it) from http://connect.apple.com or
-insert your Tiger installation DVD and try again.
+I was unable to find a valid X11SDK.pkg .  Please find the file and put it 
+under /Volumes or /Users, download the Xcode Tools dmg from  
+http://connect.apple.com and mount it or insert your Tiger installation DVD 
+and try again.
 END
                exit 1
        fi
-       if ! ( grep 3.2 $PACKAGE/Contents/version.plist )  ; then
-               cat<<END
-I found a version of X11SDK.pkg that is incompatible with Tiger.  
-Move it out of the way and try again if you have a correct one available.
-END
-       exit 1
-       fi
-
 <<
 License: Restrictive
 Homepage: http://www.apple.com/macosx/x11/


-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fink-commits

Reply via email to