Update of /cvsroot/fink/dists/10.3/stable/main/finkinfo/gnome
In directory sc8-pr-cvs17:/tmp/cvs-serv19621/gnome

Modified Files:
        librsvg2.info librsvg2.patch 
Added Files:
        libcroco3.info libcroco3.patch 
Log Message:
move to stable



--- NEW FILE: libcroco3.info ---
Package: libcroco3
Version: 0.6.1
Revision: 11

License: LGPL
Maintainer: Dave Vasilevsky <[EMAIL PROTECTED]>
Description: CSS parsing and manipulation library
DescDetail: <<
        The Libcroco project is an effort to build a generic Cascading
        Style Sheet (CSS) parsing and manipulation toolkit that can be
        used by GNOME applications in need of CSS support.
<<
Homepage: ftp://ftp.gnome.org/pub/GNOME/sources/libcroco/
DescPort: <<
        Fix upstream linking bugs (libcroco wasn't linking against the
        libs that supplied symbols it used)
<<

Source: mirror:gnome:sources/libcroco/0.6/libcroco-%v.tar.bz2
Source-MD5: b0975bd01eb11964f1b3f254f267a43d

Patch: %n.patch
PatchScript: <<
  perl -pi.bak -e 's,need_relink=yes,need_relink=no,g' ltmain.sh
  perl -pi.bak -e 's/hardcode_direct=yes/hardcode_direct=no/g' configure
<<

ConfigureParams: --infodir=%p/share/info --mandir=%p/share/man 
InstallScript: make install DESTDIR=%d

DocFiles: ABOUT* AUTHORS COPYING* ChangeLog HACKING INSTALL NEWS README TODO

BuildDependsOnly: true
Depends: %N-shlibs (= %v-%r)
BuildDepends: <<
        pkgconfig,
        
        glib2-dev               (>= 2.12.0-1),
        
        libxml2                 (>= 2.6.19-2),
        
        libgettext3-dev,
        
        libiconv-dev
<<
# Does NOT conflict with libcroco1

SplitOff: <<
        Package: %N-shlibs
        
        Depends: <<
                glib2-shlibs    (>= 2.12.0-1),
                libxml2-shlibs  (>= 2.6.19-2),
                libgettext3-shlibs,
                libiconv
        <<
        
        Files: lib/libcroco-0.6.*.dylib
        Shlibs: %p/lib/libcroco-0.6.3.dylib 4.0.0 %n (>= 0.6.0-11)
        DocFiles: ABOUT* AUTHORS COPYING* ChangeLog HACKING INSTALL NEWS README 
TODO
<<
SplitOff2: <<
        Package: %N-bin
        Depends: <<
                %N-shlibs               (= %v-%r),
                glib2-shlibs    (>= 2.12.0-1),
                libgettext3-shlibs,
                libiconv
        <<
        
        Files: bin
        DocFiles: ABOUT* AUTHORS COPYING* ChangeLog HACKING INSTALL NEWS README 
TODO
<<

Index: librsvg2.info
===================================================================
RCS file: /cvsroot/fink/dists/10.3/stable/main/finkinfo/gnome/librsvg2.info,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -d -r1.7 -r1.8
--- librsvg2.info       1 May 2005 07:18:55 -0000       1.7
+++ librsvg2.info       20 Aug 2007 02:55:54 -0000      1.8
@@ -1,42 +1,135 @@
 Package: librsvg2
-Version: 2.6.5
-Revision: 9
-BuildDependsOnly: true
-Depends: %N-shlibs (= %v-%r), libcroco1-shlibs (>= 0.5.0-1),  atk1-shlibs (>= 
1.6.0-1), gettext, glib2-shlibs (>= 2.4.0-1), gtk+2-shlibs (>= 2.4.0-1), 
libart2-shlibs (>= 2.3.16-1), libiconv, libxml2-shlibs (>= 2.6.7-1), 
pango1-xft2-shlibs, popt-shlibs, pkgconfig
-BuildDepends: libcroco1 (>= 0.5.0-1),  gconf2-dev (>= 2.6.0-1), gettext-bin, 
gettext-tools, gettext-dev, glib2-dev (>= 2.4.0-1), gnome-vfs2-dev (>= 2.6.0-1) 
| gnome-vfs2-ssl-dev (>= 2.6.0-1), gtk+2-dev (>= 2.4.0-1), libart2 (>= 
2.3.16-1), libbonobo2-dev (>= 2.6.0-1), libbonoboui2-dev (>= 2.6.0-1), 
libgnome2-dev (>= 2.6.0-1), libgnomecanvas2-dev (>= 2.6.0-1), libgnomeui2-dev 
(>= 2.6.0-1), libgsf-dev, libjpeg, libiconv-dev, libxml2 (>= 2.6.7-1), 
orbit2-dev (>= 2.10.0-1), pango1-xft2-dev (>= 1.4.0-1), popt (>= 1.5), 
pkgconfig, gtk-doc (>= 1.2-1), audiofile, esound
-Source: mirror:gnome:sources/librsvg/2.6/librsvg-%v.tar.bz2
-Source-MD5: 2d1d16f9493c80ce8214e585727334ae
+Version: 2.9.5
+Revision: 11
+
+License: GPL/LGPL
+Maintainer: Dave Vasilevsky <[EMAIL PROTECTED]>
+Description: SAX-based render library for SVG files
+Homepage: http://www.gnome.org/
+
+Source: mirror:gnome:sources/librsvg/2.9/librsvg-%v.tar.bz2
+Source-MD5: 44799d75e940eb4150acdae4f63cbe2a
+
+
 Patch: %n.patch
-PatchScript: perl -pi.bak -e 's/hardcode_direct=yes/hardcode_direct=no/g' 
configure
-ConfigureParams: --mandir=%p/share/man --without-gimp
-NoSetLDFLAGS: true
-SetCPPFLAGS: -no-cpp-precomp
-SetCFLAGS: -O3 -funroll-loops -fstrict-aliasing
-SetLIBS: -L%p/lib
-InstallScript: make install DESTDIR=%d
-PostInstScript: <<
-  if [ configure = "$1" ]; then
-    update-gdk-pixbuf-loaders
-  fi
+
+SetLDFLAGS: -L/usr/X11R6/lib
+
+ConfigureParams: --with-svgz --enable-gnome-vfs --with-croco 
--enable-gtk-theme --enable-pixbuf-loader --enable-gtk-doc 
--disable-dependency-tracking --mandir=%p/share/man 
--with-html-dir=%p/share/doc/%n/html
+
+InstallScript: <<
+       make install DESTDIR=%d
+       rm -r %i/lib/mozilla
 <<
-PostRmScript: <<
-  if [ upgrade != "$1" ]; then
-    update-gdk-pixbuf-loaders
-  fi
+
+
+DocFiles: AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO
+
+BuildDependsOnly: true
+BuildDepends: <<
+       pkgconfig,
+       
+       gtk+2-dev,
+       atk1,
+       
+       glib2-dev,
+       
+       libart2                 (>= 2.3.10-1),
+       
+       pango1-xft2-dev (>= 1.2.0-1),
+       
+       popt                    (>= 1.5-1),
+       
+       libgsf-dev              (>= 1.6.0-1),
+       libxml2                 (>= 2.4.7-1),
+       
+       dbus-dev (>= 0.60-1), libhowl-dev, gnome-vfs2-ssl-dev (>= 1.9.16-1) | 
gnome-vfs2-dev (>= 1.9.16-1),
+       libbonobo2-dev,
+       orbit2-dev,
+       gconf2-dev,
+       
+       libcroco3,
+       
+       libgnomeprint2.2-dev,
+       
+       libgnomeprintui2.2-dev,
+       libgnomecanvas2-dev,
+       
+       x11-dev,
+       
+       gtk+2,
+               
+       gtk-doc,
+       
+       libgettext3-dev,
+       libiconv-dev
 <<
+Depends: %N-shlibs (= %v-%r)
+
+
 SplitOff: <<
-  Package: %N-shlibs
-  Depends: gettext, glib2-shlibs (>= 2.4.0-1), gtk+2-shlibs (>= 2.4.0-1), 
libart2-shlibs (>= 2.3.16-1), libcroco1-shlibs, libgsf-shlibs, libiconv, 
libxml2-shlibs (>= 2.6.7-1), pango1-xft2-shlibs (>= 1.4.0-1)
-  Files: lib/librsvg-2.*.dylib
-  Shlibs: %p/lib/librsvg-2.2.dylib 7.0.0 %n (>= 2.6.0-1)
-  DocFiles: AUTHORS COPYING* ChangeLog NEWS README TODO
+       Package: %N-shlibs
+       
+       Depends: <<
+               gconf2-shlibs,
+               glib2-shlibs,
+               gnome-vfs2-ssl-shlibs (>= 1.9.16-1) | gnome-vfs2-shlibs (>= 
1.9.16-1),
+               gtk+2-shlibs,
+               libart2-shlibs          (>= 2.3.10-1),
+               libbonobo2-shlibs,
+               libcroco3-shlibs,
+               libgettext3-shlibs,
+               libgsf-shlibs           (>= 1.6.0-1),
+               libiconv,       
+               libxml2-shlibs          (>= 2.4.7-1),
+               orbit2-shlibs,
+               pango1-xft2-shlibs      (>= 1.2.0-1),
+               popt-shlibs                     (>= 1.5-1),
+               x11
+       <<
+       
+       Files: lib/librsvg-2.*.dylib
+       Shlibs: %p/lib/librsvg-2.2.dylib 12.0.0 %n (>= 2.9.5-11)
+       DocFiles: COPYING*
 <<
-DocFiles: AUTHORS COPYING* ChangeLog NEWS README TODO
-Description: SAX-based render library for SVG files
+
+SplitOff2: <<
+       Package: %N-gtk
+       Description: Enable GTK to use SVG data
+       
+       Depends: %N-shlibs (= %v-%r), gtk+2
+       Replaces: %N (<< 2.6.5-10)
+       
+       Files: <<
+               lib/gtk-2.0/2.4.0/engines/libsvg.so
+               lib/gtk-2.0/2.4.0/loaders/svg_loader.so
+       <<
+       DocFiles: COPYING*
+       
+       PostInstScript: <<
+               if [ configure = "$1" ]; then
+                       DYLD_FALLBACK_LIBRARY_PATH=: update-gdk-pixbuf-loaders
+               fi
+       <<
+       PostRmScript: <<
+               if [ upgrade != "$1" ]; then
+                       DYLD_FALLBACK_LIBRARY_PATH=: update-gdk-pixbuf-loaders
+               fi
+       <<
+<<
+
+SplitOff3: <<
+       Package: %N-bin
+       
+       Depends: %N-shlibs (= %v-%r)
+       Replaces: %N (<< 2.6.5-10)
+       
+       Files: bin share/man share/pixmaps
+       DocFiles: COPYING*
+<<
+
 DescPort: <<
-Patches pkg-config arguments in configure to find freetype2 headers before
-freetype headers.
+       - Use X11 freetype 2.
+       - Put GTK stuff in splitoff.
+       - Disable Mozilla plugin, use librsvg2-mozilla to build that.
 <<
-License: GPL/LGPL
-Maintainer: The Gnome Core Team <[EMAIL PROTECTED]>
-Homepage: http://www.gnome.org/

--- NEW FILE: libcroco3.patch ---
diff -Nurd -x'*~' libcroco-0.6.1.orig/src/Makefile.in 
libcroco-0.6.1/src/Makefile.in
--- libcroco-0.6.1.orig/src/Makefile.in 2006-03-05 17:14:36.000000000 -0500
+++ libcroco-0.6.1/src/Makefile.in      2006-08-08 14:45:49.000000000 -0400
@@ -264,7 +264,7 @@
 -I $(top_builddir)/src @GLIB2_CFLAGS@ @LIBXML2_CFLAGS@
 
 libcroco_0_6_la_LDFLAGS = -version-info @LIBCROCO_VERSION_INFO@ \
[EMAIL PROTECTED]@ $(no_undefined)
[EMAIL PROTECTED]@ @LIBXML2_LIBS@ $(no_undefined)
 
 libcroco_0_6_la_LIBADD = @GLIB2_LIBS@ @LIBXML2_LIBS@
 subdir = src

Index: librsvg2.patch
===================================================================
RCS file: /cvsroot/fink/dists/10.3/stable/main/finkinfo/gnome/librsvg2.patch,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -d -r1.2 -r1.3
--- librsvg2.patch      24 Mar 2005 14:01:15 -0000      1.2
+++ librsvg2.patch      20 Aug 2007 02:55:54 -0000      1.3
@@ -1,46 +1,32 @@
-diff -Naur librsvg-2.6.5-old/Makefile.in librsvg-2.6.5/Makefile.in
---- librsvg-2.6.5-old/Makefile.in      2004-05-01 01:00:01.000000000 -0400
-+++ librsvg-2.6.5/Makefile.in  2004-06-22 11:16:40.000000000 -0400
-@@ -175,6 +175,7 @@
+diff -Naur librsvg-2.9.5/Makefile.in librsvg-new/Makefile.in
+--- librsvg-2.9.5/Makefile.in  2005-01-18 20:14:40.000000000 -0500
++++ librsvg-new/Makefile.in    2005-08-05 22:44:20.000000000 -0400
+@@ -255,7 +255,7 @@
+ 
+ 
+ librsvg_2_la_LDFLAGS = -version-info @VERSION_INFO@ -no-undefined 
-export-dynamic
+-librsvg_2_la_LIBADD = $(LIBGNOME_VFS_LIBS) $(LIBGSF_LIBS) $(LIBCROCO_LIBS) 
$(LIBRSVG_LIBS)
++librsvg_2_la_LIBADD = $(LIBGNOME_VFS_LIBS) $(LIBGSF_LIBS) $(LIBCROCO_LIBS) 
$(LIBRSVG_LIBS) -lfreetype -lfontconfig
+ 
+ librsvgincdir = $(includedir)/librsvg-2/librsvg
+ librsvginc_HEADERS = \
+@@ -265,6 +265,7 @@
  
  
  INCLUDES = \
-+      -I/usr/X11R6/include/freetype2  \
++      -I/usr/X11R6/include/freetype2 \
+       $(LIBGNOME_VFS_CFLAGS)          \
        $(LIBGSF_CFLAGS)                \
        $(LIBCROCO_CFLAGS)              \
-       -I$(top_srcdir)                 \
-diff -Naur librsvg-2.6.5-old/configure librsvg-2.6.5/configure
---- librsvg-2.6.5-old/configure        2004-05-01 00:59:38.000000000 -0400
-+++ librsvg-2.6.5/configure    2004-06-22 11:14:33.000000000 -0400
-@@ -19201,11 +19201,11 @@
-             echo "$as_me:$LINENO: checking LIBRSVG_CFLAGS" >&5
- echo $ECHO_N "checking LIBRSVG_CFLAGS... $ECHO_C" >&6
-             LIBRSVG_CFLAGS=`$PKG_CONFIG --cflags "\
-+      pangoft2 >= $PANGOFT2_REQUIRED \
-       gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED \
-       glib-2.0 >= $GLIB_REQUIRED \
-       libart-2.0 >= $LIBART_REQUIRED \
--      libxml-2.0 >= $LIBXML_REQUIRED \
--      pangoft2 >= $PANGOFT2_REQUIRED"`
-+      libxml-2.0 >= $LIBXML_REQUIRED"`
-             echo "$as_me:$LINENO: result: $LIBRSVG_CFLAGS" >&5
- echo "${ECHO_T}$LIBRSVG_CFLAGS" >&6
- 
-diff -Naur librsvg-2.6.5-old/ltmain.sh librsvg-2.6.5/ltmain.sh
---- librsvg-2.6.5-old/ltmain.sh        2004-04-02 22:18:18.000000000 -0500
-+++ librsvg-2.6.5/ltmain.sh    2004-06-22 11:14:34.000000000 -0400
-@@ -5244,10 +5244,10 @@
- 
- # Directory that this library needs to be installed in:
- libdir='$install_libdir'"
--        if test "$installed" = no && test "$need_relink" = yes; then
--          $echo >> $output "\
--relink_command=\"$relink_command\""
--        fi
-+#       if test "$installed" = no && test "$need_relink" = yes; then
-+#         $echo >> $output "\
-+#relink_command=\"$relink_command\""
-+#       fi
-       done
-       fi
+diff -Naur librsvg-2.9.5/configure librsvg-new/configure
+--- librsvg-2.9.5/configure    2005-01-18 20:14:43.000000000 -0500
++++ librsvg-new/configure      2005-08-05 22:44:25.000000000 -0400
+@@ -23588,7 +23588,7 @@
+         echo "$as_me:$LINENO: checking for mozilla-plugin" >&5
+ echo $ECHO_N "checking for mozilla-plugin... $ECHO_C" >&6
  
+-        if $PKG_CONFIG --exists "mozilla-plugin" ; then
++        if false ; then
+             echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+             succeeded=yes


-------------------------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/fink-commits

Reply via email to