Update of /cvsroot/fink/dists/10.4/unstable/crypto/finkinfo
In directory sc8-pr-cvs17.sourceforge.net:/tmp/cvs-serv20452

Modified Files:
      Tag: pangocairo-branch
        libgnomedb.info libgnomedb.patch 
Log Message:
enable gtksourceview


Index: libgnomedb.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/crypto/finkinfo/Attic/libgnomedb.info,v
retrieving revision 1.1.2.7
retrieving revision 1.1.2.8
diff -u -d -r1.1.2.7 -r1.1.2.8
--- libgnomedb.info     6 Mar 2008 05:07:19 -0000       1.1.2.7
+++ libgnomedb.info     6 Mar 2008 19:13:11 -0000       1.1.2.8
@@ -1,6 +1,6 @@
 Package: libgnomedb
 Version: 3.1.2
-Revision: 4
+Revision: 5
 BuildDepends: <<
        atk1 (>= 1.20.0-1),
        audiofile,
@@ -21,6 +21,7 @@
        glitz,
        gnome-vfs2-unified-dev (>= 1:2.20.0-1),
        gtk+2-dev (>= 2.12.0-1),
+       gtksourceview-dev (>= 1.8.5-1),
        intltool (>= 0.36.0-1),
        libart2,
        libavahi-glib1-dev,
@@ -30,6 +31,7 @@
        libglade2 (>= 2.6.2-1),
        libgnome2-dev (>= 2.20.0-1),
        libgnomecanvas2-dev (>= 2.20.0-1),
+       libgnomeprint2.2-dev (>= 2.18.4-1),
        libgpg-error,
        libiconv-dev,
        libjpeg,
@@ -50,7 +52,7 @@
 Source:  mirror:gnome:sources/%n/3.1/%n-%v.tar.bz2
 Source-MD5: 9896bd66451c3f1e2bdd1cd79d524348
 PatchFile: %n.patch
-PatchFile-MD5: 1d416cb4554c0eb76355379dbfd7c000
+PatchFile-MD5: 607969cd15d00af7e0131dcdcca356dc
 PatchScript: <<
        %{default_script}
        perl -pi -e 's/-scrollkeeper-update/#$&/' doc/Makefile.in
@@ -80,6 +82,7 @@
                glitz-shlibs,
                gnome-vfs2-unified-shlibs (>= 1:2.20.0-1),
                gtk+2-shlibs (>= 2.12.0-1),
+               gtksourceview-shlibs (>= 1.8.5-1),
                libart2-shlibs,
                libavahi-client3-shlibs,
                libavahi-common3-shlibs,
@@ -89,6 +92,7 @@
                libgettext3-shlibs,
                libglade2-shlibs (>= 2.6.2-1),
                libgnomecanvas2-shlibs (>= 2.20.0-1),
+               libgnomeprint2.2-shlibs (>= 2.18.4-1),
                libgpg-error-shlibs,
                libiconv,
                iso-codes,
@@ -151,6 +155,10 @@
 Database Widget Library. These widgets are integrated with the 
 latest versions of glade.
 <<
+DescPort: <<
+       Fix misuse of value instead of shell return code.
+       See: http://bugzilla.gnome.org/show_bug.cgi?id=520464
+<<
 DescPackaging: <<
        share/gtk-doc moved %N -> %N4-dev as of 3.1.2-3
 
@@ -158,8 +166,9 @@
        (used by lib/glade3/modules/libgladegnomedb.so)
 
        Force non-detection of some deps for packaging sanity.
-       gtksourceview omitted for now, should look at what it entails
-       (gnomeprint stack...feh) or switching to use gtksourceview2.
+
+       Should switch to using gtksourceview2 so can lose the
+       gnomeprint stack and other antique stuff.
        See: http://bugzilla.gnome.org/show_bug.cgi?id=520463
 <<
 License: GPL/LGPL

Index: libgnomedb.patch
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/crypto/finkinfo/Attic/libgnomedb.patch,v
retrieving revision 1.1.2.1
retrieving revision 1.1.2.2
diff -u -d -r1.1.2.1 -r1.1.2.2
--- libgnomedb.patch    5 Mar 2008 05:36:49 -0000       1.1.2.1
+++ libgnomedb.patch    6 Mar 2008 19:13:11 -0000       1.1.2.2
@@ -1,6 +1,6 @@
 diff -Nurd libgnomedb-3.1.2.orig/configure libgnomedb-3.1.2/configure
 --- libgnomedb-3.1.2.orig/configure    2007-10-24 15:44:07.000000000 -0400
-+++ libgnomedb-3.1.2/configure 2008-03-04 13:51:04.000000000 -0500
++++ libgnomedb-3.1.2/configure 2008-03-06 13:16:39.000000000 -0500
 @@ -23288,7 +23288,7 @@
                        LIBGCRYPT_LIBS=""
  
@@ -53,24 +53,7 @@
  
  
  if test x"$have_graphviz" = "xyes"; then
-@@ -24001,6 +24007,7 @@
- 
- 
- 
-+if false; then
- pkg_failed=no
- { echo "$as_me:$LINENO: checking for GTKSOURCEVIEW" >&5
- echo $ECHO_N "checking for GTKSOURCEVIEW... $ECHO_C" >&6; }
-@@ -24071,6 +24078,8 @@
- echo "${ECHO_T}yes" >&6; }
-       have_gtksourceview=yes
- fi
-+fi
-+have_gtksourceview=no
- 
- 
- if test x"$have_gtksourceview" = "xyes"; then
-@@ -24092,6 +24101,7 @@
+@@ -24092,6 +24098,7 @@
  
  
  
@@ -78,7 +61,7 @@
  pkg_failed=no
  { echo "$as_me:$LINENO: checking for GDA_EVOLUTION" >&5
  echo $ECHO_N "checking for GDA_EVOLUTION... $ECHO_C" >&6; }
-@@ -24167,6 +24177,8 @@
+@@ -24167,6 +24174,8 @@
        EVOLUTION_VERSION=`pkg-config --modversion libedataserver-1.2`
  
  fi


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to