Update of /cvsroot/fink/dists/10.4/unstable/main/finkinfo/gnome
In directory sc8-pr-cvs17.sourceforge.net:/tmp/cvs-serv28466

Modified Files:
      Tag: pangocairo-branch
        gnome-games.info 
Log Message:
fix build; dep-tweaks


Index: gnome-games.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/gnome/gnome-games.info,v
retrieving revision 1.4.2.63
retrieving revision 1.4.2.64
diff -u -d -r1.4.2.63 -r1.4.2.64
--- gnome-games.info    27 Apr 2008 16:50:22 -0000      1.4.2.63
+++ gnome-games.info    6 Jun 2008 06:10:43 -0000       1.4.2.64
@@ -1,7 +1,7 @@
 Package: gnome-games
 
 Version: 2.20.3
-Revision: 5
+Revision: 6
 
 GCC: 4.0
 Depends: <<
@@ -35,17 +35,19 @@
        librsvg2-gtk (>= 2.9.5-11),
        librsvg2-shlibs (>= 2.18.0-1),
        libxml2-shlibs (>= 2.6.30-1),
-       orbit2 (>= 2.14.9-1),
+       orbit2 (>= 2.14.10-1),
        pango1-xft2-ft219 (>= 1.18.4-4),
        popt-shlibs,
        pygobject2-py25 (>= 2.12.0-1),
        pygtk2-gtk-py25 (>= 2.10.0-1),
+       python25,
        rarian-compat,
        x11-shlibs
 <<
 BuildDepends: <<
        atk1 (>= 1.20.0-1),
        audiofile (>= 0.2.5-1),
+       autoconf (>= 2.60),
         automake1.10,
        avahi-dev,
        bzip2-dev,
@@ -88,13 +90,13 @@
        libncurses5 (>= 5.4-20041023-1006),
        libpng3,
        librsvg2 (>= 2.18.0-1),
+       libtool2,
        libxml2 (>= 2.6.30-1),
-       orbit2-dev (>= 2.14.9-1),
+       orbit2-dev (>= 2.14.10-1),
        pango1-xft2-ft219-dev (>= 1.18.4-4),
        pixman (>= 0.10.0-1),
        pkgconfig (>= 0.21-1),
        popt,
-       python25,
        pycairo-py25-dev,
        pygobject2-py25-dev (>= 2.12.0-1),
        pygtk2-gtk-py25-dev (>= 2.10.0-1),
@@ -106,7 +108,7 @@
 Source-MD5: 470bec8560c931609f89aae94977d799
 PatchScript: <<
        #!/bin/sh -ev
-       perl -pi -e 's/(guile)(-config| -c)/$1-1.6$2/' configure
+       perl -pi -e 's/(guile)(-config| -c)/$1-1.8$2/' configure.in
        perl -pi -e 's/game_server/games_network_server_name/' 
libgames-support/games-network.c
        perl -pi -e 's|#\!\s*/usr/bin/env\s+python.*|#\!%p/bin/python2.5|' 
`find . -name \*.py -o -name \*.in`
 
@@ -123,6 +125,11 @@
 SetMAKEFLAGS: -j1
 BuildConflicts: libggz, libggz-crypto, ggz-client-libs-dev, ggz-server-dev
 ConfigureParams: --without-ggz-server --disable-scrollkeeper 
--disable-schemas-install --with-ncurses=%p --disable-dependency-tracking 
PKG_CONFIG_PATH="%p/lib/pango-ft219/lib/pkgconfig:%p/lib/fontconfig2/lib/pkgconfig:%p/lib/freetype219/lib/pkgconfig:$PKG_CONFIG_PATH"
 FREETYPE_CONFIG=%p/lib/freetype219/bin/freetype-config PYTHON=%p/bin/python2.5 
GUILE=%p/bin/guile-1.8 GUILE_CONFIG=%p/bin/guile-1.8-config
+CompileScript: <<
+       autoreconf -f -i
+       ./configure %c
+       make
+<<
 InstallScript: make -j1 install DESTDIR=%d
 PostInstScript: <<
        if [ configure = "$1" ]; then
@@ -203,6 +210,10 @@
 DescPackaging: <<
        gnome-games 2.12.0 dropped the shared library (no other packages
        depend on it), so we no longer need to have splitoff pkgs.
+
+       Some autotools get re-run, so we should re-run them all from
+       scratch to avoid having various support files get out-of-sync
+       for different libtool/autoconf/automake versions.
 <<
 License: GPL/GFDL
 Maintainer: The Gnome Core Team <[EMAIL PROTECTED]>


-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://sourceforge.net/services/buy/index.php
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to