Update of /cvsroot/fink/dists/10.4/unstable/main/finkinfo/graphics
In directory sc8-pr-cvs17.sourceforge.net:/tmp/cvs-serv1610

Modified Files:
        graphviz.info 
Log Message:
Eh, what's the worst that could happen?

Index: graphviz.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/graphics/graphviz.info,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -d -r1.7 -r1.8
--- graphviz.info       23 Nov 2007 21:33:52 -0000      1.7
+++ graphviz.info       7 Jul 2008 23:30:35 -0000       1.8
@@ -1,22 +1,191 @@
 Package: graphviz
-Version: 1.16
-Revision: 1013
+Version: 2.18
+Revision: 1
+License: BSD
+Maintainer: Matthias Neeracher <[EMAIL PROTECTED]>
+# Maintainer: David Fang <[EMAIL PROTECTED]>
+Homepage: http://www.graphviz.org/
+#Conflicts: graphviz
+#Replaces: graphviz
 Source: mirror:custom:%n-%v.tar.gz
 CustomMirror: <<
 nam-US: http://www.graphviz.org/pub/graphviz/ARCHIVE
 nam-US: http://www.graphviz.org/pub/graphviz
 <<
 SourceDirectory: %n-%v
-Source-MD5: a2a3bd1b9fe807c46e676fb9a3f0ba22
+Source-MD5: 7df2705482c86fc7a9ee5f0446ed0b9e
 Patch: %n.patch
-PatchScript: grep -r 'panic ' lefty | cut -d: -f1 | sort -u | xargs perl 
-pi.bak -e 's,panic ,lefty_panic ,g'
-Depends: tcltk, x11, libpng3-shlibs, libjpeg-shlibs, libiconv, expat-shlibs, 
gd2-shlibs
-BuildDepends: tcltk-dev, x11-dev, libpng3, libjpeg, libiconv-dev, expat, gd2, 
gd2-bin, gawk (>= 3.1.2-12)
-ConfigureParams: --mandir=%p/share/man --with-extraincludedir=%p/include 
--with-extralibdir=%p/lib --with-tcl=%p --with-tk=%p --with-x 
--x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib 
--with-freetypeincludedir=/usr/X11R6/include/freetype2 --enable-static 
--disable-shared
-NoSetMAKEFLAGS: true
-SetMAKEFLAGS: -j1 
-InstallScript: make -i install DESTDIR=%d
-DocFiles: AUTHORS COPYING ChangeLog FAQ.txt INSTALL NEWS README
+# PatchScript: <<
+#      patch -p0 < %a/%n.patch
+# <<
+GCC: 4.0
+Depends: <<
+       %N-shlibs (= %v-%r)
+<<
+BuildDepends: <<
+       pkgconfig (>= 0.20-1),
+       tcltk-dev, 
+       x11-dev, 
+       fontconfig2-dev (>= 2.3.95-1),
+       freetype219 (>= 2.1.10-1),
+       gmp, 
+       glib2-dev (>= 2.11.1-1), 
+       gtkglext1,
+       guile18,
+       guile18-dev, 
+       libpng3 (>= 1.2.10-1), 
+       libjpeg, 
+       librsvg2,
+       libiconv-dev, 
+       libgettext3-dev (>= 0.14.5-1),
+       gettext-tools,
+       libtool14,
+       libgnomeui2-dev,
+       lua51-dev,
+       lua51,
+       expat1 (>= 2.0.0-1), 
+       gd2, 
+       gd2-bin (>= 2.0.34-1), 
+       gdk-pixbuf,
+       gawk (>= 3.1.2-12), 
+       cairo (>= 1.1.10-1000),
+       ocaml,
+       ruby18-dev,
+       ruby18,
+       swig (>= 1.3.29-1),
+       gtk+2-dev,
+       gnome-vfs2-unified-dev,
+       libhowl-dev,
+       libbonobo2-dev,
+       gconf2-dev,
+       orbit2-dev,
+       libgsf1.114-dev,
+       libcroco3,
+       libart2,
+       libxml2,
+       pango1-xft2-dev
+<<
+ConfigureParams: --mandir=%p/share/man --with-extraincludedir=%p/include 
--with-extralibdir=%p/lib --with-tcl=%p --with-tk=%p --with-x 
--x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib --disable-r 
FREETYPE2_CFLAGS=-I%p/lib/freetype219/include/freetype2 
FREETYPE2_LIBS=-L%p/lib/freetype219/lib GUILE=guile-1.8 
+# --with-freetypeincludedir=/usr/X11R6/include/freetype2
+CompileScript: <<
+       #!/bin/sh -ev
+       ./configure %c
+       make
+<<
+# InfoTest: <<
+#      TestScript: <<
+#      #!/bin/sh -ev
+#      # make check || exit 2
+#      # rtest.sh looks intended for post-install checking
+#      cd rtest
+#      ./rtest.sh -v || exit 2
+#      <<
+##     TestDepends:
+#      TestSuiteSize: small
+#<<
+InstallScript: <<
+       #!/bin/sh -ev
+       make DESTDIR=%d install
+       # remove links in /usr
+       rm -rf %d/usr
+       rm -rf %d/Library
+       rm -rf %d/Network
+       mkdir -p %i/lib/perl5/darwin-thread-multi-2level/%n
+       ln -s %p/lib/%n/perl/gv.pm %i/lib/perl5/darwin-thread-multi-2level/%n
+       mkdir -p %i/share/doc/%n 
+       mv %i/share/%n/doc/* %i/share/doc/%n 
+       mv %i/share/%n/{demo,examples,graphs} %i/share/doc/%n
+       rm -rf %i/share/%n/doc
+       # mkdir -p %i/lib/ruby/1.8/%n
+       # didn't find any .rb files?
+       # not bothering with %p/lib/php
+<<
+# rtest/rtest.sh is intended as a installcheck-time script
+SplitOff: <<
+       Package: %N-shlibs
+       Depends: <<
+               glib2-shlibs, 
+               gtkglext1-shlibs,
+               guile18-shlibs, 
+               tcltk, 
+               x11, 
+               fontconfig2-shlibs, 
+               freetype219-shlibs,
+               libpng3-shlibs, 
+               libjpeg-shlibs, 
+               libiconv, 
+               librsvg2-shlibs,
+               libgettext3-shlibs,
+               libgsf1.114-shlibs,
+               libtool14-shlibs, 
+               libgnomeui2-shlibs,
+               lua51-shlibs,
+               expat1-shlibs, 
+               gd2-shlibs, 
+               gdk-pixbuf-shlibs,
+               ruby18-shlibs,
+               cairo-shlibs
+       <<
+       Files: <<
+               lib/graphviz/*.*.dylib
+               lib/graphviz/guile/*.so
+               lib/graphviz/lua/*.so
+               lib/graphviz/perl/*.so
+               lib/graphviz/php/*.so
+               lib/graphviz/python/*.so
+               lib/graphviz/ruby/*.so
+               lib/graphviz/tcl/*.so
+               lib/graphviz/tcl/*.*.dylib
+               lib/graphviz/tcl/pkgIndex.tcl
+               lib/*.*.dylib
+       <<
+       Shlibs: <<
+               %p/lib/graphviz/libgvplugin_core.5.dylib 6.0.0 %n (>= 2.14-1)
+               %p/lib/graphviz/libgvplugin_dot_layout.5.dylib 6.0.0 %n (>= 
2.14-1)
+               %p/lib/graphviz/libgvplugin_gd.5.dylib 6.0.0 %n (>= 2.14-1)
+               %p/lib/graphviz/libgvplugin_neato_layout.5.dylib 6.0.0 %n (>= 
2.14-1)
+               %p/lib/graphviz/libgvplugin_rsvg.5.dylib 6.0.0 %n (>= 2.18-1)
+               %p/lib/graphviz/tcl/libgdtclft.0.dylib 1.0.0 %n (>= 2.14-1)
+               %p/lib/graphviz/tcl/libtcldot.0.dylib 1.0.0 %n (>= 2.14-1)
+               %p/lib/graphviz/tcl/libtcldot_builtin.0.dylib 1.0.0 %n (>= 
2.14-1)
+               %p/lib/graphviz/tcl/libtclplan.0.dylib 1.0.0 %n (>= 2.14-1)
+               %p/lib/graphviz/tcl/libtkspline.0.dylib 1.0.0 %n (>= 2.14-1)
+               %p/lib/libagraph.4.dylib 5.0.0 %n (>= 2.14-1)
+               %p/lib/libcgraph.4.dylib 5.0.0 %n (>= 2.18-1)
+               %p/lib/libcdt.4.dylib 5.0.0 %n (>= 2.14-1)
+               %p/lib/libgraph.4.dylib 5.0.0 %n (>= 2.14-1)
+               %p/lib/libgvc.4.dylib 5.0.0 %n (>= 2.14-1)
+               %p/lib/libgvc_builtins.4.dylib 5.0.0 %n (>= 2.14-1)
+               %p/lib/libpathplan.4.dylib 5.0.0 %n (>= 2.14-1)
+       <<
+       DescPackaging: <<
+               There are some other lib/graphviz directories that are empty
+               at package-time: R/ io/ java/ ocaml/ python{23,24,25}/ sharp/.
+               Don't know what these are about...
+       <<
+<<
+SplitOff2: <<
+       Package: %N-dev
+       BuildDependsOnly: true
+       Depends: %N-shlibs (= %v-%r)
+       Description: development files for graphviz
+       Files: <<
+               include/graphviz
+               lib/graphviz/*.la
+               lib/graphviz/guile/*.la
+               lib/graphviz/lua/*.la
+               lib/graphviz/perl/*.la
+               lib/graphviz/php/*.la
+               lib/graphviz/python/*.la
+               lib/graphviz/ruby/*.la
+               lib/graphviz/tcl/*.la
+               lib/pkgconfig/*.pc
+               lib/*.la
+       <<
+<<
+PostInstScript: %p/bin/dot -c
+DocFiles: AUTHORS COPYING ChangeLog INSTALL NEWS README
+# there are more doc files
 Description: Graph visualization software
 DescDetail: <<
 graphviz is a set of graph drawing tools for Unix or MS-Windows 
@@ -30,8 +199,21 @@
 .
 Many thanks to Jeroen Scheerder <[EMAIL PROTECTED]> for
 pointing me in the right directions.
+.
+Former maintainer(s): Thomas Kotzian <[EMAIL PROTECTED]>
+<<
+DescPackaging: <<
+configure doesn't find gtkgl+: "desktop features will not be built" for now.
+Use libiconv from fink or system?
+postinstall 'dot -c' updates config file with list of built plugins.
+Links with libtool14's libltdl.dylib, but need not build-depend on libtool14 
+because libltdl already includes ltdl.h (but added bdep for safety).
+Blindly added deps for guile, lua, ocaml, ruby, libgnomeui2, gdk-pixbuf, 
+gettext-tools because they are checked in configure,
+though some may result in optional plug-ins.
+Not sure what to do about perl/python yet...
+Other deps not listed: zlib-1.2.3 (system's)
+Missing deps: pango1-1.14.9+ (according to configure.ac)
+Optional: lua (>= 5.0)
+also checked in configure: pangocairo, gtkgl+
 <<
-License: BSD
-Maintainer: Matthias Neeracher <[EMAIL PROTECTED]>
-Homepage: http://www.research.att.com/sw/tools/graphviz/
-


-------------------------------------------------------------------------
Sponsored by: SourceForge.net Community Choice Awards: VOTE NOW!
Studies have shown that voting for your favorite open source project,
along with a healthy diet, reduces your potential for chronic lameness
and boredom. Vote Now at http://www.sourceforge.net/community/cca08
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to