Update of /cvsroot/fink/experimental/dbreiser/finkinfo
In directory sc8-pr-cvs17.sourceforge.net:/tmp/cvs-serv22504

Added Files:
        gnome-settings-daemon.info gnome-control-center.info 
        gnome-control-center.patch gnome-desktop.info 
Log Message:
some attempts at 2.22 gnome bits

--- NEW FILE: gnome-desktop.info ---
Package: gnome-desktop
Version: 2.22.0
Revision: 0.9
Depends: <<
        %N4-shlibs (>= %v-%r),
        atk1-shlibs (>= 1.20.0-1),
        audiofile-shlibs (>= 0.2.5-1),
        esound-bin (>= 0.2.38-1),
        gconf2 (>= 2.20.0-1),
        glib2-shlibs (>= 2.14.0-1),
        gnome-keyring-shlibs (>= 0.8.1-1),
        gnome-vfs2-unified (>= 1:2.20.0-1),
        gtk+2 (>= 2.12.0-1),
        libart2-shlibs (>= 2.3.16-1),
        libavahi-client3-shlibs,
        libavahi-common3-shlibs,
        libavahi-glib1-shlibs,
        libbonobo2 (>= 2.20.0-1),
        libbonoboui2 (>= 2.20.0-1),
        libgettext3-shlibs,
        libgnome2 (>= 2.20.0-1),
        libgnomeui2 (>= 2.20.0-1),
        libgnomecanvas2 (>= 2.20.0-1),
        libiconv,
        libjpeg-shlibs,
        libxml2-shlibs (>= 2.6.30-1),
        orbit2 (>= 2.14.9-1),
        pango1-xft2-ft219 (>= 1.18.2-1),
        popt-shlibs,
        rarian-compat,
        scrollkeeper,
        x11-shlibs
<<
BuildDepends: <<
        avahi-dev,
        atk1 (>= 1.20.0-1),
        audiofile (>= 0.2.5-1),
        cairo (>= 1.2-1),
        dbus-dev (>= 1.0-1),
        esound (>= 0.2.38-1),
        expat1,
        fontconfig2-dev (>= 2.4.1-1),
        freetype219 (>= 2.3.5-1),
        gconf2-dev (>= 2.20.0-1),
        gettext-bin,
        gettext-tools,
        glib2-dev (>= 2.14.0-1),
        glitz,
        gnome-doc-utils (>= 0.12.0-1),
        gnome-keyring-dev (>= 0.8.1-1),
        gnome-vfs2-unified-dev (>= 1:2.20.0-1),
        gtk+2-dev (>= 2.12.0-1),
        intltool (>= 0.36.0-1),
        libart2 (>= 2.3.16-1),
        libavahi-glib1-dev,
        libbonobo2-dev (>= 2.20.0-1),
        libbonoboui2-dev (>= 2.20.0-1),
        libgettext3-dev,
        libgnome2-dev (>= 2.20.0-1),
        libgnomeui2-dev (>= 2.20.0-1),
        libgnomecanvas2-dev (>= 2.20.0-1),
        
        libiconv-dev,
        libjpeg,
        libpng3,
        libxml2 (>= 2.6.30-1),
        libxslt-bin (>= 1.1.22-1),
        orbit2-dev (>= 2.14.9-1),
        pango1-xft2-ft219-dev (>= 1.18.2-1),
        pkgconfig (>= 0.21-1),
        popt,
        rarian-compat,
        scrollkeeper,
        startup-notification-dev (>= 0.8-1),
        x11-dev,
        xft2-dev
<<
Replaces: gnome-core (<< 2.6.0-1), control-center (<< 2.4.0-1)
Conflicts: gnome-core (<< 2.6.0-1)
Source: mirror:gnome:sources/%n/2.22/%n-%v.tar.bz2
Source-MD5: 452d4ee91b3c54aac4282f3f1e3b68f0
SetCPPFLAGS: -I%p/lib/pango-ft219/include/pango-1.0 
-I%p/lib/pango-ft219/include -I%p/lib/freetype219/include/freetype2 
-I%p/lib/freetype219/include -I%p/lib/fontconfig2/include
NoSetLDFLAGS: true
SetLDFLAGS: -L%p/lib/pango-ft219/lib -L%p/lib/freetype219/lib 
-L%p/lib/fontconfig2/lib
SetLIBS: -L%p/lib
SetCFLAGS: -Os -pipe
ConfigureParams: --mandir=%p/share/man --with-kde-datadir=%p/share 
--with-kde-docdir=%p/share/doc --disable-dependency-tracking 
--disable-scrollkeeper 
PKG_CONFIG_PATH="%p/lib/pango-ft219/lib/pkgconfig:%p/lib/fontconfig2/lib/pkgconfig:%p/lib/freetype219/lib/pkgconfig:$PKG_CONFIG_PATH"
 FREETYPE_CONFIG=%p/lib/freetype219/bin/freetype-config 
--with-gnome-distributor=fink
CompileScript: ./configure %c; make MSGFMT=%p/bin/msgfmt GMSGFMT=%p/bin/msgfmt
InstallScript: <<
        make -j1 install DESTDIR=%d
<<
PostInstScript: <<
        if [ configure = "$1" ]; then
                scrollkeeper-update -q
        fi
<<
PostRmScript: <<  
        if [ remove != "$1" ]; then
                scrollkeeper-update -q
        fi
<<
SplitOff: <<
        Package: %N4-shlibs
        Depends: <<
                atk1-shlibs (>= 1.20.0-1),
                audiofile-shlibs (>= 0.2.5-1),
                esound-bin (>= 0.2.38-1),
                gconf2 (>= 2.20.0-1),
                glib2-shlibs (>= 2.14.0-1),
                gnome-base,
                gnome-keyring-shlibs (>= 0.8.1-1),
                gnome-vfs2-unified-shlibs (>= 1:2.20.0-1),
                gtk+2 (>= 2.12.0-1),
                libart2-shlibs (>= 2.3.16-1),
                libavahi-client3-shlibs,
                libavahi-common3-shlibs,
                libavahi-glib1-shlibs,
                libbonobo2 (>= 2.20.0-1),
                libbonoboui2 (>= 2.20.0-1),
                libgettext3-shlibs,
                libgnome2 (>= 2.20.0-1),
                libgnomeui2 (>= 2.20.0-1),
                libgnomecanvas2 (>= 2.20.0-1),
                libiconv,
                libjpeg-shlibs,
                libxml2-shlibs (>= 2.6.30-1),
                orbit2 (>= 2.14.9-1),
                pango1-xft2-ft219 (>= 1.18.2-1),
                popt-shlibs,
                startup-notification-shlibs (>= 0.8-1),
                x11-shlibs
        <<
        Files: lib/lib*-2.*.dylib
        Shlibs: %p/lib/libgnome-desktop-2.2.dylib 6.0.0 %n (>= 2.20.0-1)
        DocFiles: <<
                AUTHORS COPYING* HACKING NEWS README
                ChangeLog
                desktop-docs/ChangeLog:ChangeLog.desktop-docs
                gnome-about/ChangeLog:ChangeLog.gnome-about
                libgnome-desktop/ChangeLog:ChangeLog.libgnome-desktop
                po/ChangeLog:ChangeLog.po
        <<
<<
SplitOff2: <<
        Package: %N4-dev
        Depends: %N4-shlibs (= %v-%r)
        Conflicts: %N-dev
        Replaces: %N-dev
        BuildDependsOnly: True
        Files: include lib
        DocFiles: <<
                AUTHORS COPYING* HACKING NEWS README
                ChangeLog
                desktop-docs/ChangeLog:ChangeLog.desktop-docs
                gnome-about/ChangeLog:ChangeLog.gnome-about
                libgnome-desktop/ChangeLog:ChangeLog.libgnome-desktop
                po/ChangeLog:ChangeLog.po
        <<
<<
Description: The Gnome desktop
DescDetail: <<
GNOME (GNU Network Object Model Environment) is a user-friendly
set of applications and desktop tools to be used in conjunction with a
window manager for the X Window System.  GNOME is similar in purpose and
scope to CDE and KDE, but GNOME is based completely on free
software.

GNOME Desktop provides the core icons and libraries for the gnome
desktop.
<<
DescPackaging: <<
        This should really be %n=gnome-desktop2.2-{shlibs,dev} but not gonna
        change it now.

        Bogus timestamp on foundation-members.list is harmless. See:
        http://bugzilla.gnome.org/show_bug.cgi?id=508427
<<
License: GPL/LGPL/GFDL
Maintainer: The Gnome Core Team <[EMAIL PROTECTED]>
Homepage: http://www.gnome.org/

--- NEW FILE: gnome-control-center.patch ---
diff -Nurd control-center-2.18.1.orig/libwindow-settings/Makefile.am 
control-center-2.18.1/libwindow-settings/Makefile.am
--- control-center-2.18.1.orig/libwindow-settings/Makefile.am   2007-03-18 
13:04:18.000000000 -0400
+++ control-center-2.18.1/libwindow-settings/Makefile.am        2008-03-13 
16:00:31.000000000 -0400
@@ -36,7 +36,7 @@
        gnome-window-settings-2.0.pc.in         \
        ChangeLog
 
-wms_flags = -export_dynamic -avoid-version
+wms_flags = -export_dynamic -avoid-version -module
 wmsdir = $(WM_MODULE_DIR)
 
 wms_LTLIBRARIES =                      \

--- NEW FILE: gnome-settings-daemon.info ---
Package: gnome-settings-daemon
Version: 2.22.1
Revision: 0.9
Depends: <<
        atk1-shlibs (>= 1.20.0-1),
        audiofile-shlibs (>= 0.2.5-1),
        esound-shlibs (>= 0.2.38-1),
        file-roller (>= 2.20.0-1),
        gconf2 (>= 2.20.0-1),
        glib2-shlibs (>= 2.14.0-1),
        gnome-keyring (>= 0.8.1-1),
        gnome-vfs2-unified (>= 1:2.20.0-1),
        gtk+2 (>= 2.12.0-1),
        libart2-shlibs (>= 2.3.16-1),
        libbonobo2 (>= 2.20.0-1),
        libbonoboui2 (>= 2.20.0-1),
        libcroco3-shlibs,
        libgettext3-shlibs,
        libglade2-shlibs (>= 2.6.2-1),
        libgnome2 (>= 2.20.0-1),
        libgnomeui2 (>= 2.20.0-1),
        libgnomecanvas2 (>= 2.20.0-1),
        libgsf1.114-shlibs (>= 1.14.5-1),
        libiconv,
        libjpeg-shlibs,
        librsvg2-shlibs (>= 2.18.0-1),
        libxml2-shlibs (>= 2.6.30-1),
        orbit2 (>= 2.14.9-1),
        pango1-xft2-ft219 (>= 1.18.2-1),
        passwd (>= 20051118-1),
        popt-shlibs,
        rarian-compat,
        x11-shlibs
<<
BuildDepends: <<
        atk1 (>= 1.20.0-1),
        audiofile,
        cairo (>= 1.2-1),
        dbus-dev (>= 1.0-1),
        esound (>= 0.2.38-1),
        expat1,
        fink (>= 0.24.12-1),
        fontconfig2-dev (>= 2.4.1-1),
        freetype219 (>= 2.3.5-1),
        gconf2-dev (>= 2.20.0-1),
        gettext-bin,
        gettext-tools,
        glib2-dev (>= 2.14.0-1),
        glitz,
        gnome-doc-utils (>= 0.12.0-1),
        gnome-keyring-dev (>= 0.8.1-1),
        gnome-vfs2-unified-dev (>= 1:2.20.0-1),
        gtk+2-dev (>= 2.12.0-1),
        intltool (>= 0.36.0-1),
        libart2 (>= 2.3.16-1),
        libbonobo2-dev (>= 2.20.0-1),
        libbonoboui2-dev (>= 2.20.0-1),
        libcroco3,
        libgettext3-dev,
        libglade2 (>= 2.6.2-1),
        libgnome2-dev (>= 2.20.0-1),
        libgnomeui2-dev (>= 2.20.0-1),
        libgnomecanvas2-dev (>= 2.20.0-1),
        libgsf1.114-dev (>= 1.14.5-1),
        
        libiconv-dev,
        libjpeg,
        libpng3,
        librsvg2 (>= 2.18.0-1),
        libxklavier12,
        libxml2 (>= 2.6.30-1),
        orbit2-dev (>= 2.14.9-1),
        pango1-xft2-ft219-dev (>= 1.18.2-1),
        pkgconfig (>= 0.21-1),
        popt,
        x11-dev,
        xft2-dev
<<
Source: mirror:gnome:sources/%n/2.22/%n-%v.tar.bz2
Source-MD5: 959d0d289ed81f950004fa64dbcff89d
#PatchFile: %n.patch
#PatchFile-MD5: dcbb5b6ca37e107a43d176435b3220ce
PatchScript: <<
  perl -pi -e 's/-no-undefined//' configure
  <<
ConfigureParams: <<
    --disable-scrollkeeper \
    --mandir=%p/share/man \
    --libexecdir=%p/lib/%n \
    --with-dbus-sys=%p/etc/dbus-1 \
    --with-dbus-services=%p/share/dbus-1/services \
    --disable-dependency-tracking  \
    
PKG_CONFIG_PATH="%p/lib/pango-ft219/lib/pkgconfig:%p/lib/fontconfig2/lib/pkgconfig:%p/lib/freetype219/lib/pkgconfig:$PKG_CONFIG_PATH"
 \
    FREETYPE_CONFIG=%p/lib/freetype219/bin/freetype-config
  <<
InstallScript: make -j1 install DESTDIR=%d
PostInstScript: <<
        if [ configure = "$1" ]; then
                scrollkeeper-update -q
                export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
                for s in \
                        gnome-settings-daemon \
                        apps_gnome_settings_daemon_keybindings \
                        apps_gnome_settings_daemon_screensaver \
                        desktop_gnome_font_rendering \
                ; do
                        gconftool-2 --makefile-install-rule 
%p/etc/gconf/schemas/$s.schemas >/dev/null
                done

        fi
<<
PostRmScript: <<  
        if [ remove != "$1" ]; then
                scrollkeeper-update -q
        fi
<<
ConfFiles: <<
        %p/etc/gconf/schemas/gnome-settings-daemon.schemas
        %p/etc/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas
        %p/etc/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas
        %p/etc/gconf/schemas/desktop_gnome_font_rendering.schemas
<<
DocFiles: AUTHORS COPYING ChangeLog po/ChangeLog NEWS README
DescPort: <<
        first attempt. GSD was split out of gnome-control-center
<<
Description: GNOME Settings Daemon
License: GPL
Homepage: http://www.gnome.org
Maintainer: The Gnome Core Team <[EMAIL PROTECTED]>

--- NEW FILE: gnome-control-center.info ---
Package: gnome-control-center
#upstream renames to gnome-control-center in 2.20.x
Version: 2.22.0
Revision: 1
Depends: <<
        %N2-shlibs (= %v-%r),
        audiofile-bin (>= 0.2.5-1),
        gconf2 (>= 2.20.0-1),
        gnome-applets (>= 2.19.1-1),
        gnome-desktop4-shlibs (>= 2.20.0-1),
        gnome-icon-theme (>= 2.20.0-1),
        gnome-menus,
        gnome-vfs2-unified (>= 1:2.20.0-1),
        gst-plugins-base-0.10-shlibs,
        gst-plugins-0.10,
        libbonobo2 (>= 2.20.0-1),
        libbonoboui2 (>= 2.20.0-1),
        libgnome2 (>= 2.20.0-1),
        libgnomeui2 (>= 2.20.0-1),
        libgnomecanvas2 (>= 2.20.0-1),
        libgnomekbd2 (>= 2.20.0-1),
        metacity (>= 2.20.2-1),
        orbit2 (>= 2.14.9-1),
        pango1-xft2-ft219 (>= 1.18.2-1),
        rarian-compat,
        shared-mime-info,
        x11,
        xscreensaver
<<
BuildDepends: <<
        atk1 (>= 1.20.0-1),
        audiofile (>= 0.2.5-1),
        cairo (>= 1.2-1),
        dbus-dev (>= 1.0-1),
        esound (>= 0.2.38-1),
        expat1,
        fink (>= 0.24.12-1),
        fontconfig2-dev (>= 2.4.1-1),
        freetype219 (>= 2.3.5-1),
        gconf2-dev (>= 2.20.0-1),
        gettext-tools,
        glib2-dev (>= 2.14.0-1),
        glitz,
        gnome-applets (>= 2.19.1-1),
        gnome-desktop4-dev (>= 2.19.6-1),
        gnome-doc-utils (>= 0.12.0-1),
        gnome-keyring-dev (>= 0.8.1-1),
        gnome-menus2-dev (>= 2.20.0-1),
        gnome-panel-dev (>= 2.20.0-1),
        gnome-vfs2-unified-dev (>= 1:2.20.0-1),
        gstreamer-0.10-dev,
        gst-plugins-base-0.10-dev,
        gtk+2-dev (>= 2.12.0-1),
        intltool (>= 0.36.0-1),
        libart2 (>= 2.3.16-1),
        libbonobo2-dev (>= 2.20.0-1),
        libbonoboui2-dev (>= 2.20.0-1),
        libcroco3,
        libgettext3-dev,
        libglade2 (>= 2.6.2-1),
        libgnome2-dev (>= 2.20.0-1),
        libgnomeui2-dev (>= 2.20.0-1),
        libgnomecanvas2-dev (>= 2.20.0-1),
        libgnomekbd2-dev (>= 2.20.0-1),
        libgsf1.114-dev (>= 1.14.5-1),
        libiconv-dev,
        libidl2 (>= 0.8.9-1),
        libjpeg,
        libpng3,
        librsvg2 (>= 2.18.0-1),
        libxklavier12,
        libxml2 (>= 2.6.30-1),
        metacity-dev (>= 2.20.2-1),
        orbit2-dev (>= 2.14.9-1),
        pango1-xft2-ft219-dev (>= 1.18.2-1),
        pkgconfig (>= 0.21-1),
        popt,
        startup-notification-dev (>= 0.8-1),
        x11-dev,
        xft2-dev
<<
Source: 
mirror:gnome:sources/gnome-control-center/2.22/gnome-control-center-%v.tar.bz2
Source-MD5: e6730ac4ee8b14a577978dee6c1cb88f
#PatchFile: %n.patch
#PatchFile-MD5: add30dc52ec60d691c6c3a5fa403139e
NoSetCPPFLAGS: true
SetCPPFLAGS: -D__DARWIN_UNIX03=1 -I%p/lib/pango-ft219/include/pango-1.0 
-I%p/lib/pango-ft219/include -I%p/lib/freetype219/include/freetype2 
-I%p/lib/freetype219/include -I%p/lib/fontconfig2/include -I%p/include
NoSetLDFLAGS: true
SetLDFLAGS: -L%p/lib/pango-ft219/lib -L%p/lib/freetype219/lib 
-L%p/lib/fontconfig2/lib
SetLIBS: -L%p/lib
SetCFLAGS: -Os -pipe
ConfigureParams: --enable-gstreamer=0.10 --disable-hal --mandir=%p/share/man 
--libexecdir=%p/lib/%n --disable-scrollkeeper --disable-schemas-install 
--disable-update-mimedb --disable-dependency-tracking --disable-vfs-methods 
PKG_CONFIG_PATH="%p/lib/pango-ft219/lib/pkgconfig:%p/lib/fontconfig2/lib/pkgconfig:%p/lib/freetype219/lib/pkgconfig:$PKG_CONFIG_PATH"
 FREETYPE_CONFIG=%p/lib/freetype219/bin/freetype-config F77=no
InstallScript: make -j1 install DESTDIR="%d" _ENABLE_SK=false
PostInstScript: <<
        if [ configure = "$1" ]; then
                scrollkeeper-update -q
        fi
        [ -x %p/bin/update-mime-database ] && update-mime-database 
%p/share/mime > /dev/null 2>&1 || :
<<
PostRmScript: <<  
        if [ remove != "$1" ]; then
                scrollkeeper-update -q
        fi
        [ -x %p/bin/update-mime-database ] && update-mime-database 
%p/share/mime > /dev/null 2>&1 || :
<<
SplitOff: <<
        Package: %N2-shlibs
        Depends: <<
                atk1-shlibs (>= 1.20.0-1),
                audiofile-shlibs (>= 0.2.5-1),
                esound-shlibs (>= 0.2.38-1),
                gconf2-shlibs (>= 2.20.0-1),
                glib2-shlibs (>= 2.14.0-1),
                gnome-base,
                gnome-desktop4-shlibs (>= 2.19.6-1),
                gnome-keyring-shlibs (>= 0.8.1-1),
                gnome-menus2-shlibs (>= 2.20.0-1),
                gnome-vfs2-unified-shlibs (>= 1:2.20.0-1),
                gtk+2 (>= 2.12.0-1),
                libart2-shlibs (>= 2.3.16-1),
                libbonobo2-shlibs (>= 2.20.0-1),
                libbonoboui2-shlibs (>= 2.20.0-1),
                libgettext3-shlibs,
                libglade2-shlibs (>= 2.6.2-1),
                libgnome2-shlibs (>= 2.20.0-1),
                libgnomecanvas2-shlibs (>= 2.20.0-1),
                libgnomekbd2-shlibs (>= 2.20.0-1),
                libgnomeui2-shlibs (>= 2.20.0-1),
                libgsf1.114-shlibs (>= 1.14.5-1),
                libiconv,
                libjpeg-shlibs,
                librsvg2-shlibs (>= 2.18.0-1),
                libxklavier11-shlibs,
                libxml2-shlibs (>= 2.6.30-1),
                metacity (>= 2.19.34-1),
                orbit2-shlibs (>= 2.14.9-1),
                pango1-xft2-ft219-shlibs (>= 1.18.2-1),
                popt-shlibs,
                startup-notification-shlibs (>= 0.8-1),
                x11,
                xscreensaver
        <<
        Replaces: %N
        Files: lib/libgnome-window-settings.*.dylib 
lib/window-manager-settings/*.so
        Shlibs: %p/lib/libgnome-window-settings.1.dylib 2.0.0 %N-shlibs (>= 
2.6.0-1)
        DocFiles: AUTHORS COPYING ChangeLog po/ChangeLog:ChangeLog.po NEWS 
README TODO
<<
SplitOff2: <<
        Package: %N2-dev
        BuildDependsOnly: True
        Depends: %N (= %v-%r), %N2-shlibs (= %v-%r)
        Conflicts: %N-dev
        Replaces: %N-dev, %N (<< 2.6.0-1)
        Files: include lib/libgnome-window-settings.*
        DocFiles: AUTHORS COPYING ChangeLog po/ChangeLog:ChangeLog.po NEWS 
README TODO
<<
DocFiles: AUTHORS COPYING ChangeLog po/ChangeLog:ChangeLog.po NEWS README TODO
Description: The Gnome control center
DescDetail: <<
Control-center is a configuration tool for easily
setting up your GNOME environment.

GNOME is the GNU Network Object Model Environment. That's
a fancy name, but really GNOME is a nice GUI desktop
environment.

It's a powerful, easy to configure environment which
helps to make your computer easy to use.
<<
License: GPL
Maintainer: The Gnome Core Team <[EMAIL PROTECTED]>
Homepage: http://www.gnome.org/
DescPackaging: <<
        Had to add F77=no to configure to get around a weird libtool thing
        when "fort77" is installed.

        Need to vfs-methods would need xft >= 2.1.2 but only 2.1.0 seems
        available (from X11R6).

        Old version of %N displaced a gnome-icon-theme file, so now %N
        Depends on that package so that user doesn't have that file become
        missing during %N upgrade.
<<


-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to