Update of /cvsroot/fink/dists/10.4/unstable/main/finkinfo/devel
In directory fdv4jf1.ch3.sourceforge.com:/tmp/cvs-serv27456/main/finkinfo/devel

Added Files:
        devhelp.info 
Log Message:
New devhelp version, now with webkit goodness instead of gecko choices, and 
with bonus upgrade-chaos!


--- NEW FILE: devhelp.info ---
Package: devhelp
Version: 0.23
Revision: 1
Source: mirror:gnome:sources/devhelp/%v/devhelp-%v.tar.bz2
Source-MD5: 704c0c90616aeb1c52ca3af1df93fde6
BuildDepends: <<
        atk1 (>= 1.26.0-1),
        cairo (>= 1.8.0-1),
        dbus-dev (>= 1.2.1-1),
        enchant1-dev (>= 1.4.2-1),
        expat1,
        fontconfig2-dev (>= 2.4.1-1),
        freetype219 (>= 2.3.8-2),
        gconf2-dev (>= 2.26.0-1),
        gettext-bin,
        gettext-tools,
        glib2-dev (>= 2.20.0-1),
        glitz,
        gnutls26 (>= 2.8.0-1),
        gtk+2-dev (>= 2.16.0-1),
        libgcrypt (>= 1.4.3-2),
        libgettext3-dev,
        libgpg-error,
        libiconv-dev,
        libjpeg,
        libpng3,
        libsoup2.4.1-ssl (>= 2.26.0-1),
        libtasn1-3 (>= 2.2-2),
        libwnck1.22 (>= 2.26.0-1),
        libxml2 (>= 2.6.30-1),
        libxslt,
        orbit2-dev (>= 2.14.17-1),
        pango1-xft2-ft219-dev (>= 1.24.0-1),
        pixman (>= 0.14.0-1),
        pkgconfig (>= 0.23),
        sqlite3,
        startup-notification-dev,
        webkit-1.0.2 (>= 1.1.10-1),
        x11-dev
<<
Depends: <<
        lib%N23-shlibs (>= %v-%r),
        atk1-shlibs (>= 1.26.0-1),
        cairo-shlibs (>= 1.8.0-1),
        dbus-shlibs (>= 1.2.1-1),
        desktop-file-utils (>= 0.15-1),
        enchant1-shlibs (>= 1.4.2-1),
        expat1-shlibs,
        fontconfig2-shlibs (>= 2.4.1-1),
        freetype219-shlibs (>= 2.3.8-2),
        gconf2 (>= 2.26.0-1),
        gconf2-shlibs (>= 2.26.0-1),
        glib2-shlibs (>= 2.20.0-1),
        glitz-shlibs,
        gnutls26-shlibs (>= 2.8.0-1),
        gtk+2 (>= 2.16.0-1),
        gtk+2-shlibs (>= 2.16.0-1),
        libgcrypt-shlibs (>= 1.4.3-2),
        libgettext3-shlibs,
        libgpg-error-shlibs,
        libiconv,
        libjpeg-shlibs,
        libpng3-shlibs,
        libsoup2.4.1-ssl-shlibs (>= 2.26.0-1),
        libtasn1-3-shlibs (>= 2.2-2),
        libwnck1.22-shlibs (>= 2.26.0-1),
        libxml2-shlibs (>= 2.6.30-1),
        libxslt-shlibs,
        orbit2-shlibs (>= 2.14.17-1),
        pango1-xft2-ft219-shlibs (>= 1.24.0-1),
        pixman-shlibs (>= 0.14.0-1),
        shared-mime-info (>= 0.40-1),
        sqlite3-shlibs,
        startup-notification-shlibs,
        webkit-1.0.2-shlibs (>= 1.1.10-1),
        x11
<<
Conflicts: <<
        devhelp-shlibs (<< 0.10-1101)
<<
Replaces: <<
        devhelp-shlibs (<< 0.10-1101),
        devhelp-viewer-firefox (<< 0.23-1), devhelp-viewer-mozilla (<< 0.23-1)
<<
PatchScript: <<
        perl -pi -e 's/gedit-plugin//g' misc/Makefile.in
<<
ConfigureParams: -disable-dependency-tracking --libdir=%p/lib/libdevhelp23 
--disable-schemas-install PYTHON="true but python is disabled"
InstallScript: <<
        make -j1 install DESTDIR="%d" pkgconfigdir=%p/lib/pkgconfig
        ln -s libdevhelp23/libdevhelp-1.{la,dylib} %i/lib
<<
DocFiles: AUTHORS COPYING ChangeLog NEWS README TODO
PostInstScript: <<
        . %p/bin/init.sh
        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
        gconftool-2 --makefile-install-rule 
%p/etc/gconf/schemas/devhelp.schemas >/dev/null
        [ -x %p/bin/update-mime-database ] && update-mime-database 
%p/share/mime > /dev/null 2>&1 || :
        [ -x %p/bin/update-desktop-database ] && update-desktop-database -q || :
        gtk-update-icon-cache -f -t %p/share/icons/hicolor || :
<<
PostRmScript: <<
        . %p/bin/init.sh
        [ -x %p/bin/update-mime-database ] && update-mime-database 
%p/share/mime > /dev/null 2>&1 || :
        [ -x %p/bin/update-desktop-database ] && update-desktop-database -q || :
        gtk-update-icon-cache -f -t %p/share/icons/hicolor || :
<<
ConfFiles: %p/etc/gconf/schemas/devhelp.schemas
SplitOff: <<
        Package: lib%N23-shlibs
        Depends: <<
                atk1-shlibs (>= 1.26.0-1),
                cairo-shlibs (>= 1.8.0-1),
                dbus-shlibs (>= 1.2.1-1),
                enchant1-shlibs (>= 1.4.2-1),
                expat1-shlibs,
                fontconfig2-shlibs (>= 2.4.1-1),
                freetype219-shlibs (>= 2.3.8-2),
                gconf2-shlibs (>= 2.26.0-1),
                glib2-shlibs (>= 2.20.0-1),
                glitz-shlibs,
                gnutls26-shlibs (>= 2.8.0-1),
                gtk+2-shlibs (>= 2.16.0-1),
                libgcrypt-shlibs (>= 1.4.3-2),
                libgettext3-shlibs,
                libgpg-error-shlibs,
                libiconv,
                libjpeg-shlibs,
                libpng3-shlibs,
                libsoup2.4.1-ssl-shlibs (>= 2.26.0-1),
                libtasn1-3-shlibs (>= 2.2-2),
                libwnck1.22-shlibs (>= 2.26.0-1),
                libxml2-shlibs (>= 2.6.30-1),
                libxslt-shlibs,
                orbit2-shlibs (>= 2.14.17-1),
                pango1-xft2-ft219-shlibs (>= 1.24.0-1),
                pixman-shlibs (>= 0.14.0-1),
                sqlite3-shlibs,
                startup-notification-shlibs,
                webkit-1.0.2-shlibs (>= 1.1.10-1),
                x11-shlibs
        <<
        Conflicts: <<
                devhelp-viewer-firefox-dev  (<< 0.23-1), 
devhelp-viewer-mozilla-dev (<< 0.23-1)
        <<
        Replaces: <<
                devhelp-viewer-firefox-dev  (<< 0.23-1), 
devhelp-viewer-mozilla-dev (<< 0.23-1)
        <<
        Files: lib/libdevhelp23/libdevhelp*.*.dylib
        Shlibs: %p/lib/libdevhelp23/libdevhelp-1.0.dylib 1.0.0 %n (>= 0.23-1)
        DocFiles: AUTHORS COPYING ChangeLog NEWS README TODO
<<
SplitOff2: <<
        Package: lib%N23-dev
        Depends: %N (>= %v-%r), lib%N23-shlibs (= %v-%r)
        BuildDependsOnly: true
        Files: <<
                include
                lib
        <<
        DocFiles: AUTHORS COPYING ChangeLog NEWS README TODO
<<
Description: API documentation browser for GNOME
DescDetail: <<
API documentation browser for GNOME 2. It works natively with gtk-doc 
(the API reference framework developed for GTK+ and used throughout 
GNOME for API documentation). If you use gtk-doc with your project, 
you can use Devhelp to browse the documentation.

Starting in 0.10-1101, the "devhelp" package is a place-holder to let user
pick which rendering engine to use (it's hard-coded and linked at
compile-time, not a swappable back-end). Starting in 0.23-1, uses
webkit (no gecko multiple-choice), so no need for this -viewer
back-end game.
<<
DescPackaging: <<
        Formerly maintained by Michele Garoche

        Disable gedit plugin so we don't need a dependency on gedit or
        on pygtk stuff. Could roll its own standalone pkg if wanted.

        Lots of non-backward-compatible changes to public interface of
        lib for same install_name...bury in subdir to avoid breakage.
        See: http://bugzilla.gnome.org/show_bug.cgi?id=586236

        Former viewer*-dev pkg depended on %N=%v-%r, which can block
        updates to new libversion, and not on its -shlibs, so need to
        nuke that -dev as early as possible in the packge-upgrading
        process.
<<
License: GPL
Maintainer: None <fink-de...@lists.sourceforge.net>
Homepage: http://www.gtk.org


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing 
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to