Update of /cvsroot/fink/dists/10.4/unstable/main/finkinfo/gnome
In directory fdv4jf1.ch3.sourceforge.com:/tmp/cvs-serv14786

Modified Files:
        libgksu2.info libgksu2.patch gksu.info 
Log Message:
new version


Index: gksu.info
===================================================================
RCS file: /cvsroot/fink/dists/10.4/unstable/main/finkinfo/gnome/gksu.info,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -d -r1.7 -r1.8
--- gksu.info   18 Nov 2008 20:40:33 -0000      1.7
+++ gksu.info   25 Jun 2009 16:36:10 -0000      1.8
@@ -1,76 +1,68 @@
 Package: gksu
-Version: 2.0.0
-Revision: 2
+Version: 2.0.2
+Revision: 1
 
 BuildDepends: <<
-       atk1 (>= 1.24.0-1),
-       avahi-dev,
+       atk1 (>= 1.26.0-1),
        cairo (>= 1.8-1),
        dbus-dev (>= 1.2.1-1),
        expat1,
        fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.7-7),
-       gconf2-dev (>= 2.24.0-1),
-       glib2-dev (>= 2.18.0-1),
+       freetype219 (>= 2.3.8-2),
+       gconf2-dev (>= 2.26.0-1),
+       glib2-dev (>= 2.20.0-1),
        glitz,
-       gnome-keyring-dev (>= 0.8.1-1),
-       gnome-vfs2-unified-dev (>= 1:2.24.0-1),
-       gtk+2-dev (>= 2.14.0-1),
+       gnome-keyring-dev (>= 2.26.0-1),
+       gtk+2-dev (>= 2.16.0-1),
        gtk-doc (>= 1.8-1),
        intltool40,
-       libavahi-glib1-dev,
        libgettext3-dev,
-       libgksu2-dev (>= 2.0.7-1),
+       libgksu2-dev (>= 2.0.9-1),
        libgtop2.0.7-dev (>= 2.20.2-3),
        libiconv-dev,
-       libnautilus-ext2-dev,
+       libnautilus-ext2-dev (>= 2.26.3-1),
        libpng3,
        libxml2,
-       orbit2-dev (>= 2.14.16-1),
-       pango1-xft2-ft219-dev (>= 1.22.0-4),
-       pixman (>= 0.12.0-1),
+       orbit2-dev (>= 2.14.17-1),
+       pango1-xft2-ft219-dev (>= 1.24.0-1),
+       pixman (>= 0.14.0-1),
        pkgconfig (>= 0.23),
        startup-notification-dev,
        x11-dev,
        xft2-dev
 <<
 Depends: <<
-       atk1-shlibs (>= 1.24.0-1),
+       atk1-shlibs (>= 1.26.0-1),
        cairo-shlibs (>= 1.8-1),
        dbus-shlibs (>= 1.2.1-1),
        expat1-shlibs,
        fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.7-7),
-       gconf2-shlibs(>= 2.24.0-1),
-       glib2-shlibs (>= 2.18.0-1),
+       freetype219-shlibs (>= 2.3.8-2),
+       gconf2-shlibs(>= 2.26.0-1),
+       glib2-shlibs (>= 2.20.0-1),
        glitz-shlibs,
-       gnome-keyring-shlibs (>= 0.8.1-1),
-       gnome-vfs2-unified-shlibs (>= 1:2.24.0-1),
-       gtk+2-shlibs (>= 2.14.0-1),
-       libavahi-client3-shlibs,
-       libavahi-common3-shlibs,
-       libavahi-glib1-shlibs,
+       gnome-keyring-shlibs (>= 2.26.0-1),
+       gtk+2-shlibs (>= 2.16.0-1),
        libgettext3-shlibs,
-       libgksu2 (>= 2.0.7-1),
-       libgksu2-shlibs (>= 2.0.7-1),
+       libgksu2 (>= 2.0.9-1),
+       libgksu2-shlibs (>= 2.0.9-1),
        libgtop2.0.7-shlibs (>= 2.20.2-3),
        libiconv,
-       libnautilus-ext2-shlibs,
+       libnautilus-ext2-shlibs (>= 2.26.3-1),
        libpng3-shlibs,
        libxml2-shlibs,
-       orbit2-shlibs (>= 2.14.16-1),
-       pango1-xft2-ft219-shlibs (>= 1.22.0-4),
-       pixman-shlibs (>= 0.12.0-1),
+       orbit2-shlibs (>= 2.14.17-1),
+       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
+       pixman-shlibs (>= 0.14.0-1),
        startup-notification-shlibs,
        x11
 <<
 
 Source: http://people.debian.org/~kov/%n/%n-%v.tar.gz
-Source-MD5: f517302cff6f09e4f2f312c4b618bd40
+Source-MD5: cacbcac3fc272dce01c6ea38354489e2
 SourceDirectory: %n-%v
 PatchScript: <<
        perl -pi -e 's,-lutil,,' gksu/Makefile.in
-       perl -pi -e 's/(libnautilus-extension)/\1 gnome-vfs-2.0/g' configure
 <<
 ConfigureParams: --mandir=%p/share/man --disable-dependency-tracking 
--disable-schemas-install 
PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH" 
--disable-static
 
@@ -86,9 +78,6 @@
   wrap sudo.
 <<
 DescPackaging: <<
-       Uses gnome-vfs but doesn't check for its flags (formerly
-       inherited from old libnautilus or some other direct check?)
-
        Use nautilus's self-published extensions dir instead of
        hard-coding what it was for a certain libnautilus version
 <<

Index: libgksu2.info
===================================================================
RCS file: /cvsroot/fink/dists/10.4/unstable/main/finkinfo/gnome/libgksu2.info,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -d -r1.4 -r1.5
--- libgksu2.info       13 Nov 2008 18:56:28 -0000      1.4
+++ libgksu2.info       25 Jun 2009 16:36:10 -0000      1.5
@@ -1,62 +1,93 @@
 Package: libgksu2
-Version: 2.0.7
+Version: 2.0.9
 Revision: 1
 
 BuildDepends: <<
-       atk1 (>= 1.24.0-1),
+       atk1 (>= 1.26.0-1),
+       autoconf,
+       automake1.11,
        cairo (>= 1.8-1),
        dbus-dev (>= 1.2.1-1),
        expat1,
        fink (>= 0.24.12-1),
        fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.7-7),
-       gconf2-dev (>= 2.24.0-1),
+       freetype219 (>= 2.3.8-2),
+       gconf2-dev (>= 2.26.0-1),
        gettext-bin,
        gettext-tools,
-       glib2-dev (>= 2.18.0-1),
+       glib2-dev (>= 2.20.0-1),
        glitz,
-       gnome-keyring-dev (>= 0.8.1-1),
-       gtk+2-dev (>= 2.14.0-1),
+       gnome-keyring-dev (>= 2.26.0-1),
+       gtk+2-dev (>= 2.16.0-1),
        gtk-doc (>= 1.8-1),
        intltool40,
        libgettext3-dev,
-       libglade2 (>= 2.6.3-1),
-       libgtop2.0.7-dev (>= 2.20.0-1),
+       libglade2 (>= 2.6.4-1),
+       libgtop2.0.7-dev (>= 2.20.2-3),
        libiconv-dev,
+       libtool2,
        libpng3 (>= 1.2.5-4),
        libxml2 (>= 2.6.30-1),
-       orbit2-dev (>= 2.14.16-1),
-       pango1-xft2-ft219-dev (>= 1.22.0-4),
-       pixman (>= 0.12.0-1),
+       orbit2-dev (>= 2.14.17-1),
+       pango1-xft2-ft219-dev (>= 1.24.0-1),
+       pixman (>= 0.14.0-1),
        pkgconfig (>= 0.23),
        startup-notification-dev (>= 0.9-1),
        x11-dev,
        xft2-dev
 <<
 Depends: <<
-       %N-shlibs (= %v-%r),
-       gconf2 (>= 2.24.0-1),
-       gnome-keyring (>= 0.8.1-1),
-       startup-notification-shlibs (>= 0.9-1)
+       %N-shlibs (>= %v-%r),
+       atk1-shlibs (>= 1.26.0-1),
+       cairo-shlibs (>= 1.8-1),
+       dbus-shlibs (>= 1.2.1-1),
+       expat1-shlibs,
+       fontconfig2-shlibs (>= 2.4.1-1),
+       freetype219-shlibs (>= 2.3.8-2),
+       gconf2 (>= 2.26.0-1),
+       gconf2-shlibs (>= 2.26.0-1),
+       glib2-shlibs (>= 2.20.0-1),
+       glitz-shlibs,
+       gnome-keyring (>= 2.26.0-1),
+       gtk+2-shlibs (>= 2.16.0-1),
+       libgettext3-shlibs,
+       libglade2-shlibs(>= 2.6.4-1),
+       libiconv,
+       libpng3-shlibs (>= 1.2.5-4),
+       libxml2-shlibs (>= 2.6.30-1),
+       orbit2-shlibs (>= 2.14.17-1),
+       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
+       pixman-shlibs (>= 0.14.0-1),
+       x11
 <<
 
 Source: http://people.debian.org/~kov/gksu/libgksu-%v.tar.gz
-Source-MD5: 2f2c6a21281370942ea2855553d3ad89
+Source-MD5: 6f3642c9096518e12e61cea551ac02d0
 SourceDirectory: libgksu-%v
 PatchFile: %n.patch
-PatchFile-MD5: 4b546b30f6257f62e7d635d8f27e483e
+PatchFile-MD5: 1f34a00a12197f23a5bd8fd53c0b1fa2
+PatchScript: <<
+       %{default_script}
+       touch NEWS README
+<<
 
-Replaces: gksu (<< 2.0-1)
+Replaces: gksu (<< 2.0-1), libgksu2-dev (<< 2.0.9-1)
 
 ConfigureParams: --disable-dependency-tracking --disable-static
 CompileScript: <<
 #!/bin/sh -ev
 
        export 
PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+       intltoolize --force
+       autoreconf -fi
        ./configure %c
        make
 <<
-InstallScript: make -j1 install DESTDIR=%d
+InstallScript: <<
+       make -j1 install DESTDIR=%d
+       mv %i/lib/libgksu/gksu-run-helper %i/lib/libgksu/gksu-run-helper-2
+       ln -s gksu-run-helper-2 %i/lib/libgksu/gksu-run-helper
+<<
 
 PostInstScript: <<
        if [ configure = "$1" ]; then
@@ -70,46 +101,62 @@
 SplitOff: <<
        Package: %N-shlibs
        Depends: <<
-               atk1-shlibs (>= 1.24.0-1),
+               atk1-shlibs (>= 1.26.0-1),
                cairo-shlibs (>= 1.8-1),
                dbus-shlibs (>= 1.2.1-1),
                expat1-shlibs,
                fontconfig2-shlibs (>= 2.4.1-1),
-               freetype219-shlibs (>= 2.3.7-7),
-               gconf2-shlibs (>= 2.24.0-1),
-               glib2-shlibs (>= 2.18.0-1),
+               freetype219-shlibs (>= 2.3.8-2),
+               gconf2-shlibs (>= 2.26.0-1),
+               glib2-shlibs (>= 2.20.0-1),
                glitz-shlibs,
-               gnome-keyring-shlibs (>= 0.8.1-1),
-               gtk+2-shlibs (>= 2.14.0-1),
+               gnome-keyring-shlibs (>= 2.26.0-1),
+               gtk+2-shlibs (>= 2.16.0-1),
                libgettext3-shlibs,
-               libglade2-shlibs(>= 2.6.3-1),
-               libgtop2.0.7-shlibs (>= 2.20.0-1),
+               libgtop2.0.7-shlibs (>= 2.20.2-3),
                libiconv,
                libpng3-shlibs (>= 1.2.5-4),
                libxml2-shlibs (>= 2.6.30-1),
-               orbit2-shlibs (>= 2.14.16-1),
-               pango1-xft2-ft219-shlibs (>= 1.22.0-4),
-               pixman-shlibs (>= 0.12.0-1),
+               orbit2-shlibs (>= 2.14.17-1),
+               pango1-xft2-ft219-shlibs (>= 1.24.0-1),
+               pixman-shlibs (>= 0.14.0-1),
                startup-notification-shlibs (>= 0.9-1),
                x11
        <<
-       Files: lib/libgksu2.*.dylib share/locale
+       Files: <<
+               lib/libgksu/gksu-run-helper-2
+               lib/libgksu2.*.dylib
+               share/locale
+       <<
        Shlibs: %p/lib/libgksu2.0.dylib 1.0.0 %n (>= 2.0.3-1)
        DocFiles: AUTHORS COPYING ChangeLog po/ChangeLog:ChangeLog.po
 <<
 SplitOff2: <<
        Package: %N-dev
-       Depends: %N (= %v-%r)
+       Depends: %N-shlibs (= %v-%r), %N (>= %v-%r)
        BuildDependsOnly: true
-       Files: include lib share/gtk-doc
+       Files: <<
+               include
+               lib/libgksu2.*
+               lib/pkgconfig
+               share/gtk-doc
+       <<
 <<
 
 DescPort: <<
        Fix pathname to "su" executable
 
-       ld chokes on -Wl,-O1; scrap it and use default CFLAGS
-
        Adjust pty headers and libs for darwin
+
+       po Makefile generation has bug that causes CATALOGS to be
+       blanked in the Makefile.in -> Makefile processing. Redo
+       starting at intltool to get stuff that works.
+<<
+DescPackaging: <<
+       gksu-run-helper runtime program was in -dev prior to 2.0.9-1
+       but it's used by .dylib. Rename to include libversion and move
+       into -shlibs.  Leave unversioned name (default) as symlink in
+       %N for external caller compatibility.
 <<
 Description: Library providing su and sudo functionality
 License: LGPL

Index: libgksu2.patch
===================================================================
RCS file: /cvsroot/fink/dists/10.4/unstable/main/finkinfo/gnome/libgksu2.patch,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -d -r1.3 -r1.4
--- libgksu2.patch      13 Nov 2008 18:56:28 -0000      1.3
+++ libgksu2.patch      25 Jun 2009 16:36:10 -0000      1.4
@@ -1,7 +1,19 @@
-diff -Nurd -x'*~' libgksu-2.0.7.orig/libgksu/Makefile.in 
libgksu-2.0.7/libgksu/Makefile.in
---- libgksu-2.0.7.orig/libgksu/Makefile.in     2008-05-27 20:24:09.000000000 
-0400
-+++ libgksu-2.0.7/libgksu/Makefile.in  2008-11-13 13:43:13.000000000 -0500
-@@ -275,7 +275,7 @@
+diff -Nurd -x'*~' libgksu-2.0.9.orig/libgksu/Makefile.am 
libgksu-2.0.9/libgksu/Makefile.am
+--- libgksu-2.0.9.orig/libgksu/Makefile.am     2008-05-09 13:39:55.000000000 
-0400
++++ libgksu-2.0.9/libgksu/Makefile.am  2009-06-25 10:32:59.000000000 -0400
+@@ -9,7 +9,7 @@
+ # minor -> keeps compatibility (additions to the API)
+ # micro -> no change to the API/ABI
+ libgksu2_la_LIBADD = ../libgksuui/libgksuui1.0.la
+-libgksu2_la_LDFLAGS = -version-info 0:2:0 -Wl,-O1 -lutil ${LIBGKSU_LIBS}
++libgksu2_la_LDFLAGS = -version-info 0:2:0 ${LIBGKSU_LIBS}
+ if USE_VERSION_SCRIPT
+ libgksu2_la_LDFLAGS += -Wl,--version-script=libgksu.ver
+ endif
+diff -Nurd -x'*~' libgksu-2.0.9.orig/libgksu/Makefile.in 
libgksu-2.0.9/libgksu/Makefile.in
+--- libgksu-2.0.9.orig/libgksu/Makefile.in     2009-03-04 13:56:14.000000000 
-0500
++++ libgksu-2.0.9/libgksu/Makefile.in  2009-06-25 04:49:13.000000000 -0400
+@@ -276,7 +276,7 @@
  # minor -> keeps compatibility (additions to the API)
  # micro -> no change to the API/ABI
  libgksu2_la_LIBADD = ../libgksuui/libgksuui1.0.la
@@ -10,9 +22,9 @@
        ${LIBGKSU_LIBS} $(am__append_1)
  noinst_HEADERS = defines.h
  include_HEADERS = gksu.h libgksu.h
-diff -Nurd -x'*~' libgksu-2.0.7.orig/libgksu/libgksu.c 
libgksu-2.0.7/libgksu/libgksu.c
---- libgksu-2.0.7.orig/libgksu/libgksu.c       2008-05-27 20:00:44.000000000 
-0400
-+++ libgksu-2.0.7/libgksu/libgksu.c    2008-11-13 13:19:53.000000000 -0500
+diff -Nurd -x'*~' libgksu-2.0.9.orig/libgksu/libgksu.c 
libgksu-2.0.9/libgksu/libgksu.c
+--- libgksu-2.0.9.orig/libgksu/libgksu.c       2009-03-04 13:53:02.000000000 
-0500
++++ libgksu-2.0.9/libgksu/libgksu.c    2009-06-25 11:33:30.000000000 -0400
 @@ -23,7 +23,7 @@
  #include <unistd.h>
  #include <string.h>
@@ -22,7 +34,16 @@
  #include <pwd.h>
  #include <sys/types.h>
  #include <sys/wait.h>
-@@ -1930,7 +1930,7 @@
+@@ -1932,7 +1932,7 @@
+   GQuark gksu_quark;
+   int i = 0;
+ 
+-  gchar auxcommand[] = PREFIX "/lib/" PACKAGE "/gksu-run-helper";
++  gchar auxcommand[] = PREFIX "/lib/" PACKAGE "/gksu-run-helper-2";
+ 
+   int fdpty;
+   pid_t pid;
+@@ -1976,7 +1976,7 @@
        gchar **cmd = g_malloc (sizeof(gchar*)*7);
  
        setsid();   // make us session leader
@@ -31,7 +52,7 @@
        if (context->login_shell)
        {
          cmd[i] = g_strdup ("-"); i++;
-@@ -1952,7 +1952,7 @@
+@@ -1998,7 +1998,7 @@
        if (execv (cmd[0], cmd) == -1)
        {
          fprintf (stderr,
@@ -40,10 +61,22 @@
                   strerror(errno));
        }
  
-diff -Nurd -x'*~' libgksu-2.0.7.orig/libgksuui/Makefile.in 
libgksu-2.0.7/libgksuui/Makefile.in
---- libgksu-2.0.7.orig/libgksuui/Makefile.in   2008-05-27 20:24:09.000000000 
-0400
-+++ libgksu-2.0.7/libgksuui/Makefile.in        2008-11-13 13:34:55.000000000 
-0500
-@@ -245,7 +245,7 @@
+diff -Nurd -x'*~' libgksu-2.0.9.orig/libgksuui/Makefile.am 
libgksu-2.0.9/libgksuui/Makefile.am
+--- libgksu-2.0.9.orig/libgksuui/Makefile.am   2008-05-09 13:39:54.000000000 
-0400
++++ libgksu-2.0.9/libgksuui/Makefile.am        2009-06-25 10:33:15.000000000 
-0400
+@@ -4,7 +4,7 @@
+ 
+ noinst_LTLIBRARIES = libgksuui1.0.la
+ libgksuui1_0_la_SOURCES = gksuui-dialog.c
+-libgksuui1_0_la_LDFLAGS = -Wl,-O1 `pkg-config --libs gtk+-2.0 gconf-2.0`
++libgksuui1_0_la_LDFLAGS = `pkg-config --libs gtk+-2.0 gconf-2.0`
+ 
+ noinst_HEADERS = defines.h gksuui.h gksuui-dialog.h
+ includedir = ${prefix}/include/$(PACKAGE)
+diff -Nurd -x'*~' libgksu-2.0.9.orig/libgksuui/Makefile.in 
libgksu-2.0.9/libgksuui/Makefile.in
+--- libgksu-2.0.9.orig/libgksuui/Makefile.in   2009-03-04 13:56:14.000000000 
-0500
++++ libgksu-2.0.9/libgksuui/Makefile.in        2009-06-25 04:49:14.000000000 
-0400
+@@ -246,7 +246,7 @@
  AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" -DDATA_DIR=\"$(datadir)\" 
-DPREFIX=\"$(prefix)\"
  noinst_LTLIBRARIES = libgksuui1.0.la
  libgksuui1_0_la_SOURCES = gksuui-dialog.c


------------------------------------------------------------------------------
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to