Update of /cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods
In directory 
sfp-cvsdas-3.v30.ch3.sourceforge.com:/tmp/cvs-serv14266/unstable/main/finkinfo/libs/perlmods

Modified Files:
        cairo-pm.info gnome2-canvas-pm.info gnome2-pm.info 
        gnome2-vfs-pm.info gtk2-gladexml-pm.info gtk2-pm.info 
        pango-pm.info 
Log Message:
new gnome2.28 suite to unstable


Index: pango-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/pango-pm.info,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -d -r1.2 -r1.3
--- pango-pm.info       23 Aug 2009 04:23:29 -0000      1.2
+++ pango-pm.info       7 Apr 2010 13:55:54 -0000       1.3
@@ -1,44 +1,39 @@
 Info2: <<
 Package: pango-pm%type_pkg[perl]
-Version: 1.220
+Version: 1.221
 Revision: 2
 Architecture: (%type_pkg[perl] = 581) powerpc
 Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 ###
 Depends: <<
-       cairo-pm%type_pkg[perl] (>= 1.061-1),
-       cairo-shlibs (>= 1.8-1),
-       fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.8-2),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
-       glib2-shlibs (>= 2.20.0-1),
-       libgettext3-shlibs,
-       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
-       perl%type_pkg[perl]-core,
-       x11
+       cairo-pm%type_pkg[perl] (>= 1.061-3),
+       cairo-shlibs (>= 1.8.8-3),
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
+       glib2-shlibs (>= 2.22.0-1),
+       pango1-xft2-ft219-shlibs (>= 1.24.5-4),
+       perl%type_pkg[perl]-core
 <<
 BuildDepends: <<
-       cairo (>= 1.8-1),
-       expat1,
-       extutils-depends-pm (>= 0.301-1),
+       cairo (>= 1.8.8-3),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
        fink (>= 0.24.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.8-2),
-       glib2-dev (>= 2.20.0-1),
+       fink-package-precedence (>= 0.6),
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       libgettext3-dev,
-       libiconv-dev,
-       pango1-xft2-ft219-dev (>= 1.24.0-1),
-       pixman (>= 0.14.0-1),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
 Replaces: gtk2-perl-pm, gtk2-pm%type_pkg[perl] (<< 1.220-1)
 ###
 Source: mirror:cpan:authors/id/T/TS/TSCH/Pango-%v.tar.gz
-Source-MD5: ee4884ffe436fb936b4d84ea9c9372e3
+Source-MD5: 8d257209aa11bd6c3a2beb235c2f103f
 PatchFile: %{ni}.patch
 PatchFile-MD5: 61e251c6e5bf1aebeaa7926b466f7de0
 ###
@@ -50,20 +45,24 @@
 CompileScript: <<
 #!/bin/sh -ev
 
-       export 
PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+       export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
        %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
   %{default_script}
   /bin/mv %i/share/man %i/lib/perl5/%type_raw[perl]
 <<
-DocFiles: AUTHORS ChangeLog LICENSE MAINTAINERS NEWS README
+DocFiles: AUTHORS ChangeLog* LICENSE MAINTAINERS NEWS README
 ###
-ConfigureParams: --without-guessing
+ConfigureParams: --without-guessing NOECHO= DEFINE=-MD
 ###
 Description: Pango perl module
 DescPackaging: <<
        pango-pmXXX externalized from gtk2-pmXXX as of 1.220
+
+       Enable dependency tracking so can check for coherent fink deps
 <<
 DescPort: <<
        Make sure whitespace between flags.

Index: gtk2-gladexml-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/gtk2-gladexml-pm.info,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -d -r1.10 -r1.11
--- gtk2-gladexml-pm.info       23 Aug 2009 04:23:28 -0000      1.10
+++ gtk2-gladexml-pm.info       7 Apr 2010 13:55:54 -0000       1.11
@@ -1,60 +1,57 @@
 Info2: <<
 Package: gtk2-gladexml-pm%type_pkg[perl]
 Version: 1.007
-Revision: 2
+Revision: 4
 Architecture: (%type_pkg[perl] = 581) powerpc
 Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 Type: perl (5.8.1 5.8.6 5.8.8)
 
 Depends: <<
-       atk1-shlibs (>= 1.26.0-1),
-       cairo-pm%type_pkg[perl] (>= 1.061-1),
-       cairo-shlibs (>= 1.8-1),
-       fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.8-2),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
-       glib2-shlibs (>= 2.20.0-1),
-       gtk+2-shlibs (>= 2.16.0-1),
-       gtk2-pm%type_pkg[perl] (>= 1.220-1),
-       libgettext3-shlibs,
-       libglade2-shlibs (>= 2.6.4-1),
+       atk1-shlibs (>= 1.28.0-1),
+       cairo-pm%type_pkg[perl] (>= 1.061-3),
+       cairo-shlibs (>= 1.8.8-3),
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
+       glib2-shlibs (>= 2.22.0-1),
+       gtk+2-shlibs (>= 2.18.0-1),
+       gtk2-pm%type_pkg[perl] (>= 1.221-1),
+       libglade2-shlibs (>= 2.6.4-6),
        libxml2-shlibs (>= 2.6.30-1),
-       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
-       perl%type_pkg[perl]-core,
-       x11
+       pango1-xft2-ft219-shlibs (>= 1.24.5-4),
+       perl%type_pkg[perl]-core
 <<
 BuildDepends: <<
-       atk1 (>= 1.26.0-1),
-       cairo (>= 1.8-1),
-       expat1,
-       extutils-depends-pm (>= 0.301-1),
+       atk1 (>= 1.28.0-1),
+       cairo (>= 1.8.8-3),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.8-2),
-       glib2-dev (>= 2.20.0-1),
+       fink-package-precedence (>= 0.6),
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       gtk+2-dev (>= 2.16.0-1),
-       libgettext3-dev,
-       libglade2 (>= 2.6.4-1),
-       libiconv-dev,
-       libpng3,
+       gtk+2-dev (>= 2.18.0-1),
+       libglade2 (>= 2.6.4-6),
        libxml2 (>= 2.6.30-1),
-       pango1-xft2-ft219-dev (>= 1.24.0-1),
-       pixman (>= 0.14.0-1),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
 
 Source: mirror:cpan:authors/id/T/TS/TSCH/Gtk2-GladeXML-%v.tar.gz
 Source-MD5: e6ca234e2a9f0221263acd2a593c583b
 
 NoPerlTests: true
+ConfigureParams: NOECHO= DEFINE=-MD
 CompileScript: <<
 #!/bin/sh -ev
 
-  export PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+  export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
   %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
   %{default_script}
@@ -65,6 +62,8 @@
 
 DescPackaging: <<
   Tests require x11 DISPLAY
+
+       Enable dependency tracking so can check for coherent fink deps
 <<
 DescPort: <<
        ExtUtils::Liblist::Kid can't handle -framework flags even as

Index: gnome2-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/gnome2-pm.info,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -d -r1.9 -r1.10
--- gnome2-pm.info      23 Aug 2009 04:23:28 -0000      1.9
+++ gnome2-pm.info      7 Apr 2010 13:55:54 -0000       1.10
@@ -1,7 +1,7 @@
 Info2: <<
 Package: gnome2-pm%type_pkg[perl]
 Version: 1.042
-Revision: 5
+Revision: 7
 Architecture: (%type_pkg[perl] = 581) powerpc
 Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 Type: perl (5.8.1 5.8.6 5.8.8)
@@ -10,77 +10,71 @@
 Source-MD5: eb7b624114e45e54e022a633ffc1cce6
 
 BuildDepends: <<
-       atk1 (>= 1.26.0-1),
-       audiofile,
-       cairo (>= 1.8-1),
-       dbus-dev (>= 1.2.1-1),
-       esound,
-       expat1,
-       extutils-depends-pm (>= 0.301-1),
+       atk1 (>= 1.28.0-1),
+       cairo (>= 1.8.8-3),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.8-2),
-       gconf2-dev (>= 2.26.0-1),
-       glib2-dev (>= 2.20.0-1),
+       fink-package-precedence (>= 0.6),
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
+       gconf2-dev (>= 2.28.0-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       gnome-keyring-dev (>= 2.26.0-1),
-       gnome-vfs2-unified-dev (>= 1:2.24.1-1),
-       gtk+2-dev (>= 2.16.0-1),
+       gnome-keyring-dev (>= 2.28.0-1),
+       gnome-vfs2-unified-dev (>= 1:2.24.2-1),
+       gtk+2-dev (>= 2.18.0-1),
        libart2,
-       libbonobo2-dev (>= 2.24.1-1),
-       libbonoboui2-dev (>= 2.24.1-1),
-       libgettext3-dev,
-       libgnome2-dev (>= 2.26.0-1),
-       libgnomecanvas2-dev (>= 2.26.0-1),
-       libgnomeui2-dev (>= 2.24.1-1),
-       libiconv-dev,
-       libpng3,
+       libbonobo2-dev (>= 2.24.2-1),
+       libbonoboui2-dev (>= 2.24.2-1),
+       libgettext8-dev,
+       libgnome2-dev (>= 2.28.0-1),
+       libgnomecanvas2-dev (>= 2.26.0-3),
+       libgnomeui2-dev (>= 2.24.2-1),
        libxml2 (>= 2.6.30-1),
-       orbit2-dev (>= 2.14.17-1),
-       pango1-xft2-ft219-dev (>= 1.24.0-1),
-       pixman (>= 0.14.0-1),
-       libpng3,
+       orbit2-dev (>= 2.14.17-2),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
        popt,
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
 Depends: <<
-       atk1-shlibs (>= 1.26.0-1),
-       cairo-shlibs (>= 1.8-1),
-       fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.8-2),
-       gconf2-shlibs (>= 2.26.0-1),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
-       glib2-shlibs (>= 2.20.0-1),
-       gnome-keyring-shlibs (>= 2.26.0-1),
-       gnome-vfs2-unified-shlibs (>= 1:2.24.1-1),
-       gnome2-canvas-pm%type_pkg[perl] (>= 1.002-6),
-       gnome2-vfs-pm%type_pkg[perl] (>= 1.081-3),
-       gtk+2-shlibs (>= 2.16.0-1),
-       gtk2-pm%type_pkg[perl] (>= 1.220-1),
+       atk1-shlibs (>= 1.28.0-1),
+       cairo-shlibs (>= 1.8.8-3),
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
+       gconf2-shlibs (>= 2.28.0-1),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
+       glib2-shlibs (>= 2.22.0-1),
+       gnome-keyring-shlibs (>= 2.28.0-1),
+       gnome-vfs2-unified-shlibs (>= 1:2.24.2-1),
+       gnome2-canvas-pm%type_pkg[perl] (>= 1.002-8),
+       gnome2-vfs-pm%type_pkg[perl] (>= 1.081-5),
+       gtk+2-shlibs (>= 2.18.0-1),
+       gtk2-pm%type_pkg[perl] (>= 1.221-1),
        libart2-shlibs,
-       libbonobo2-shlibs (>= 2.24.1-1),
-       libbonoboui2-shlibs (>= 2.24.1-1),
-       libgettext3-shlibs,
-       libgnome2-shlibs (>= 2.26.0-1),
-       libgnomecanvas2-shlibs (>= 2.26.0-1),
-       libgnomeui2-shlibs (>= 2.24.1-1),
-       libiconv,
+       libbonobo2-shlibs (>= 2.24.2-1),
+       libbonoboui2-shlibs (>= 2.24.2-1),
+       libgnome2-shlibs (>= 2.28.0-1),
+       libgnomecanvas2-shlibs (>= 2.26.0-3),
+       libgnomeui2-shlibs (>= 2.24.2-1),
        libxml2-shlibs (>= 2.6.30-1),
-       orbit2-shlibs (>= 2.14.17-1),
-       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
+       orbit2-shlibs (>= 2.14.17-2),
+       pango1-xft2-ft219-shlibs (>= 1.24.5-4),
        perl%type_pkg[perl]-core,
        popt-shlibs,
        x11
 <<
 
 NoPerlTests: true
+ConfigureParams: NOECHO= DEFINE=-MD
 CompileScript: <<
 #!/bin/sh -ev
 
-  export PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+  export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
   %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
   %{default_script}
@@ -94,6 +88,8 @@
 DescPackaging: <<
   Disable tests because they want an active GNOME session and they
   can't deal with changed HOME env var during sudo
+
+       Enable dependency tracking so can check for coherent fink deps
 <<
 DescPort: <<
        ExtUtils::Liblist::Kid can't handle -framework flags even as

Index: gnome2-canvas-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/gnome2-canvas-pm.info,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -d -r1.9 -r1.10
--- gnome2-canvas-pm.info       23 Aug 2009 04:23:28 -0000      1.9
+++ gnome2-canvas-pm.info       7 Apr 2010 13:55:54 -0000       1.10
@@ -1,7 +1,7 @@
 Info2: <<
 Package: gnome2-canvas-pm%type_pkg[perl]
 Version: 1.002
-Revision: 7
+Revision: 9
 Architecture: (%type_pkg[perl] = 581) powerpc
 Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 Type: perl (5.8.1 5.8.6 5.8.8)
@@ -10,49 +10,46 @@
 Source-MD5: 93405a987ba4bbd03c2f91592b88f5cb
 
 BuildDepends: <<
-       atk1 (>= 1.26.0-1),
-       cairo (>= 1.8-1),
-       expat1,
-       extutils-depends-pm (>= 0.301-1),
+       atk1 (>= 1.28.0-1),
+       cairo (>= 1.8.8-3),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.8-2),
-       glib2-dev (>= 2.20.0-1),
+       fink-package-precedence (>= 0.6),
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       gtk+2-dev (>= 2.16.0-1),
+       gtk+2-dev (>= 2.18.0-1),
        libart2,
-       libgettext3-dev,
-       libgnomecanvas2-dev (>= 2.26.0-1),
-       libiconv-dev,
-       libpng3,
-       pango1-xft2-ft219-dev (>= 1.24.0-1),
-       pixman (>= 0.14.0-1),
+       libgnomecanvas2-dev (>= 2.26.0-3),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
 Depends: <<
-       atk1-shlibs (>= 1.26.0-1),
-       cairo-shlibs (>= 1.8-1),
-       fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.8-2),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
-       glib2-shlibs (>= 2.20.0-1),
-       gtk+2-shlibs (>= 2.16.0-1),
-       gtk2-pm%type_pkg[perl] (>= 1.220-1),
+       atk1-shlibs (>= 1.28.0-1),
+       cairo-shlibs (>= 1.8.8-3),
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
+       glib2-shlibs (>= 2.22.0-1),
+       gtk+2-shlibs (>= 2.18.0-1),
+       gtk2-pm%type_pkg[perl] (>= 1.221-1),
        libart2-shlibs,
-       libgettext3-shlibs,
-       libgnomecanvas2-shlibs (>= 2.26.0-1),
-       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
-       perl%type_pkg[perl]-core,
-       x11
+       libgnomecanvas2-shlibs (>= 2.26.0-3),
+       pango1-xft2-ft219-shlibs (>= 1.24.5-4),
+       perl%type_pkg[perl]-core
 <<
 
+ConfigureParams: NOECHO= DEFINE=-MD
 CompileScript: <<
 #!/bin/sh -ev
 
-  export PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+  export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
   %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
   %{default_script}
@@ -74,6 +71,9 @@
        http://rt.cpan.org/Ticket/Display.html?id=32883
        ) so letting it alone.
 <<
+DescPackaging: <<
+       Enable dependency tracking so can check for coherent fink deps
+<<
 Description: Perl bindings for libgnomecanvas2
 License: LGPL
 Maintainer: The Gnome Core Team <fink-gnome-c...@lists.sourceforge.net>

Index: gtk2-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/gtk2-pm.info,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -d -r1.16 -r1.17
--- gtk2-pm.info        23 Aug 2009 04:23:28 -0000      1.16
+++ gtk2-pm.info        7 Apr 2010 13:55:54 -0000       1.17
@@ -1,50 +1,44 @@
 Info2: <<
 Package: gtk2-pm%type_pkg[perl]
-Version: 1.220
+Version: 1.221
 Revision: 2
 Architecture: (%type_pkg[perl] = 581) powerpc
 Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 ###
 Depends: <<
-       atk1-shlibs (>= 1.26.0-1),
-       cairo-pm%type_pkg[perl] (>= 1.061-1),
-       cairo-shlibs (>= 1.8-1),
-       fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.8-2),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
-       glib2-shlibs (>= 2.20.0-1),
-       gtk+2-shlibs (>= 2.16.0-1),
-       libgettext3-shlibs,
-       pango-pm%type_pkg[perl] (>= 1.220-1),
-       pango1-xft2-ft219-shlibs (>= 1.24.0-1),
-       perl%type_pkg[perl]-core,
-       x11
+       atk1-shlibs (>= 1.28.0-1),
+       cairo-pm%type_pkg[perl] (>= 1.061-3),
+       cairo-shlibs (>= 1.8.8-3),
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
+       glib2-shlibs (>= 2.22.0-1),
+       gtk+2-shlibs (>= 2.18.0-1),
+       pango-pm%type_pkg[perl] (>= 1.221-1),
+       pango1-xft2-ft219-shlibs (>= 1.24.5-4),
+       perl%type_pkg[perl]-core
 <<
 BuildDepends: <<
-       atk1 (>= 1.26.0-1),
-       cairo (>= 1.8-1),
-       expat1,
-       extutils-depends-pm (>= 0.301-1),
+       atk1 (>= 1.28.0-1),
+       cairo (>= 1.8.8-3),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
        fink (>= 0.24.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.8-2),
-       glib2-dev (>= 2.20.0-1),
+       fink-package-precedence (>= 0.6),
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       gtk+2-dev (>= 2.16.0-1),
-       libgettext3-dev,
-       libiconv-dev,
-       libpng3,
-       pango1-xft2-ft219-dev (>= 1.24.0-1),
-       pixman (>= 0.14.0-1),
+       gtk+2-dev (>= 2.18.0-1),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
 Replaces: gtk2-perl-pm
 ###
 Source: mirror:cpan:authors/id/T/TS/TSCH/Gtk2-%v.tar.gz
-Source-MD5: 76e4f3ca3f9f80dc15a35ff9b88f736d
+Source-MD5: ba412049d10978ed802b98976f6adaa9
 PatchFile: %{ni}.patch
 PatchFile-MD5: fbfef09ed87bce52a543f2ac9f60fc86
 ###
@@ -56,20 +50,24 @@
 CompileScript: <<
 #!/bin/sh -ev
 
-       export 
PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+       export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
        %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
   %{default_script}
   /bin/mv %i/share/man %i/lib/perl5/%type_raw[perl]
 <<
-DocFiles: AUTHORS ChangeLog LICENSE MAINTAINERS NEWS README TODO
+DocFiles: AUTHORS ChangeLog* LICENSE MAINTAINERS NEWS README TODO
 ###
-ConfigureParams: --without-guessing
+ConfigureParams: --without-guessing NOECHO= DEFINE=-MD
 ###
 Description: Gtk2:: perl module
 DescPackaging: <<
        pango-pmXXX externalized from gtk2-pmXXX as of 1.220
+
+       Enable dependency tracking so can check for coherent fink deps
 <<
 DescPort: <<
        Fix -I flag ordering, same as glib-pmXXX. See:

Index: cairo-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/cairo-pm.info,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -d -r1.5 -r1.6
--- cairo-pm.info       23 Aug 2009 04:23:28 -0000      1.5
+++ cairo-pm.info       7 Apr 2010 13:55:54 -0000       1.6
@@ -1,36 +1,32 @@
 Info2: <<
 Package: cairo-pm%type_pkg[perl]
 Version: 1.061
-Revision: 2
+Revision: 4
 Architecture: (%type_pkg[perl] = 581) powerpc
-Distribution:  (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
+Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 ###
 Depends: <<
-       freetype219-shlibs (>= 2.3.8-2),
-       cairo-shlibs (>= 1.8-1),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
-       perl%type_pkg[perl]-core,
-       x11
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
+       cairo-shlibs (>= 1.8.8-3),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
+       perl%type_pkg[perl]-core
 <<
 BuildDepends: <<
-       cairo (>= 1.8-1),
-       expat1,
-       extutils-depends-pm (>= 0.301-1),
+       cairo (>= 1.8.8-3),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
        fink (>= 0.24.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.8-2),
-       glib2-dev (>= 2.20.0-1),
+       fink-package-precedence (>= 0.6),
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       libgettext3-dev,
-       libiconv-dev,
-       libpng3,
-       pango1-xft2-ft219-dev (>= 1.24.0-1),
-       pixman (>= 0.14.0-1),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
        test-number-delta-pm%type_pkg[perl],
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
 ###
 Source: mirror:cpan:authors/id/T/TS/TSCH/Cairo-%v.tar.gz
@@ -42,8 +38,10 @@
 CompileScript: <<
 #!/bin/sh -ev
 
-       export 
PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+       export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
        %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
   %{default_script}
@@ -51,12 +49,14 @@
 <<
 DocFiles: ChangeLog LICENSE NEWS README TODO
 ###
-ConfigureParams: --without-guessing
+ConfigureParams: --without-guessing DEFINE=-MD
 ###
 DescPackaging: <<
        Can use Font::FreeType if found at runtime (not required for
        operation, not sure what functionality is lost without it),
        but that module is badly broken so it's not in fink.
+
+       Enable dependency tracking so can check for coherent fink deps
 <<
 Description: Cairo:: perl module
 ###

Index: gnome2-vfs-pm.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/libs/perlmods/gnome2-vfs-pm.info,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -d -r1.7 -r1.8
--- gnome2-vfs-pm.info  23 Aug 2009 04:23:28 -0000      1.7
+++ gnome2-vfs-pm.info  7 Apr 2010 13:55:54 -0000       1.8
@@ -1,7 +1,7 @@
 Info2: <<
 Package: gnome2-vfs-pm%type_pkg[perl]
 Version: 1.081
-Revision: 3
+Revision: 6
 Architecture: (%type_pkg[perl] = 581) powerpc
 Distribution: (%type_pkg[perl] = 581) 10.4, (%type_pkg[perl] = 586) 10.4, 
(%type_pkg[perl] = 586) 10.5
 Type: perl (5.8.1 5.8.6 5.8.8)
@@ -12,32 +12,31 @@
 PatchFile-MD5: c7312a4656afaaf3ab767d21945f069d
 
 BuildDepends: <<
-       dbus-dev (>= 1.2.1-1),
-       extutils-depends-pm (>= 0.301-1),
+       extutils-depends-pm (>= 0.302-1),
        extutils-pkgconfig-pm (>= 1.12-1),
        fink (>= 0.24.12-1),
-       gconf2-dev (>= 2.26.0-1),
-       glib2-dev (>= 2.20.0-1),
-       gnome-vfs2-unified-dev (>= 1:2.24.1-1),
-       libgettext3-dev,
-       libiconv-dev,
-       orbit2-dev (>= 2.14.17-1),
+       fink-package-precedence (>= 0.6),
+       gconf2-dev (>= 2.28.0-1),
+       glib2-dev (>= 2.22.0-1),
+       gnome-vfs2-unified-dev (>= 1:2.24.2-1),
        pkgconfig (>= 0.23)
 <<
 Depends: <<
-       gconf2-shlibs (>= 2.26.0-1),
-       glib-pm%type_pkg[perl] (>= 1.221-1),
+       gconf2-shlibs (>= 2.28.0-1),
+       glib-pm%type_pkg[perl] (>= 1.222-1),
        glib2-shlibs (>= 2.20.0-1),
-       gnome-vfs2-unified-shlibs (>= 1:2.24.1-1),
-       libgettext3-shlibs,
+       gnome-vfs2-unified-shlibs (>= 1:2.24.2-1),
        perl%type_pkg[perl]-core
 <<
 
+ConfigureParams: NOECHO= DEFINE=-MD
 CompileScript: <<
 #!/bin/sh -ev
 
-  export PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
+  export 
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
   %{default_script}
+
+       fink-package-precedence --depfile-ext='\.d' .
 <<
 InstallScript: <<
        %{default_script}
@@ -51,6 +50,9 @@
        Fix -I flag ordering, same as glib-pmXXX. See:
        http://rt.cpan.org/Ticket/Display.html?id=32883
 <<
+DescPackaging: <<
+       Enable dependency tracking so can check for coherent fink deps
+<<
 Description: Perl bindings for gnome-vfs2
 License: LGPL
 Maintainer: The Gnome Core Team <fink-gnome-c...@lists.sourceforge.net>


------------------------------------------------------------------------------
Download Intel&#174; Parallel Studio Eval
Try the new software tools for yourself. Speed compiling, find bugs
proactively, and fine-tune applications for parallel performance.
See why Intel Parallel Studio got high marks during beta.
http://p.sf.net/sfu/intel-sw-dev
_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to