Update of /cvsroot/fink/dists/10.4/unstable/main/finkinfo/editors
In directory sfp-cvsdas-3.v30.ch3.sourceforge.com:/tmp/cvs-serv22384

Modified Files:
        abiword-docs.info abiword.info abiword.patch 
Log Message:
new version


Index: abiword-docs.info
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/editors/abiword-docs.info,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -d -r1.3 -r1.4
--- abiword-docs.info   15 Nov 2009 06:20:08 -0000      1.3
+++ abiword-docs.info   18 May 2010 07:31:48 -0000      1.4
@@ -1,60 +1,22 @@
 Package: abiword-docs
-Version: 2.6.8
+Version: 2.8.4
 Revision: 1
-Architecture: i386, powerpc
 Depends: <<
        abiword (>= %v-1)
 <<
 BuildDepends: <<
-       abiword (>= %v-1),
-       atk1 (>= 1.24.0-1),
-       audiofile,
-       cairo (>= 1.8-1),
-       dbus-dev (>= 1.2.1-1),
-       enchant1-dev (>= 1.4.2-1),
-       esound,
-       expat1,
-       fink (>= 0.24.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.7-7),
-       fribidi (>= 0.10.9-1),
-       fribidi-dev,
-       gconf2-dev (>= 2.24.0-1),
-       gettext-bin,
-       gettext-tools,
-       glib2-dev (>= 2.18.0-1),
-       glitz,
-       gnome-keyring-dev (>= 2.26.0-1),
-       gnome-vfs2-unified-dev (>= 1:2.24.0-1),
-       gtk+2-dev (>= 2.14.0-1),
-       libart2,
-       libbonobo2-dev (>= 2.24.0-1),
-       libbonoboui2-dev (>= 2.24.0-1),
-       libgettext3-dev,
-       libglade2 (>= 2.6.3-1),
-       libgnome2-dev (>= 2.24.0-1),
-       libgnomecanvas2-dev (>= 2.20.1.1-2),
-       libgnomeprint2.2-dev (>= 2.18.5-1),
-       libgnomeprintui2.2-dev (>= 2.18.3-1),
-       libgnomeui2-dev (>= 2.24.0-1),
-       libgsf1.114-gnome-dev (>= 1.14.11-1),
-       libgsf1.114-dev (>= 1.14.11-1),
-       libiconv-dev,
-       libpng3,
-       libwv1,
-       libxml2 (>= 2.6.30-1),
-       orbit2-dev (>= 2.14.16-1),
-       pango1-xft2-ft219-dev (>= 1.22.4-1),
-       pixman (>= 0.12.0-1),
-       pkgconfig (>= 0.23),
-       popt,
-       x11-dev,
-       xft2-dev
+       abiword2.8-dev (>= %v-1),
+       pkgconfig (>= 0.23)
 <<
 Source: http://www.abiword.com/downloads/abiword/%v/source/%n-%v.tar.gz
-Source-MD5: 5698c79cfa179f4b15c82a699d11a309
+Source-MD5: f0902e3e45d3e5a9916997e3347bc491
 NoSetMAKEFLAGS: true
 SetMAKEFLAGS: -j1
+PatchScript: <<
+       cp %p/lib/pkgconfig/abiword-2.8.pc .
+       perl -ni -e 'print unless /^Requires/' abiword-2.8.pc
+<<
+ConfigureParams: PKG_CONFIG_PATH="%b"
 InstallScript: <<
        make -j1 install DESTDIR=%d
 <<
@@ -62,9 +24,9 @@
        As of 2.6.8, -docs is separated into its own package. The
        helpfile build system needs to be able to run abiword.
 
-       Because abiword.pc is accessed, need all the indirect deps of
-       abiword even though we're not compiling anything at
-       all. Thanks pkg-config:(
+       Because abiword's .pc is accessed, would need all the indirect
+       deps of abiword even though we're not compiling anything. Only
+       need a variable from the .pc, so make local copy with no deps.
 <<
 Description: Helpfiles for AbiWord
 License: GPL

Index: abiword.patch
===================================================================
RCS file: 
/cvsroot/fink/dists/10.4/unstable/main/finkinfo/editors/abiword.patch,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -d -r1.4 -r1.5
--- abiword.patch       27 Mar 2009 02:11:03 -0000      1.4
+++ abiword.patch       18 May 2010 07:31:48 -0000      1.5
@@ -1,6 +1,6 @@
-diff -Nurd -x'*~' abiword-2.6.8.orig/abiword.sh abiword-2.6.8/abiword.sh
---- abiword-2.6.8.orig/abiword.sh      1969-12-31 19:00:00.000000000 -0500
-+++ abiword-2.6.8/abiword.sh   2009-03-20 16:24:26.000000000 -0400
+diff -Nurd -x'*~' abiword-2.8.4.orig/abiword.sh abiword-2.8.4/abiword.sh
+--- abiword-2.8.4.orig/abiword.sh      1969-12-31 19:00:00.000000000 -0500
++++ abiword-2.8.4/abiword.sh   2010-05-16 16:08:41.000000000 -0400
 @@ -0,0 +1,14 @@
 +#!/bin/sh
 +# make symlinks in ~/.fonts for applettf .ttf files
@@ -16,15 +16,88 @@
 +done
 +# launch abiword
 +exec @PREFIX@/bin/abiword.exe "$@"
-diff -Nurd -x'*~' abiword-2.6.8.orig/src/af/util/xp/ut_go_file.cpp 
abiword-2.6.8/src/af/util/xp/ut_go_file.cpp
---- abiword-2.6.8.orig/src/af/util/xp/ut_go_file.cpp   2009-03-04 
13:15:22.000000000 -0500
-+++ abiword-2.6.8/src/af/util/xp/ut_go_file.cpp        2009-03-20 
16:20:16.000000000 -0400
-@@ -1594,7 +1594,7 @@
+diff -Nurd -x'*~' abiword-2.8.4.orig/configure abiword-2.8.4/configure
+--- abiword-2.8.4.orig/configure       2010-04-14 17:50:56.000000000 -0400
++++ abiword-2.8.4/configure    2010-05-17 14:05:10.000000000 -0400
+@@ -16598,10 +16598,10 @@
+ { $as_echo "$as_me:$LINENO: checking for platform and toolkit" >&5
+ $as_echo_n "checking for platform and toolkit... " >&6; }
+ case ${host_os} in
+-  *darwin*)
+-    PLATFORM="unix"
+-    TOOLKIT="cocoa"
+-    ;;
++#  *darwin*)
++#    PLATFORM="unix"
++#    TOOLKIT="cocoa"
++#    ;;
+   *mingw*)
+     PLATFORM="win"
+     TOOLKIT="win"
+@@ -19036,13 +19036,13 @@
+    test "$enable_dynamic" == "yes"; then
+       # link plugins to work around gcc visibility issue with
+       # derived classes in dlopened modules
+-      PLUGIN_LIBS="$PLUGIN_LIBS "'-L${top_builddir}/src'" 
-labiword-$ABIWORD_SERIES"
++      PLUGIN_LIBS="$PLUGIN_LIBS 
"'${top_builddir}/src'"/libabiword-$ABIWORD_SERIES.la"
+ elif test "$TOOLKIT" == "win"; then
+       PLUGIN_CFLAGS="$PLUGIN_CFLAGS "'-D_WIN32_IE=0x0501 
-D_WIN32_WINNT=0x0500'
+       # link plugins to the executable so they can be loaded
+       PLUGIN_LIBS="$PLUGIN_LIBS "'-L${top_builddir}/src -labiword'
+ elif test "$TOOLKIT" == "cocoa" ; then
+-      PLUGIN_LIBS="$PLUGIN_LIBS "'-L${top_builddir}/src'" 
-labiword-$ABIWORD_SERIES"
++      PLUGIN_LIBS="$PLUGIN_LIBS 
"'${top_builddir}/src'"/libabiword-$ABIWORD_SERIES.la"
+ fi
  
-       if (browser == NULL) {
-               static char const * const browsers[] = {
--                      "sensible-browser",     /* debian */
-+                      "open",                 /* OS X */
-                       "epiphany",             /* primary gnome */
-                       "galeon",               /* secondary gnome */
-                       "encompass",
+ 
+diff -Nurd -x'*~' abiword-2.8.4.orig/libabiword.pc.in 
abiword-2.8.4/libabiword.pc.in
+--- abiword-2.8.4.orig/libabiword.pc.in        2010-04-14 17:50:18.000000000 
-0400
++++ abiword-2.8.4/libabiword.pc.in     2010-05-17 23:57:21.000000000 -0400
+@@ -9,6 +9,6 @@
+ Name: abiwo...@abiword_series@
+ Description: AbiWord word processing library
+ Version: @VERSION@
+-Requires: @ABIWORD_REQUIRED_PKGS@
++Requires: glib-2.0 gobject-2.0 libgsf-1 gtk+-2.0
+ Libs: -L${libdir} -labiwo...@abiword_series@
+ Cflags: -I${includedir}/abiwo...@abiword_series@
+diff -Nurd -x'*~' abiword-2.8.4.orig/src/Makefile.in 
abiword-2.8.4/src/Makefile.in
+--- abiword-2.8.4.orig/src/Makefile.in 2010-04-14 17:51:20.000000000 -0400
++++ abiword-2.8.4/src/Makefile.in      2010-05-17 19:12:44.000000000 -0400
+@@ -502,7 +502,7 @@
+ 
+ libabiword_2_8_la_LDFLAGS = $(DEPS_LIBS) --no-undefined -avoid-version \
+       -export-dynamic $(am__append_6)
+-libabiword_2_8_la_LIBADD = $(opt_libs) plugins/libplugins.la \
++libabiword_2_8_la_LIBADD_ltlibs = $(opt_libs) plugins/libplugins.la \
+       text/fmt/xp/libxp.la text/ptbl/xp/libxp.la \
+       wp/ap/$(TOOLKIT)/lib$(TOOLKIT).la wp/ap/xp/libxp.la \
+       wp/impexp/$(TOOLKIT)/lib$(TOOLKIT).la wp/impexp/xp/libxp.la \
+@@ -511,6 +511,7 @@
+       af/util/$(PLATFORM)/lib$(PLATFORM).la af/util/xp/libxp.la \
+       af/ev/$(TOOLKIT)/lib$(TOOLKIT).la af/ev/xp/libxp.la \
+       $(am__append_7)
++libabiword_2_8_la_LIBADD = $(libabiword_2_8_la_LIBADD_ltlibs) $(PNG_LIBS) 
-L/usr/X11R6/lib -lX11
+ 
+ # headers are GTK only.
+ @toolkit_gtk_t...@libabiword_2_8_includedir = @ABIWORD_HEADERSDIR@
+@@ -520,7 +521,7 @@
+ @TOOLKIT_GTK_TRUE@    af/xap/gtk/xap_UnixTableWidget.h
+ 
+ libabiword_2_8_la_DEPENDENCIES = \
+-      $(libabiword_2_8_la_LIBADD)
++      $(libabiword_2_8_la_LIBADD_ltlibs)
+ 
+ libabiword_2_8_la_SOURCES = \
+       $(top_srcdir)/src/wp/main/xp/abi_ver.cpp \
+diff -Nurd -x'*~' abiword-2.8.4.orig/src/af/ev/gtk/ev_UnixKeyboard.cpp 
abiword-2.8.4/src/af/ev/gtk/ev_UnixKeyboard.cpp
+--- abiword-2.8.4.orig/src/af/ev/gtk/ev_UnixKeyboard.cpp       2010-04-14 
17:50:11.000000000 -0400
++++ abiword-2.8.4/src/af/ev/gtk/ev_UnixKeyboard.cpp    2010-05-17 
03:51:26.000000000 -0400
+@@ -23,6 +23,7 @@
+ #include <gdk/gdk.h>
+ #include <gdk/gdkx.h>
+ #include <gdk/gdkkeysyms.h>
++#include <X11/keysym.h>
+ 
+ #include "ut_types.h"
+ #include "ut_assert.h"

Index: abiword.info
===================================================================
RCS file: /cvsroot/fink/dists/10.4/unstable/main/finkinfo/editors/abiword.info,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -d -r1.10 -r1.11
--- abiword.info        9 Sep 2009 11:03:31 -0000       1.10
+++ abiword.info        18 May 2010 07:31:48 -0000      1.11
@@ -1,110 +1,76 @@
 Package: abiword
-Version: 2.6.8
-Revision: 3
+Version: 2.8.4
+Revision: 1
 Depends: <<
+       %n2.8-shlibs (>= %v-%r),
        applesystemfonts,
-       atk1-shlibs (>= 1.24.0-1),
-       cairo-shlibs (>= 1.8-1),
-       enchant1-shlibs (>= 1.4.2-1),
-       fontconfig2-shlibs (>= 2.4.1-1),
-       freetype219-shlibs (>= 2.3.7-7),
+       atk1-shlibs (>= 1.28.0-1),
+       cairo-shlibs (>= 1.8.8-3),
+       enchant1-shlibs (>= 1.6.0-1),
+       fontconfig2-shlibs (>= 2.8.0-4),
+       freetype219-shlibs (>= 2.3.12-1),
        fribidi-shlibs (>= 0.10.9-1),
-       gconf2 (>= 2.24.0-1),
-       gconf2-shlibs (>= 2.24.0-1),
-       glib2-shlibs (>= 2.18.0-1),
-       gnome-vfs2-unified-shlibs (>= 1:2.24.0-1),
-       gtk+2-shlibs (>= 2.14.0-1),
-       libart2-shlibs,
-       libbonobo2-shlibs (>= 2.24.0-1),
-       libbonoboui2-shlibs (>= 2.24.0-1),
-       libgettext3-shlibs,
-       libglade2-shlibs (>= 2.6.3-1),
-       libgnome2-shlibs (>= 2.24.0-1),
-       libgnomecanvas2-shlibs (>= 2.20.1.1-2),
-       libgnomeprint2.2-shlibs (>= 2.18.5-1),
-       libgnomeprintui2.2-shlibs (>= 2.18.3-1),
-       libgnomeui2-shlibs (>= 2.24.0-1),
-       libgsf1.114-gnome-shlibs (>= 1.14.11-1),
-       libgsf1.114-shlibs (>= 1.14.11-1),
-       libiconv,
-       libpng3-shlibs,
-       libwv1-shlibs,
+       glib2-shlibs (>= 2.22.0-1),
+       gtk+2-shlibs (>= 2.18.0-1),
+       libgoffice-0.8-shlibs,
+       libgsf1.114-shlibs (>= 1.14.18-1),
+       libjpeg-shlibs,
+       libpng14-shlibs,
+       librsvg2-shlibs (>= 2.26.0-3),
+       libwv3-shlibs,
        libxml2-shlibs (>= 2.6.30-1),
-       orbit2-shlibs (>= 2.14.16-1),
-       pango1-xft2-ft219-shlibs (>= 1.22.4-1),
-       popt-shlibs,
-       x11-shlibs
+       pango1-xft2-ft219-shlibs (>= 1.24.5-4),
+       x11
 <<
 BuildDepends: <<
        applesystemfonts,
-       atk1 (>= 1.24.0-1),
-       audiofile,
-       cairo (>= 1.8-1),
-       dbus-dev (>= 1.2.1-1),
-       enchant1-dev (>= 1.4.2-1),
-       esound,
-       expat1,
+       atk1 (>= 1.28.0-1),
+       cairo (>= 1.8.8-3),
+       enchant1-dev (>= 1.6.0-1),
        fink (>= 0.24.12-1),
-       fontconfig2-dev (>= 2.4.1-1),
-       freetype219 (>= 2.3.7-7),
+       fink-package-precedence,
+       fontconfig2-dev (>= 2.8.0-4),
+       freetype219 (>= 2.3.12-1),
        fribidi (>= 0.10.9-1),
-       fribidi-dev,
-       gconf2-dev (>= 2.24.0-1),
+       fribidi-dev (>= 0.10.9-1),
        gettext-bin,
        gettext-tools,
-       glib2-dev (>= 2.18.0-1),
+       glib2-dev (>= 2.22.0-1),
        glitz,
-       gnome-keyring-dev (>= 2.26.0-1),
-       gnome-vfs2-unified-dev (>= 1:2.24.0-1),
-       gtk+2-dev (>= 2.14.0-1),
-       libart2,
-       libbonobo2-dev (>= 2.24.0-1),
-       libbonoboui2-dev (>= 2.24.0-1),
-       libgettext3-dev,
-       libglade2 (>= 2.6.3-1),
-       libgnome2-dev (>= 2.24.0-1),
-       libgnomecanvas2-dev (>= 2.20.1.1-2),
-       libgnomeprint2.2-dev (>= 2.18.5-1),
-       libgnomeprintui2.2-dev (>= 2.18.3-1),
-       libgnomeui2-dev (>= 2.24.0-1),
-       libgsf1.114-gnome-dev (>= 1.14.11-1),
-       libgsf1.114-dev (>= 1.14.11-1),
+       gtk+2-dev (>= 2.18.0-1),
+       libgsf1.114-dev (>= 1.14.18-1),
        libiconv-dev,
-       libpng3,
-       libwv1,
+       libpng14,
+       libwv3,
        libxml2 (>= 2.6.30-1),
-       orbit2-dev (>= 2.14.16-1),
-       pango1-xft2-ft219-dev (>= 1.22.4-1),
-       pixman (>= 0.12.0-1),
+       pango1-xft2-ft219-dev (>= 1.24.5-4),
+       pixman (>= 0.16.0-1),
        pkgconfig (>= 0.23),
-       popt,
-       x11-dev,
-       xft2-dev
+       x11-dev
 <<
-BuildConflicts: libgoffice, libgoffice-0.6
 Recommends: abiword-docs
+Source: http://www.abiword.com/downloads/%n/%v/source/%n-%v.tar.gz
+Source-MD5: f782ecb8e07d07ec179f7a143353cc29
+GCC: 4.0
 PatchFile: %n.patch
-PatchFile-MD5: 293e295814d941c57d907cbe56f85fea
+PatchFile-MD5: 55bbfb33492ef97ce2d01d042a8404bf
 PatchScript: <<
        sed 's|@PREFIX@|%p|g' < %{PatchFile} | patch -p1
-       perl -pi -e 
's,(GOFFICE_VERSION_REQUIRED=).*,${1}99999.FORCE.NONDETECT,' configure
        perl -pi -e 's/-pedantic//g' configure
-<<
-Description: Open-source word processor
-DescUsage: <<
-
-       Default help viewer might be your OS X default web-browser.
-       Setting the BROWSER environment variable to an alternate
-       command (for example, "firefox" if you have %p/bin/firefox)
-       might override.
+       perl -pi -e 's/--no-undefined/-no-undefined/' src/Makefile.in
+       perl -pi -e 's/enable_dynamic/enable_shared/g' configure
 
-       As of 2.6.8, the docs are separated into their own package
-       (abiword-docs).
+       # --{enable,disable}-collab-backend-* flags are broken:
+       # --disable acts like --enable, and not passing still
+       # autodetects. So make it fail.
+       perl -pi -e 's/^(collab_.*req)=".*"/\1="FORCE.NONDETECT"/' configure
+<<
+ConfigureParams: <<
+       --without-gnomevfs --with-gio \
+       --enable-dependency-tracking \
+       --disable-static \
+       
PKG_CONFIG_PATH="%p/lib/glib-2.0/pkgconfig-strict:%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
 <<
-Source: http://www.abiword.com/downloads/%n/%v/source/%n-%v.tar.gz
-Source-MD5: fab04d8ef999c303f720197adf261310
-GCC: 4.0
-ConfigureParams: --enable-gnomevfs --enable-gnomeui --disable-Cocoa 
--with-libxml2 --disable-gucharmap --without-epath 
--disable-dependency-tracking 
PKG_CONFIG_PATH="%p/lib/fontconfig2/lib/pkgconfig:$PKG_CONFIG_PATH"
 NoSetMAKEFLAGS: true
 SetMAKEFLAGS: -j1
 SetCPPFLAGS: -I%p/lib/fontconfig2/include
@@ -114,6 +80,7 @@
 CompileScript: <<
        ./configure %c
        make
+       fink-package-precedence --prohibit-bdep %n2.8-dev .
 <<
 InstallScript: <<
        make -j1 install DESTDIR=%d
@@ -125,9 +92,43 @@
        # install abiword startup script
        install -m 755 abiword.sh %i/bin/abiword
 <<
+DocFiles: BUILD.TXT BiDiReadme.txt COPYING COPYRIGHT.TXT README
+SplitOff: <<
+       Package: %N2.8-shlibs
+       Depends: <<
+               atk1-shlibs (>= 1.28.0-1),
+               cairo-shlibs (>= 1.8.8-3),
+               enchant1-shlibs (>= 1.6.0-1),
+               fontconfig2-shlibs (>= 2.8.0-4),
+               freetype219-shlibs (>= 2.3.12-1),
+               fribidi-shlibs (>= 0.10.9-1),
+               glib2-shlibs (>= 2.22.0-1),
+               gtk+2-shlibs (>= 2.18.0-1),
+               libgoffice-0.8-shlibs,
+               libgsf1.114-shlibs (>= 1.14.18-1),
+               libjpeg-shlibs,
+               libpng14-shlibs,
+               librsvg2-shlibs (>= 2.26.0-3),
+               libwv3-shlibs,
+               libxml2-shlibs (>= 2.6.30-1),
+               pango1-xft2-ft219-shlibs (>= 1.24.5-4),
+               x11
+       <<
+       Files: lib/libabiword-2.8.dylib
+       Shlibs: %p/lib/libabiword-2.8.dylib 0.0.0 %n (>= 2.8.4-1)
+       DocFiles: BUILD.TXT BiDiReadme.txt COPYING COPYRIGHT.TXT README
+<<
+SplitOff2: <<
+       Package: %N2.8-dev
+       Depends: %N2.8-shlibs
+       Files: <<
+               include
+               lib/pkgconfig
+               lib/libabiword-2.8.la
+       <<
+       DocFiles: BUILD.TXT BiDiReadme.txt COPYING COPYRIGHT.TXT README
+<<
 DescPort: <<
-       Patch to use 'open' as default help browser (set the BROWSER
-       environment variable to override this).
        abiword is a wrapper script that sets up symlinks to applettf
        fonts in ~/.fonts, so that abiword will find them.
 
@@ -137,18 +138,61 @@
        Got a bunch of realloc diagnostics while reading fonts (font
        pulldown or format menu) but oh well. See:
        http://bugzilla.abisource.com/show_bug.cgi?id=12024
+
+       Patch missing #include and lib for directly used x11. See:
+       http://bugzilla.abisource.com/show_bug.cgi?id=12734
+
+       libtool autoconf is enable-dynamic not enable-shared, so
+       configure was never auto-detecting that we were a
+       shared-binaries platform. See:
+       http://bugzilla.abisource.com/show_bug.cgi?id=12737
+
+       Link against libtool lib rather than using -l and -L to
+       resolve build-time library. See:
+       http://bugzilla.abisource.com/show_bug.cgi?id=12738
 <<
 DescPackaging: <<
-       Uses libgnomeprint directly. Fixed in 2.7 dev cycle.
+       Use modern gio instead of crufty obsolete gnomevfs.
 
-       Wants gucharmap (old, unavailable in fink) not gucharmap-2.
-       Fixed in 2.7 dev cycle.
+       Tons of global-before-local -I flag ordering. Not fixing for
+       now (known no interference from installed %n, unknown about
+       unexpected external that masks source). Would have to adjust
+       lots of Makefile.in, and fix recursively-defined/expanded
+       variables in configure)
 
-       Wants libgoffice-0.4 (old, unavailable in fink) not
-       libgoffice-0.6. Instead builds a local lib fragment, so need
-       to make we don't accidentally see the installed wrong-version.
+       Fix typo in forcing symbol resolution when building lib. See:
+       http://bugzilla.abisource.com/show_bug.cgi?id=12732
+
+       Add missing png direct dependency for lib. See:
+       http://bugzilla.abisource.com/show_bug.cgi?id=12731
+
+       Build as runtime binary (not framework) for x11 gui (not aqua)
+       because that's how this %n has apways been and that's how our
+       gtk is. See:
+       http://bugzilla.abisource.com/show_bug.cgi?id=12733
+
+       Shared library is tied to package major-minor by name (no
+       unversioned link) so not caring that it doesn't use proper c_v
+       values..."that's how upstream must want it"
+
+       Clean up .pc Requires: don't need entries that are not
+       #included by public .h to avoid publishing useless and hidden
+       InheritedBuildDepends.
+
+       Going with default plugins set for now. Disable collaboration
+       backends...untested, need to avoid autodetect.
+<<
+Description: Open-source word processor
+DescUsage: <<
+       Default help viewer might be your OS X default web-browser.
+       Setting the BROWSER environment variable to an alternate
+       command (for example, "firefox" if you have %p/bin/firefox)
+       might override.
+
+       As of 2.6.8, the docs are separated into their own package
+       (abiword-docs). Viewing is via gtk service, which may not
+       detect your html-viewer properly at this time.
 <<
-DocFiles: BUILD.TXT BiDiReadme.txt COPYING COPYRIGHT.TXT CREDITS.TXT README.TXT
 License: GPL
 Homepage: http://www.abiword.com
 Maintainer: The Gnome Core Team <fink-gnome-c...@lists.sourceforge.net>


------------------------------------------------------------------------------

_______________________________________________
Fink-commits mailing list
Fink-commits@lists.sourceforge.net
http://news.gmane.org/gmane.os.apple.fink.cvs

Reply via email to