> On Aug 21, 2017, at 13:10, TheSin <the...@southofheaven.org> wrote:
> 
> I’d like to recommend this change to the current code base for future perl, 
> and to fix the PDB, I’m just not sure if it works on all fink supported 
> version of OS X (macOS).
> 
> diff --git a/perlmod/Fink/VirtPackage.pm b/perlmod/Fink/VirtPackage.pm
> index 2019c74b..cde125bf 100644
> --- a/perlmod/Fink/VirtPackage.pm
> +++ b/perlmod/Fink/VirtPackage.pm
> @@ -47,7 +47,8 @@ our $VERSION = 1.00;
> # you must not print to STDOUT.
> 
> use Fink::Config qw($config $basepath $distribution);
> -use POSIX qw(uname tmpnam);
> +use POSIX qw(uname);
> +use File::Temp qw(:POSIX);
> use Fink::Status;
> use File::Basename;
> use Fink::FinkVersion;
> 
> ---
> TS
> http://www.southofheaven.org/
> Life begins and ends with chaos, live between the chaos!
> 

I believe 10.10-12 all use the same Perl (I’m not sure about 10.13), so I think 
we just need to make sure that 10.9 is OK with it.

—akh
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
fink-core mailing list
fink-core@lists.sourceforge.net
List archive:
http://news.gmane.org/gmane.os.apple.fink.core
Subscription management:
https://lists.sourceforge.net/lists/listinfo/fink-core

Reply via email to