While running El Capitan, and after updating to Xcode 8, I could not run fink 
because I get warning;
WARNING: Xcode.app version (8.0) and Xcode Command Line Tools version (7.3) are 
not compatible.

Apple claims this is false warning with fink

Apple Closed my Bug saying that the CLI works, and that the issue is with fink.
If this is not the case, please let them know.  I do not a system to test CLI 
as I am now on Sierra on my machines.

Bug ID 28356077 - Xcode 8 installs on El Capitan.

Apple Developer Relations   13-Oct-2016 05:13 PM
Engineering has provided the following information regarding this issue:

Please know that there is not incompatibility.  You should report the issue to 
fink and request that fink remove the incorrect warning.

Here is my bug report:
The App Store allows installation of Xcode 8 on El Capitan system resulting in 
incompatible Command Line Tools.  One cannot install  

Steps to Reproduce:
1. install Xcode 8 on El Capitan system from App Store.

Expected Results:
compilation from Command Line.

Actual Results:
WARNING: Xcode.app version (8.0) and Xcode Command Line Tools version (7.3)
are not compatible.
You may experience build errors.

Xcode 8.0  (8A218a)

Installer should prevent installation, or bring up dialog explaining 
incompatible Command Line Tools (and others) will result if installation 

MacOS El Capitan 10.11.6

Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
Fink-users mailing list
List archive:
Subscription management:

Reply via email to