On 10.08.2018 10:26, liviuslivius wrote:

i have tested this more detailed.
I have created TCP socket on computer and TCP client on Android side and 
communication was established.
But when i have tried by firedac(and client lib) it did not even tried.
Then i have changed in firebird.conf

         Providers = Engine12, Remote

then another success :)

Certainly - it's very hard to have remote connections w/o appropriate provider ;)

i have connected from Delphi Firedac on Android to remote firebird without any 
issues (numerics are ok).
Tested with newer Firebird WI-V3.0.4.32954 Firebird 3.0 and then with same 
version Firebird- to remove possibility that something was bad 
only with older version.

It looks like client library work ok
only Firebird server on Android have some bug releated to Numerics.

Yes - seems to be so.
Please add a ticket to the tracker - I will try to find time to reproduce and fix it.

PS. What does isql do with numerics when started on Android?

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Firebird-Devel mailing list, web interface at 

Reply via email to