Hello Hellen

 


The Problem are not on the server 3.0.1, this is working well!! The problem
are on the server 2.5.5.26952 and 2.5.6.27020!


 


When you querying the MON$STATEMENTS table, the active statements are not
shows a transaction-id and not a timestamp, These columns are allwas Zero /
NULL!


 


I'm programing a Program thats shows whats going on in the monitoring
tables, and yesterday i realized that the active statements are not showed.
This problem also existst with the Sinatica-Monitor (may you now this
software)


 


Best Regards


Gregor


 


 


Von: firebird-support@yahoogroups.com
[mailto:firebird-support@yahoogroups.com] 
Gesendet: Freitag, 16. September 2016 03:47
An: firebird-support@yahoogroups.com
Betreff: Re: [firebird-support] Problem querying MON$STATEMENTS table


 


  


Friday, September 16, 2016, 12:02:28 AM, Gregor Kobler wrote:


> I have a problem when i querying the MON$STATEMENS table on Server 2.5.5
and also 2.5.6
>
> Do the follow steps:
> 
> Open a connection to the database, then start a transaction an open
> a table to show the content and keep it open/active Now run the
> follow statement "SELECT * FROM MON$STATEMENS"
> 
> The Row that should shows you the active query are not correct!
Open output set <> active query.
Once the SELECT statement has finished fetching, its state is no
longer active...it becomes "idle".
> 
> The column MON$STATE shows allways Zero
Zero is the "idle" state. It will go to "active" (1) next time the
cursor restarts.


> and also the columns
> MON$TRANSACTION_ID and MON$TIMESTAMP are also allways NULL!!


Both of those fields will hold values only while the statement is
active. A statement that is idle is not active.
> 
> The Server 3.0.1 are not affected on this problem.
>
> The follow databases with charset are not working (tested) NONE, WIN1250,
ISO8859_1
> 
> A database with charset WIN1251 are working well.
>
> May this could be a bug.


If you suspect a bug, please try to give a proper description of what
you mean by "working well" and "not working" and post it, with your
statements, to firebird-devel. Also give the build number of the
snapshot that you refer to as "Server 3.0.1", as these snapshots are
refreshed very regularly.


The core devs have been working pretty solidly on Fb3 bugs over the
past 3 months so you should be able to discover what kind of a problem
(if any) you are actually observing and whether it is fixed.


HB






  • [firebird-s... gregorkob...@yahoo.com [firebird-support]
    • Re: [f... Helen Borrie hele...@iinet.net.au [firebird-support]
      • Re... monteropetronila...@yahoo.com [firebird-support]
      • AW... 'Gregor Kobler' g...@gksoft.ch [firebird-support]
        • ... Dimitry Sibiryakov s...@ibphoenix.com [firebird-support]
          • ... 'Gregor Kobler' g...@gksoft.ch [firebird-support]
          • ... 'Gregor Kobler' g...@gksoft.ch [firebird-support]
        • ... Dmitry Yemanov dim...@users.sourceforge.net [firebird-support]
          • ... 'Gregor Kobler' g...@gksoft.ch [firebird-support]
            • ... Dimitry Sibiryakov s...@ibphoenix.com [firebird-support]
              • ... 'Gregor Kobler' g...@gksoft.ch [firebird-support]
                • ... fabia...@itbizolutions.com.au [firebird-support]
                • ... hv...@users.sourceforge.net [firebird-support]
                • ... fabia...@itbizolutions.com.au [firebird-support]

Reply via email to