Call off the hounds, I've solved it. 

it turns out that when the a nested movie clip called the variables it
called them from one nesting level up, and I'd coded that as
_root.variable. Flash was fine with that in testing, but the browser
plugin didn't like it. Once I'd changed the path to _parent.variable it
was all working as planned again.

Odd that the Test Movie behaved differently though.

-- 
Rick Lecoat

--
Original message:
Received from Rick Lecoat on 5/7/06 at 13:23

>Back again.
>
>Well, I *thought* it was working...
>What do you guys make of a situation where a movie works in Test Movie
>but not from the web server? Here's the deal:
>
>variable1:String populates textField1  (initial value = " ")
>variable2:String populates textField2  (initial value = " ")
>variable3:String populates textField3  (initial value = "Click on a
>photo to learn more about the person")
>
>Variables get changed according to button clicks.
>
>When I run Test Movie, the first two fields are blank as expected and
>the third one shows the instructional text as set by the variable.
>
>Publish... upload to server... clear browser cache to be sure...
>But now:
>
>first two fields say "ee"
>third one says "undefined"
>
>Clicking buttons, which should rewrite the text fields, also gives the
>same results.
>
>For the record, text fields one and two just have uppercase glyphs
>embedded, whilst the third one has upper and lower case, numerals, and
>punctuation. These choices are appropriate to the text that the button
>clicks will enter.
>
>So, why will it work in test but not online?
>Heeeelp!
>
>-- 
>Rick Lecoat


_______________________________________________
Flashcoders@chattyfig.figleaf.com
To change your subscription options or search the archive:
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders

Brought to you by Fig Leaf Software
Premier Authorized Adobe Consulting and Training
http://www.figleaf.com
http://training.figleaf.com

Reply via email to